summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-04-04 21:25:44 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-04-04 21:26:15 -0700
commita0103a61da2ab319aa179ff4b6e6f638f2b7fa7c (patch)
treee0d0502eae91ece9789b630c948c60fd93945966 /dev-lang/rust
parentapp-arch/p7zip: avoid using EROOT in src_install (diff)
downloadgentoo-a0103a61da2ab319aa179ff4b6e6f638f2b7fa7c.tar.gz
gentoo-a0103a61da2ab319aa179ff4b6e6f638f2b7fa7c.tar.bz2
gentoo-a0103a61da2ab319aa179ff4b6e6f638f2b7fa7c.zip
dev-lang/rust: fix 1.51.0 bootstrap with same version
Closes: https://bugs.gentoo.org/779970 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-lang/rust')
-rw-r--r--dev-lang/rust/files/1.51.0-bootstrap-panic.patch43
-rw-r--r--dev-lang/rust/rust-1.51.0.ebuild1
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-lang/rust/files/1.51.0-bootstrap-panic.patch b/dev-lang/rust/files/1.51.0-bootstrap-panic.patch
new file mode 100644
index 000000000000..529d5a1f402f
--- /dev/null
+++ b/dev-lang/rust/files/1.51.0-bootstrap-panic.patch
@@ -0,0 +1,43 @@
+From 31c93397bde772764cda3058e16f9cef61895090 Mon Sep 17 00:00:00 2001
+From: Joshua Nelson <jyn514@gmail.com>
+Date: Mon, 8 Feb 2021 22:51:21 -0500
+Subject: [PATCH] Use format string in bootstrap panic instead of a string
+ directly
+
+This fixes the following warning when compiling with nightly:
+
+```
+warning: panic message is not a string literal
+ --> src/bootstrap/builder.rs:1515:24
+ |
+1515 | panic!(out);
+ | ^^^
+ |
+ = note: `#[warn(non_fmt_panic)]` on by default
+ = note: this is no longer accepted in Rust 2021
+help: add a "{}" format string to Display the message
+ |
+1515 | panic!("{}", out);
+ | ^^^^^
+help: or use std::panic::panic_any instead
+ |
+1515 | std::panic::panic_any(out);
+ | ^^^^^^^^^^^^^^^^^^^^^^
+```
+---
+ src/bootstrap/builder.rs | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/bootstrap/builder.rs b/src/bootstrap/builder.rs
+index f1a160250dbe1..0f5fcb4af400d 100644
+--- a/src/bootstrap/builder.rs
++++ b/src/bootstrap/builder.rs
+@@ -1490,7 +1490,7 @@ impl<'a> Builder<'a> {
+ for el in stack.iter().rev() {
+ out += &format!("\t{:?}\n", el);
+ }
+- panic!(out);
++ panic!("{}", out);
+ }
+ if let Some(out) = self.cache.get(&step) {
+ self.verbose(&format!("{}c {:?}", " ".repeat(stack.len()), step));
diff --git a/dev-lang/rust/rust-1.51.0.ebuild b/dev-lang/rust/rust-1.51.0.ebuild
index 630a170abe58..45c23455773f 100644
--- a/dev-lang/rust/rust-1.51.0.ebuild
+++ b/dev-lang/rust/rust-1.51.0.ebuild
@@ -135,6 +135,7 @@ PATCHES=(
"${FILESDIR}"/1.47.0-libressl.patch
"${FILESDIR}"/1.47.0-ignore-broken-and-non-applicable-tests.patch
"${FILESDIR}"/1.49.0-gentoo-musl-target-specs.patch
+ "${FILESDIR}"/1.51.0-bootstrap-panic.patch
)
S="${WORKDIR}/${MY_P}-src"