summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathy Vanvoorden <mathy@vanvoorden.be>2017-11-07 23:35:49 +0100
committerCraig Andrews <candrews@gentoo.org>2017-12-20 14:47:16 -0500
commit6632bce8e713fab5f91ca75798ba9ae546f58c16 (patch)
treeb4dcf1d6401af7418a82a46e4acc2e95d4001387 /dev-lang/solidity/solidity-0.4.18.ebuild
parentnet-p2p/go-ethereum: Cleanup old version (diff)
downloadgentoo-6632bce8e713fab5f91ca75798ba9ae546f58c16.tar.gz
gentoo-6632bce8e713fab5f91ca75798ba9ae546f58c16.tar.bz2
gentoo-6632bce8e713fab5f91ca75798ba9ae546f58c16.zip
dev-lang/solidity: version bump to 0.4.18
The previous patch needed to build valid releases is no longer needed since upstream now provides valid release tarballs. A new patch is added to remove the download and static compile of jsoncpp during the build. The dependency has been fixed on 1.8.1 since the code does not compile with a newer version. Upstream actually fixes to 1.7.7 but that version isn't in the tree and 1.8.1 works. Closes: https://bugs.gentoo.org/629998 Closes: https://bugs.gentoo.org/627940 Package-Manager: Portage-2.3.8, Repoman-2.3.4
Diffstat (limited to 'dev-lang/solidity/solidity-0.4.18.ebuild')
-rw-r--r--dev-lang/solidity/solidity-0.4.18.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-lang/solidity/solidity-0.4.18.ebuild b/dev-lang/solidity/solidity-0.4.18.ebuild
new file mode 100644
index 000000000000..8a36d44a9092
--- /dev/null
+++ b/dev-lang/solidity/solidity-0.4.18.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+MY_P="${PN}_${PV}"
+
+DESCRIPTION="The Solidity Contract-Oriented Programming Language"
+HOMEPAGE="https://github.com/ethereum/solidity"
+SRC_URI="https://github.com/ethereum/${PN}/releases/download/v${PV}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="=dev-libs/jsoncpp-1.8.1:=
+ >=dev-libs/boost-1.54:=
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ # Upstream downloads and builds a static jsoncpp during build
+ "${FILESDIR}"/${P}-fix-cmake-external-jsoncpp.diff
+)
+
+src_configure() {
+ local mycmakeargs=(
+ "-DBoost_USE_STATIC_LIBS=off"
+ )
+
+ cmake-utils_src_configure
+}