summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-09-22 15:17:28 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-09-22 15:18:27 +0200
commitd2db2a52517cd974644c04fea991131457661f1d (patch)
tree4a64b3d8509806810c9a7fdd29b70b83120efc16 /dev-lang/typescript
parentdev-lang/typescript: take the maintainership (diff)
downloadgentoo-d2db2a52517cd974644c04fea991131457661f1d.tar.gz
gentoo-d2db2a52517cd974644c04fea991131457661f1d.tar.bz2
gentoo-d2db2a52517cd974644c04fea991131457661f1d.zip
dev-lang/typescript: update to EAPI 8; misc tweaks
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang/typescript')
-rw-r--r--dev-lang/typescript/typescript-4.5.4-r1.ebuild (renamed from dev-lang/typescript/typescript-4.8.3.ebuild)38
-rw-r--r--dev-lang/typescript/typescript-4.5.4.ebuild39
-rw-r--r--dev-lang/typescript/typescript-4.8.3-r1.ebuild39
3 files changed, 58 insertions, 58 deletions
diff --git a/dev-lang/typescript/typescript-4.8.3.ebuild b/dev-lang/typescript/typescript-4.5.4-r1.ebuild
index 647f4a120aee..02196457057b 100644
--- a/dev-lang/typescript/typescript-4.8.3.ebuild
+++ b/dev-lang/typescript/typescript-4.5.4-r1.ebuild
@@ -1,39 +1,39 @@
# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
DESCRIPTION="Superset of JavaScript with optional static typing, classes and interfaces"
-HOMEPAGE="https://www.typescriptlang.org"
+HOMEPAGE="https://www.typescriptlang.org/
+ https://github.com/microsoft/TypeScript/"
SRC_URI="https://registry.npmjs.org/${PN}/-/${P}.tgz"
+S="${WORKDIR}"/package
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~ppc64"
-DEPEND=""
RDEPEND="net-libs/nodejs"
BDEPEND=">=net-libs/nodejs-16[npm]"
-S="${WORKDIR}/package"
-
src_compile() {
- # nothing to compile here
+ # Skip, nothing to compile here.
:
}
src_install() {
- npm \
- --audit false \
- --color false \
- --foreground-scripts \
- --global \
- --offline \
- --omit dev \
- --prefix "${ED}"/usr \
- --progress false \
- --verbose \
- install "${DISTDIR}/${P}".tgz || die "npm install failed"
-
- einstalldocs
+ local myopts=(
+ --audit false
+ --color false
+ --foreground-scripts
+ --global
+ --offline
+ --omit dev
+ --prefix "${ED}"/usr
+ --progress false
+ --verbose
+ )
+ npm ${myopts[@]} install "${DISTDIR}"/${P}.tgz || die "npm install failed"
+
+ dodoc *.md *.txt
}
diff --git a/dev-lang/typescript/typescript-4.5.4.ebuild b/dev-lang/typescript/typescript-4.5.4.ebuild
deleted file mode 100644
index dcbc71b38d89..000000000000
--- a/dev-lang/typescript/typescript-4.5.4.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="Superset of JavaScript with optional static typing, classes and interfaces"
-HOMEPAGE="https://www.typescriptlang.org"
-SRC_URI="https://registry.npmjs.org/${PN}/-/${P}.tgz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~ppc64"
-
-DEPEND=""
-RDEPEND="net-libs/nodejs"
-BDEPEND=">=net-libs/nodejs-16[npm]"
-
-S="${WORKDIR}/package"
-
-src_compile() {
- # nothing to compile here
- :
-}
-
-src_install() {
- npm \
- --audit false \
- --color false \
- --foreground-scripts \
- --global \
- --offline \
- --omit dev \
- --prefix "${ED}"/usr \
- --progress false \
- --verbose \
- install "${DISTDIR}/${P}".tgz || die "npm install failed"
-
- einstalldocs
-}
diff --git a/dev-lang/typescript/typescript-4.8.3-r1.ebuild b/dev-lang/typescript/typescript-4.8.3-r1.ebuild
new file mode 100644
index 000000000000..02196457057b
--- /dev/null
+++ b/dev-lang/typescript/typescript-4.8.3-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Superset of JavaScript with optional static typing, classes and interfaces"
+HOMEPAGE="https://www.typescriptlang.org/
+ https://github.com/microsoft/TypeScript/"
+SRC_URI="https://registry.npmjs.org/${PN}/-/${P}.tgz"
+S="${WORKDIR}"/package
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+
+RDEPEND="net-libs/nodejs"
+BDEPEND=">=net-libs/nodejs-16[npm]"
+
+src_compile() {
+ # Skip, nothing to compile here.
+ :
+}
+
+src_install() {
+ local myopts=(
+ --audit false
+ --color false
+ --foreground-scripts
+ --global
+ --offline
+ --omit dev
+ --prefix "${ED}"/usr
+ --progress false
+ --verbose
+ )
+ npm ${myopts[@]} install "${DISTDIR}"/${P}.tgz || die "npm install failed"
+
+ dodoc *.md *.txt
+}