summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2016-11-02 00:02:20 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2016-11-02 00:58:05 +0100
commit86130ebff14e48c20543aeeb6c1cb369d56e6b53 (patch)
tree61fbc570914b9b4705823451abc5857805ee5926 /dev-lang/vala/vala-0.34.2.ebuild
parentnet-misc/gnome-online-miners: cleanup old revisions (diff)
downloadgentoo-86130ebff14e48c20543aeeb6c1cb369d56e6b53.tar.gz
gentoo-86130ebff14e48c20543aeeb6c1cb369d56e6b53.tar.bz2
gentoo-86130ebff14e48c20543aeeb6c1cb369d56e6b53.zip
dev-lang/vala: version bump 0.32.1 → 0.34.2
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-lang/vala/vala-0.34.2.ebuild')
-rw-r--r--dev-lang/vala/vala-0.34.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-lang/vala/vala-0.34.2.ebuild b/dev-lang/vala/vala-0.34.2.ebuild
new file mode 100644
index 000000000000..ed1e769ba459
--- /dev/null
+++ b/dev-lang/vala/vala-0.34.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="Compiler for the GObject type system"
+HOMEPAGE="https://wiki.gnome.org/Projects/Vala"
+
+LICENSE="LGPL-2.1"
+SLOT="0.34"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/vala-common-${PV}
+"
+DEPEND="${RDEPEND}
+ !${CATEGORY}/${PN}:0
+ dev-libs/libxslt
+ sys-devel/flex
+ virtual/pkgconfig
+ virtual/yacc
+ test? (
+ dev-libs/dbus-glib
+ >=dev-libs/glib-2.26:2 )
+"
+
+src_configure() {
+ gnome2_src_configure --disable-unversioned
+}