summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Joldasov <bratishkaerik@getgoogleoff.me>2022-12-07 07:59:30 +0600
committerSam James <sam@gentoo.org>2022-12-14 09:19:10 +0000
commit71cc785aae8ce2453258188b87e307ca42906d32 (patch)
tree6dc119026720c0c91f089c47b42ab242bd8998ce /dev-lang/zig/zig-9999.ebuild
parentdev-libs/qcoro5: use pkg tag for dev-qt/qtdeclarative (diff)
downloadgentoo-71cc785aae8ce2453258188b87e307ca42906d32.tar.gz
gentoo-71cc785aae8ce2453258188b87e307ca42906d32.tar.bz2
gentoo-71cc785aae8ce2453258188b87e307ca42906d32.zip
dev-lang/zig: relax memory requirements for 9999
https://www.github.com/ziglang/zig/commit/e7d28344fa3ee81d6ad7ca5ce1f83d50d8502118 was merged recently, so memory usage (when building) drops from ~10GB to ~4GB Bug: https://bugs.gentoo.org/823086 Signed-off-by: Eric Joldasov <bratishkaerik@getgoogleoff.me> Closes: https://github.com/gentoo/gentoo/pull/28581 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/zig/zig-9999.ebuild')
-rw-r--r--dev-lang/zig/zig-9999.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/dev-lang/zig/zig-9999.ebuild b/dev-lang/zig/zig-9999.ebuild
index a19a2873f8cd..04794281b8d8 100644
--- a/dev-lang/zig/zig-9999.ebuild
+++ b/dev-lang/zig/zig-9999.ebuild
@@ -21,7 +21,8 @@ SLOT="0"
BUILD_DIR="${S}/build"
-# Zig requires zstd and zlib compression support in LLVM, if using LLVM backend (non-LLVM backends don't require these).
+# Zig requires zstd and zlib compression support in LLVM, if using LLVM backend.
+# (non-LLVM backends don't require these)
# They are not required "on their own", so please don't add them here.
# You can check https://github.com/ziglang/zig-bootstrap in future, to see
# options that are passed to LLVM CMake building (excluding "static" ofc).
@@ -39,11 +40,9 @@ RDEPEND="
# see https://github.com/ziglang/zig/issues/3382
QA_FLAGS_IGNORED="usr/bin/zig"
-# see https://ziglang.org/download/0.10.0/release-notes.html#Self-Hosted-Compiler
-# 0.10.0 release - 9.6 GiB, since we use compiler written in C++ for bootstrapping
-# 0.11.0 release - ~2.8 GiB, since we will (at least according to roadmap) use self-hosted compiler
-# (transpiled to C via C backend) for bootstrapping
-CHECKREQS_MEMORY="10G"
+# Since commit https://github.com/ziglang/zig/commit/e7d28344fa3ee81d6ad7ca5ce1f83d50d8502118
+# Zig uses self-hosted compiler only
+CHECKREQS_MEMORY="4G"
llvm_check_deps() {
has_version "sys-devel/clang:${LLVM_SLOT}"