summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2021-11-05 13:38:53 +0000
committerPatrick Lauer <patrick@gentoo.org>2021-11-05 13:39:17 +0000
commita9506d0fdd5713698e24b41ce4f6f5afea2bd7ad (patch)
treeb99e3a58a8bd7619666e6f525212a06177da469c /dev-lang/zig/zig-9999.ebuild
parentgnome-extra/evolution-ews: bump to 3.42.1 (diff)
downloadgentoo-a9506d0fdd5713698e24b41ce4f6f5afea2bd7ad.tar.gz
gentoo-a9506d0fdd5713698e24b41ce4f6f5afea2bd7ad.tar.bz2
gentoo-a9506d0fdd5713698e24b41ce4f6f5afea2bd7ad.zip
dev-lang/zig: Disable experimental useflag for newest
Doesn't build otherwise, can't be fixed easily as upstream assumes full LLVM_TARGETS available Bug: https://bugs.gentoo.org/800206 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-lang/zig/zig-9999.ebuild')
-rw-r--r--dev-lang/zig/zig-9999.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/dev-lang/zig/zig-9999.ebuild b/dev-lang/zig/zig-9999.ebuild
index ecb9704d75a2..6aa6d288a706 100644
--- a/dev-lang/zig/zig-9999.ebuild
+++ b/dev-lang/zig/zig-9999.ebuild
@@ -9,7 +9,7 @@ DESCRIPTION="A robust, optimal, and maintainable programming language"
HOMEPAGE="https://ziglang.org/"
LICENSE="MIT"
SLOT="0"
-IUSE="+experimental test"
+IUSE="test"
RESTRICT="!test? ( test )"
if [[ ${PV} == 9999 ]]; then
@@ -37,8 +37,7 @@ RDEPEND="
sys-devel/clang:${LLVM_MAX_SLOT}
>=sys-devel/lld-12.0.0
<sys-devel/lld-14.0.0
- sys-devel/llvm:${LLVM_MAX_SLOT}
- !experimental? ( sys-devel/llvm:${LLVM_MAX_SLOT}[${LLVM_TARGET_USEDEPS// /,}] )
+ sys-devel/llvm:${LLVM_MAX_SLOT}[${LLVM_TARGET_USEDEPS// /,}]
"
DEPEND="${RDEPEND}"