summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-09 00:23:44 +0000
committerSam James <sam@gentoo.org>2024-03-09 00:23:44 +0000
commit00bda20b71f706a71b02304a3798bd1bcd742bbe (patch)
tree4dd875defaa7693b1a066c192bd05c9c71d25c9d /dev-lang
parentnet-misc/rsync: drop 3.2.4-r3, 3.2.7-r2 (diff)
downloadgentoo-00bda20b71f706a71b02304a3798bd1bcd742bbe.tar.gz
gentoo-00bda20b71f706a71b02304a3798bd1bcd742bbe.tar.bz2
gentoo-00bda20b71f706a71b02304a3798bd1bcd742bbe.zip
dev-lang/python: disable make output synchronisation for tests
It makes it look like they're hanging. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-2.7.18_p16-r2.ebuild2
-rw-r--r--dev-lang/python/python-3.10.13.ebuild2
-rw-r--r--dev-lang/python/python-3.10.13_p3.ebuild2
-rw-r--r--dev-lang/python/python-3.11.7.ebuild2
-rw-r--r--dev-lang/python/python-3.11.8.ebuild2
-rw-r--r--dev-lang/python/python-3.11.8_p1.ebuild2
-rw-r--r--dev-lang/python/python-3.12.1.ebuild2
-rw-r--r--dev-lang/python/python-3.12.1_p1.ebuild2
-rw-r--r--dev-lang/python/python-3.12.2.ebuild2
-rw-r--r--dev-lang/python/python-3.12.2_p1.ebuild2
-rw-r--r--dev-lang/python/python-3.13.0_alpha2.ebuild2
-rw-r--r--dev-lang/python/python-3.13.0_alpha3.ebuild2
-rw-r--r--dev-lang/python/python-3.13.0_alpha3_p1.ebuild2
-rw-r--r--dev-lang/python/python-3.13.0_alpha4.ebuild2
-rw-r--r--dev-lang/python/python-3.8.18.ebuild2
-rw-r--r--dev-lang/python/python-3.8.18_p2.ebuild2
-rw-r--r--dev-lang/python/python-3.9.18.ebuild2
-rw-r--r--dev-lang/python/python-3.9.18_p2.ebuild2
18 files changed, 18 insertions, 18 deletions
diff --git a/dev-lang/python/python-2.7.18_p16-r2.ebuild b/dev-lang/python/python-2.7.18_p16-r2.ebuild
index 539f7addcb1c..468b16a72d08 100644
--- a/dev-lang/python/python-2.7.18_p16-r2.ebuild
+++ b/dev-lang/python/python-2.7.18_p16-r2.ebuild
@@ -266,7 +266,7 @@ src_test() {
local -x TZ=UTC
# Rerun failed tests in verbose mode (regrtest -w).
- emake test EXTRATESTOPTS="-w" < /dev/tty
+ emake -Onone test EXTRATESTOPTS="-w" < /dev/tty
for test in "${skipped_tests[@]}"; do
mv "${T}/test_${test}.py" Lib/test/ || die
diff --git a/dev-lang/python/python-3.10.13.ebuild b/dev-lang/python/python-3.10.13.ebuild
index a8dc2f6575f8..d00f770b886d 100644
--- a/dev-lang/python/python-3.10.13.ebuild
+++ b/dev-lang/python/python-3.10.13.ebuild
@@ -410,7 +410,7 @@ src_test() {
# workaround https://bugs.gentoo.org/775416
addwrite "/usr/lib/python${PYVER}/site-packages"
- nonfatal emake test EXTRATESTOPTS="${test_opts[*]}" \
+ nonfatal emake -Onone test EXTRATESTOPTS="${test_opts[*]}" \
CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty
local ret=${?}
diff --git a/dev-lang/python/python-3.10.13_p3.ebuild b/dev-lang/python/python-3.10.13_p3.ebuild
index 8854e2d6d012..916bc1290842 100644
--- a/dev-lang/python/python-3.10.13_p3.ebuild
+++ b/dev-lang/python/python-3.10.13_p3.ebuild
@@ -406,7 +406,7 @@ src_test() {
# workaround https://bugs.gentoo.org/775416
addwrite "/usr/lib/python${PYVER}/site-packages"
- nonfatal emake test EXTRATESTOPTS="${test_opts[*]}" \
+ nonfatal emake -Onone test EXTRATESTOPTS="${test_opts[*]}" \
CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty
local ret=${?}
diff --git a/dev-lang/python/python-3.11.7.ebuild b/dev-lang/python/python-3.11.7.ebuild
index a43e610443d3..a5f20c83a163 100644
--- a/dev-lang/python/python-3.11.7.ebuild
+++ b/dev-lang/python/python-3.11.7.ebuild
@@ -421,7 +421,7 @@ src_test() {
# workaround https://bugs.gentoo.org/775416
addwrite "/usr/lib/python${PYVER}/site-packages"
- nonfatal emake test EXTRATESTOPTS="${test_opts[*]}" \
+ nonfatal emake -Onone test EXTRATESTOPTS="${test_opts[*]}" \
CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty
local ret=${?}
diff --git a/dev-lang/python/python-3.11.8.ebuild b/dev-lang/python/python-3.11.8.ebuild
index 8ea6f0bd7b58..3526c356b750 100644
--- a/dev-lang/python/python-3.11.8.ebuild
+++ b/dev-lang/python/python-3.11.8.ebuild
@@ -421,7 +421,7 @@ src_test() {
# workaround https://bugs.gentoo.org/775416
addwrite "/usr/lib/python${PYVER}/site-packages"
- nonfatal emake test EXTRATESTOPTS="${test_opts[*]}" \
+ nonfatal emake -Onone test EXTRATESTOPTS="${test_opts[*]}" \
CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty
local ret=${?}
diff --git a/dev-lang/python/python-3.11.8_p1.ebuild b/dev-lang/python/python-3.11.8_p1.ebuild
index a5f007d2605d..d5a9dc5eaa12 100644
--- a/dev-lang/python/python-3.11.8_p1.ebuild
+++ b/dev-lang/python/python-3.11.8_p1.ebuild
@@ -420,7 +420,7 @@ src_test() {
# workaround https://bugs.gentoo.org/775416
addwrite "/usr/lib/python${PYVER}/site-packages"
- nonfatal emake test EXTRATESTOPTS="${test_opts[*]}" \
+ nonfatal emake -Onone test EXTRATESTOPTS="${test_opts[*]}" \
CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty
local ret=${?}
diff --git a/dev-lang/python/python-3.12.1.ebuild b/dev-lang/python/python-3.12.1.ebuild
index 6c0fd66252e4..f4902a2479fe 100644
--- a/dev-lang/python/python-3.12.1.ebuild
+++ b/dev-lang/python/python-3.12.1.ebuild
@@ -412,7 +412,7 @@ src_test() {
# workaround https://bugs.gentoo.org/775416
addwrite "/usr/lib/python${PYVER}/site-packages"
- nonfatal emake test EXTRATESTOPTS="${test_opts[*]}" \
+ nonfatal emake -Onone test EXTRATESTOPTS="${test_opts[*]}" \
CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty
local ret=${?}
diff --git a/dev-lang/python/python-3.12.1_p1.ebuild b/dev-lang/python/python-3.12.1_p1.ebuild
index 0e3c0c9370b5..2ccf8d09c699 100644
--- a/dev-lang/python/python-3.12.1_p1.ebuild
+++ b/dev-lang/python/python-3.12.1_p1.ebuild
@@ -415,7 +415,7 @@ src_test() {
# workaround https://bugs.gentoo.org/775416
addwrite "/usr/lib/python${PYVER}/site-packages"
- nonfatal emake test EXTRATESTOPTS="${test_opts[*]}" \
+ nonfatal emake -Onone test EXTRATESTOPTS="${test_opts[*]}" \
CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty
local ret=${?}
diff --git a/dev-lang/python/python-3.12.2.ebuild b/dev-lang/python/python-3.12.2.ebuild
index 3c9c8ce7a1ce..09feb0f52466 100644
--- a/dev-lang/python/python-3.12.2.ebuild
+++ b/dev-lang/python/python-3.12.2.ebuild
@@ -415,7 +415,7 @@ src_test() {
# workaround https://bugs.gentoo.org/775416
addwrite "/usr/lib/python${PYVER}/site-packages"
- nonfatal emake test EXTRATESTOPTS="${test_opts[*]}" \
+ nonfatal emake -Onone test EXTRATESTOPTS="${test_opts[*]}" \
CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty
local ret=${?}
diff --git a/dev-lang/python/python-3.12.2_p1.ebuild b/dev-lang/python/python-3.12.2_p1.ebuild
index 5f3f03ade60a..e6450baf0c45 100644
--- a/dev-lang/python/python-3.12.2_p1.ebuild
+++ b/dev-lang/python/python-3.12.2_p1.ebuild
@@ -414,7 +414,7 @@ src_test() {
# workaround https://bugs.gentoo.org/775416
addwrite "/usr/lib/python${PYVER}/site-packages"
- nonfatal emake test EXTRATESTOPTS="${test_opts[*]}" \
+ nonfatal emake -Onone test EXTRATESTOPTS="${test_opts[*]}" \
CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty
local ret=${?}
diff --git a/dev-lang/python/python-3.13.0_alpha2.ebuild b/dev-lang/python/python-3.13.0_alpha2.ebuild
index 4ddf84d9d1c8..17306dbb0b69 100644
--- a/dev-lang/python/python-3.13.0_alpha2.ebuild
+++ b/dev-lang/python/python-3.13.0_alpha2.ebuild
@@ -414,7 +414,7 @@ src_test() {
# workaround https://bugs.gentoo.org/775416
addwrite "/usr/lib/python${PYVER}/site-packages"
- nonfatal emake test EXTRATESTOPTS="${test_opts[*]}" \
+ nonfatal emake -Onone test EXTRATESTOPTS="${test_opts[*]}" \
CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty
local ret=${?}
diff --git a/dev-lang/python/python-3.13.0_alpha3.ebuild b/dev-lang/python/python-3.13.0_alpha3.ebuild
index e3cdda1302cb..4fdd3eb970cc 100644
--- a/dev-lang/python/python-3.13.0_alpha3.ebuild
+++ b/dev-lang/python/python-3.13.0_alpha3.ebuild
@@ -414,7 +414,7 @@ src_test() {
# workaround https://bugs.gentoo.org/775416
addwrite "/usr/lib/python${PYVER}/site-packages"
- nonfatal emake test EXTRATESTOPTS="${test_opts[*]}" \
+ nonfatal emake -Onone test EXTRATESTOPTS="${test_opts[*]}" \
CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty
local ret=${?}
diff --git a/dev-lang/python/python-3.13.0_alpha3_p1.ebuild b/dev-lang/python/python-3.13.0_alpha3_p1.ebuild
index 2cd791faab28..8354775539d8 100644
--- a/dev-lang/python/python-3.13.0_alpha3_p1.ebuild
+++ b/dev-lang/python/python-3.13.0_alpha3_p1.ebuild
@@ -413,7 +413,7 @@ src_test() {
# workaround https://bugs.gentoo.org/775416
addwrite "/usr/lib/python${PYVER}/site-packages"
- nonfatal emake test EXTRATESTOPTS="${test_opts[*]}" \
+ nonfatal emake -Onone test EXTRATESTOPTS="${test_opts[*]}" \
CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty
local ret=${?}
diff --git a/dev-lang/python/python-3.13.0_alpha4.ebuild b/dev-lang/python/python-3.13.0_alpha4.ebuild
index 08b7d322bbbf..b763d4213f47 100644
--- a/dev-lang/python/python-3.13.0_alpha4.ebuild
+++ b/dev-lang/python/python-3.13.0_alpha4.ebuild
@@ -425,7 +425,7 @@ src_test() {
# workaround https://bugs.gentoo.org/775416
addwrite "/usr/lib/python${PYVER}/site-packages"
- nonfatal emake test EXTRATESTOPTS="${test_opts[*]}" \
+ nonfatal emake -Onone test EXTRATESTOPTS="${test_opts[*]}" \
CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty
local ret=${?}
diff --git a/dev-lang/python/python-3.8.18.ebuild b/dev-lang/python/python-3.8.18.ebuild
index 8c559d9f08d8..f70359ce0ac7 100644
--- a/dev-lang/python/python-3.8.18.ebuild
+++ b/dev-lang/python/python-3.8.18.ebuild
@@ -336,7 +336,7 @@ src_test() {
local -x COLUMNS=80
local -x PYTHONDONTWRITEBYTECODE=
- nonfatal emake test EXTRATESTOPTS="${test_opts[*]}" \
+ nonfatal emake -Onone test EXTRATESTOPTS="${test_opts[*]}" \
CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty
local ret=${?}
diff --git a/dev-lang/python/python-3.8.18_p2.ebuild b/dev-lang/python/python-3.8.18_p2.ebuild
index 4be53e25faf5..30365c0caa7c 100644
--- a/dev-lang/python/python-3.8.18_p2.ebuild
+++ b/dev-lang/python/python-3.8.18_p2.ebuild
@@ -326,7 +326,7 @@ src_test() {
local -x COLUMNS=80
local -x PYTHONDONTWRITEBYTECODE=
- nonfatal emake test EXTRATESTOPTS="${test_opts[*]}" \
+ nonfatal emake -Onone test EXTRATESTOPTS="${test_opts[*]}" \
CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty
local ret=${?}
diff --git a/dev-lang/python/python-3.9.18.ebuild b/dev-lang/python/python-3.9.18.ebuild
index c10ec2f54b06..1d35ed1759fd 100644
--- a/dev-lang/python/python-3.9.18.ebuild
+++ b/dev-lang/python/python-3.9.18.ebuild
@@ -393,7 +393,7 @@ src_test() {
local -x COLUMNS=80
local -x PYTHONDONTWRITEBYTECODE=
- nonfatal emake test EXTRATESTOPTS="${test_opts[*]}" \
+ nonfatal emake -Onone test EXTRATESTOPTS="${test_opts[*]}" \
CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty
local ret=${?}
diff --git a/dev-lang/python/python-3.9.18_p2.ebuild b/dev-lang/python/python-3.9.18_p2.ebuild
index 8dc37abfdb8c..3f0257a31151 100644
--- a/dev-lang/python/python-3.9.18_p2.ebuild
+++ b/dev-lang/python/python-3.9.18_p2.ebuild
@@ -385,7 +385,7 @@ src_test() {
local -x COLUMNS=80
local -x PYTHONDONTWRITEBYTECODE=
- nonfatal emake test EXTRATESTOPTS="${test_opts[*]}" \
+ nonfatal emake -Onone test EXTRATESTOPTS="${test_opts[*]}" \
CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty
local ret=${?}