summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-11-17 20:01:16 +0100
committerMichał Górny <mgorny@gentoo.org>2015-11-17 21:39:09 +0100
commit05dbe214abfe5900123a378ddc45411bf4805726 (patch)
tree275238e8ef52f2134c67b664699f76929a20c0e7 /dev-lang
parentdev-lang/python: Add symlinks for python-exec wrapping of execs (diff)
downloadgentoo-05dbe214abfe5900123a378ddc45411bf4805726.tar.gz
gentoo-05dbe214abfe5900123a378ddc45411bf4805726.tar.bz2
gentoo-05dbe214abfe5900123a378ddc45411bf4805726.zip
dev-lang/python-exec: Drop autotools-utils, clean up
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python-exec/python-exec-2.9999.ebuild21
1 files changed, 13 insertions, 8 deletions
diff --git a/dev-lang/python-exec/python-exec-2.9999.ebuild b/dev-lang/python-exec/python-exec-2.9999.ebuild
index a4628994aa58..d6ec26f1e103 100644
--- a/dev-lang/python-exec/python-exec-2.9999.ebuild
+++ b/dev-lang/python-exec/python-exec-2.9999.ebuild
@@ -5,18 +5,19 @@
EAPI=5
#if LIVE
-AUTOTOOLS_AUTORECONF=yes
EGIT_REPO_URI="https://bitbucket.org/mgorny/${PN}.git"
EGIT_BRANCH="python-exec2"
-inherit git-r3
+inherit autotools git-r3
#endif
# Kids, don't do this at home!
inherit python-utils-r1
PYTHON_COMPAT=( "${_PYTHON_ALL_IMPLS[@]}" )
-inherit autotools-utils python-r1
+# Inherited purely to have PYTHON_TARGET flags which will satisfy USE
+# dependencies and trigger necessary rebuilds.
+inherit python-r1
DESCRIPTION="Python script wrapper"
HOMEPAGE="https://bitbucket.org/mgorny/python-exec/"
@@ -32,19 +33,23 @@ RDEPEND="!<dev-python/python-exec-10000"
#if LIVE
KEYWORDS=
SRC_URI=
+
+src_prepare() {
+ eautoreconf
+}
#endif
src_configure() {
- local pyimpls i EPYTHON
+ local pyimpls=() i EPYTHON
for i in "${PYTHON_COMPAT[@]}"; do
python_export "${i}" EPYTHON
- pyimpls+=" ${EPYTHON}"
+ pyimpls+=( "${EPYTHON}" )
done
- local myeconfargs=(
+ local myconf=(
--with-eprefix="${EPREFIX}"
- --with-python-impls="${pyimpls}"
+ --with-python-impls="${pyimpls[*]}"
)
- autotools-utils_src_configure
+ econf "${myconf[@]}"
}