summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-06 11:53:05 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-06 13:23:31 +0100
commit0a2f7dda89a2ee2092cbcbf62a88976f409ab217 (patch)
treeac82d55016eba2cec444182eebbb045c276685ec /dev-lang
parentmedia-sound/strawberry: Moved dev-cpp/gtest from BDEPEND to DEPEND (diff)
downloadgentoo-0a2f7dda89a2ee2092cbcbf62a88976f409ab217.tar.gz
gentoo-0a2f7dda89a2ee2092cbcbf62a88976f409ab217.tar.bz2
gentoo-0a2f7dda89a2ee2092cbcbf62a88976f409ab217.zip
dev-lang/zig: Switch to cmake.eclass
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/zig/zig-0.5.0.ebuild8
-rw-r--r--dev-lang/zig/zig-9999.ebuild8
2 files changed, 8 insertions, 8 deletions
diff --git a/dev-lang/zig/zig-0.5.0.ebuild b/dev-lang/zig/zig-0.5.0.ebuild
index 7189e4ddc62f..223f162cfd9c 100644
--- a/dev-lang/zig/zig-0.5.0.ebuild
+++ b/dev-lang/zig/zig-0.5.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils llvm
+inherit cmake llvm
DESCRIPTION="A robust, optimal, and maintainable programming language"
HOMEPAGE="https://ziglang.org/"
@@ -48,7 +48,7 @@ src_prepare() {
sed -i 's/--prefix "${CMAKE_INSTALL_PREFIX}"/--prefix ".\/${CMAKE_INSTALL_PREFIX}"/' CMakeLists.txt || \
die "unable to fix install path"
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -57,5 +57,5 @@ src_configure() {
-DCLANG_LIBDIRS="$(llvm-config --libdir)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/dev-lang/zig/zig-9999.ebuild b/dev-lang/zig/zig-9999.ebuild
index 7189e4ddc62f..223f162cfd9c 100644
--- a/dev-lang/zig/zig-9999.ebuild
+++ b/dev-lang/zig/zig-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils llvm
+inherit cmake llvm
DESCRIPTION="A robust, optimal, and maintainable programming language"
HOMEPAGE="https://ziglang.org/"
@@ -48,7 +48,7 @@ src_prepare() {
sed -i 's/--prefix "${CMAKE_INSTALL_PREFIX}"/--prefix ".\/${CMAKE_INSTALL_PREFIX}"/' CMakeLists.txt || \
die "unable to fix install path"
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -57,5 +57,5 @@ src_configure() {
-DCLANG_LIBDIRS="$(llvm-config --libdir)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}