summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-01-21 13:57:42 +0200
committerMart Raudsepp <leio@gentoo.org>2018-01-21 13:57:42 +0200
commit0f109a9ac976bba1982c5b0b4997a2de7a58f8fa (patch)
treecbc2f614c8189b0d3ee3060b02abd147ef2a5bf1 /dev-lang
parentdev-lang/orc: install test headers always, used by some things (diff)
downloadgentoo-0f109a9ac976bba1982c5b0b4997a2de7a58f8fa.tar.gz
gentoo-0f109a9ac976bba1982c5b0b4997a2de7a58f8fa.tar.bz2
gentoo-0f109a9ac976bba1982c5b0b4997a2de7a58f8fa.zip
dev-lang/orc: remove problematic revision
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/orc/orc-0.4.28.ebuild71
1 files changed, 0 insertions, 71 deletions
diff --git a/dev-lang/orc/orc-0.4.28.ebuild b/dev-lang/orc/orc-0.4.28.ebuild
deleted file mode 100644
index a8bdc643a1d9..000000000000
--- a/dev-lang/orc/orc-0.4.28.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils flag-o-matic multilib-minimal pax-utils
-
-DESCRIPTION="The Oil Runtime Compiler, a just-in-time compiler for array operations"
-HOMEPAGE="https://gstreamer.freedesktop.org/"
-SRC_URI="https://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
-
-LICENSE="BSD BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="examples pax_kernel static-libs test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- app-arch/xz-utils
- >=dev-util/gtk-doc-am-1.12
-"
-
-src_prepare() {
- default
-
- # Do not build examples
- sed -e '/SUBDIRS/ s:examples::' \
- -i Makefile.am Makefile.in || die
-}
-
-multilib_src_configure() {
- # any optimisation on PPC/Darwin yields in a complaint from the assembler
- # Parameter error: r0 not allowed for parameter %lu (code as 0 not r0)
- # the same for Intel/Darwin, although the error message there is different
- # but along the same lines
- [[ ${CHOST} == *-darwin* ]] && filter-flags -O*
-
- # FIXME: handle backends per arch? What about cross-compiling for the other arches?
- ECONF_SOURCE="${S}" econf \
- --disable-gtk-doc \
- --enable-backend=all \
- $(use_enable static-libs static) \
- $(use_enable test tests)
-}
-
-multilib_src_install() {
- emake DESTDIR="${D}" install
- prune_libtool_files --all
-
- if use pax_kernel; then
- pax-mark m "${ED}"usr/bin/orc-bugreport
- pax-mark m "${ED}"usr/bin/orcc
- pax-mark m "${ED}"usr/$(get_libdir)/liborc*.so*
- fi
-}
-
-multilib_src_install_all() {
- einstalldocs
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins examples/{*.c,*.orc}
- fi
-}
-
-pkg_postinst() {
- if use pax_kernel; then
- ewarn "Please run \"revdep-pax\" after installation".
- ewarn "It's provided by sys-apps/elfix."
- fi
-}