summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2017-03-09 19:29:23 -0600
committerWilliam Hubbs <williamh@gentoo.org>2017-03-09 19:30:35 -0600
commit15e685eec630dfef63d3f20854a8becf23ae3211 (patch)
treef9a26f12a183f585db55df300845d66e7298634f /dev-lang
parentapp-admin/mcollective: 2.10.2 bup (diff)
downloadgentoo-15e685eec630dfef63d3f20854a8becf23ae3211.tar.gz
gentoo-15e685eec630dfef63d3f20854a8becf23ae3211.tar.bz2
gentoo-15e685eec630dfef63d3f20854a8becf23ae3211.zip
dev-lang/go: sync live ebuild
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/go/go-9999.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-lang/go/go-9999.ebuild b/dev-lang/go/go-9999.ebuild
index 11d1819c35f9..1137d737fef5 100644
--- a/dev-lang/go/go-9999.ebuild
+++ b/dev-lang/go/go-9999.ebuild
@@ -162,10 +162,12 @@ src_compile()
export GOROOT_BOOTSTRAP="${WORKDIR}"/go-$(go_os)-$(go_arch)-bootstrap
if use gccgo; then
mkdir -p "${GOROOT_BOOTSTRAP}/bin" || die
- local go_binary=$(gcc-config --get-bin-path)/go-5
+ local go_binary=$(gcc-config --get-bin-path)/go-$(gcc-major-version)
[[ -x ${go_binary} ]] || go_binary=$(
- find "${EPREFIX}"/usr/${CHOST}/gcc-bin/*/go-5 | sort -V | tail -n1)
- [[ -x ${go_binary} ]] || die "go-5: command not found"
+ find "${EPREFIX}"/usr/${CHOST}/gcc-bin/*/go-$(gcc-major-version) |
+ sort -V | tail -n1)
+ [[ -x ${go_binary} ]] ||
+ die "go-$(gcc-major-version): command not found"
ln -s "${go_binary}" "${GOROOT_BOOTSTRAP}/bin/go" || die
fi
export GOROOT_FINAL="${EPREFIX}"/usr/lib/go