summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2015-11-23 19:34:12 +0800
committerJason Zaman <perfinion@gentoo.org>2015-11-23 19:34:40 +0800
commit1ed77efedf7b762cea57373c02b299862198ea2f (patch)
tree54e54fcaddf4119aad91558c2d934bfa4162492a /dev-lang
parentdev-python/elasticsearch-curator: rm old versions (diff)
downloadgentoo-1ed77efedf7b762cea57373c02b299862198ea2f.tar.gz
gentoo-1ed77efedf7b762cea57373c02b299862198ea2f.tar.bz2
gentoo-1ed77efedf7b762cea57373c02b299862198ea2f.zip
dev-lang/mono: do not call paxctl directly
paxmark.sh should be used instead which follows XT/PT marks correctly Gentoo-Bug: https://bugs.gentoo.org/532244 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/mono/mono-2.10.9-r2.ebuild3
-rw-r--r--dev-lang/mono/mono-3.12.1.ebuild5
-rw-r--r--dev-lang/mono/mono-4.0.3.20.ebuild5
3 files changed, 8 insertions, 5 deletions
diff --git a/dev-lang/mono/mono-2.10.9-r2.ebuild b/dev-lang/mono/mono-2.10.9-r2.ebuild
index 8f938146451f..0938c29b2636 100644
--- a/dev-lang/mono/mono-2.10.9-r2.ebuild
+++ b/dev-lang/mono/mono-2.10.9-r2.ebuild
@@ -64,9 +64,10 @@ src_prepare() {
# we need to sed in the paxctl-ng -mr in the runtime/mono-wrapper.in so it doesn't
# get killed in the build process when MPROTECT is enabled. #286280
# RANDMMAP kills the build process to #347365
+ # use paxmark.sh to get PT/XT logic #532244
if use pax_kernel ; then
ewarn "We are disabling MPROTECT on the mono binary."
- sed '/exec "/ i\paxctl-ng -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in || die "Failed to sed mono-wrapper.in"
+ sed '/exec "/ i\paxmark.sh -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in || die "Failed to sed mono-wrapper.in"
fi
}
diff --git a/dev-lang/mono/mono-3.12.1.ebuild b/dev-lang/mono/mono-3.12.1.ebuild
index 14544b93cd9e..956028228fc6 100644
--- a/dev-lang/mono/mono-3.12.1.ebuild
+++ b/dev-lang/mono/mono-3.12.1.ebuild
@@ -46,13 +46,14 @@ pkg_setup() {
src_prepare() {
# we need to sed in the paxctl-ng -mr in the runtime/mono-wrapper.in so it don't
- # get killed in the build proces when MPROTEC is enable. #286280
+ # get killed in the build proces when MPROTECT is enable. #286280
# RANDMMAP kill the build proces to #347365
+ # use paxmark.sh to get PT/XT logic #532244
if use pax_kernel ; then
ewarn "We are disabling MPROTECT on the mono binary."
# issue 9 : https://github.com/Heather/gentoo-dotnet/issues/9
- sed '/exec "/ i\paxctl-ng -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in || die "Failed to sed mono-wrapper.in"
+ sed '/exec "/ i\paxmark.sh -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in || die "Failed to sed mono-wrapper.in"
fi
# mono build system can fail otherwise
diff --git a/dev-lang/mono/mono-4.0.3.20.ebuild b/dev-lang/mono/mono-4.0.3.20.ebuild
index 89fcad95a1d9..2675538530f0 100644
--- a/dev-lang/mono/mono-4.0.3.20.ebuild
+++ b/dev-lang/mono/mono-4.0.3.20.ebuild
@@ -51,13 +51,14 @@ pkg_setup() {
src_prepare() {
# we need to sed in the paxctl-ng -mr in the runtime/mono-wrapper.in so it don't
- # get killed in the build proces when MPROTEC is enable. #286280
+ # get killed in the build proces when MPROTECT is enable. #286280
# RANDMMAP kill the build proces to #347365
+ # use paxmark.sh to get PT/XT logic #532244
if use pax_kernel ; then
ewarn "We are disabling MPROTECT on the mono binary."
# issue 9 : https://github.com/Heather/gentoo-dotnet/issues/9
- sed '/exec "/ i\paxctl-ng -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in || die "Failed to sed mono-wrapper.in"
+ sed '/exec "/ i\paxmark.sh -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in || die "Failed to sed mono-wrapper.in"
fi
# mono build system can fail otherwise