summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-18 05:14:01 +0000
committerSam James <sam@gentoo.org>2021-11-18 05:14:10 +0000
commit219824a9f0de0597bd2f48b67f3f45aa24ea598e (patch)
treec58a88b8ee8cfe918f94f966871cf7d6adde821e /dev-lang
parentdev-java/icedtea-web: add 1.8.8 (diff)
downloadgentoo-219824a9f0de0597bd2f48b67f3f45aa24ea598e.tar.gz
gentoo-219824a9f0de0597bd2f48b67f3f45aa24ea598e.tar.bz2
gentoo-219824a9f0de0597bd2f48b67f3f45aa24ea598e.zip
dev-lang/python: skip test_distutils with PGO if rpm is installed
Leads to sandbox errors as it tries to write to /var/lib/rpm; couldn't seem to refine this further yet. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-3.10.0_p1.ebuild5
-rw-r--r--dev-lang/python/python-3.11.0_alpha2.ebuild5
-rw-r--r--dev-lang/python/python-3.9.9.ebuild5
3 files changed, 15 insertions, 0 deletions
diff --git a/dev-lang/python/python-3.10.0_p1.ebuild b/dev-lang/python/python-3.10.0_p1.ebuild
index b1491cac95e8..3f688422d821 100644
--- a/dev-lang/python/python-3.10.0_p1.ebuild
+++ b/dev-lang/python/python-3.10.0_p1.ebuild
@@ -163,6 +163,11 @@ src_configure() {
if use pgo; then
local jobs=$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")
export PROFILE_TASK="-m test -j${jobs} --pgo-extended -x test_gdb"
+
+ if has_version "app-arch/rpm" ; then
+ # Avoid sandbox failure (attempts to write to /var/lib/rpm)
+ PROFILE_TASK+=" -x test_distutils"
+ fi
fi
local myeconfargs=(
diff --git a/dev-lang/python/python-3.11.0_alpha2.ebuild b/dev-lang/python/python-3.11.0_alpha2.ebuild
index f1e7a4cccaeb..af6ab1080186 100644
--- a/dev-lang/python/python-3.11.0_alpha2.ebuild
+++ b/dev-lang/python/python-3.11.0_alpha2.ebuild
@@ -164,6 +164,11 @@ src_configure() {
if use pgo; then
local jobs=$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")
export PROFILE_TASK="-m test -j${jobs} --pgo-extended -x test_gdb"
+
+ if has_version "app-arch/rpm" ; then
+ # Avoid sandbox failure (attempts to write to /var/lib/rpm)
+ PROFILE_TASK+=" -x test_distutils"
+ fi
fi
local myeconfargs=(
diff --git a/dev-lang/python/python-3.9.9.ebuild b/dev-lang/python/python-3.9.9.ebuild
index 492a5a2fcbb2..3e5d7a9544f3 100644
--- a/dev-lang/python/python-3.9.9.ebuild
+++ b/dev-lang/python/python-3.9.9.ebuild
@@ -161,6 +161,11 @@ src_configure() {
if use pgo; then
local jobs=$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")
export PROFILE_TASK="-m test -j${jobs} --pgo-extended -x test_gdb"
+
+ if has_version "app-arch/rpm" ; then
+ # Avoid sandbox failure (attempts to write to /var/lib/rpm)
+ PROFILE_TASK+=" -x test_distutils"
+ fi
fi
local myeconfargs=(