summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-03-30 00:11:39 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-03-30 00:22:33 -0700
commit23468458c2b3066172904ecfe6f688a6e5c999d5 (patch)
treeade3d696c77204ea36e6a7b9889829cda208faa5 /dev-lang
parentmail-client/mutt-1.13.5: version bump (diff)
downloadgentoo-23468458c2b3066172904ecfe6f688a6e5c999d5.tar.gz
gentoo-23468458c2b3066172904ecfe6f688a6e5c999d5.tar.bz2
gentoo-23468458c2b3066172904ecfe6f688a6e5c999d5.zip
dev-lang/rust: allow llvm-10 for 1.42.0
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/rust/rust-1.42.0.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/dev-lang/rust/rust-1.42.0.ebuild b/dev-lang/rust/rust-1.42.0.ebuild
index 484af8fa84f6..196b58683e69 100644
--- a/dev-lang/rust/rust-1.42.0.ebuild
+++ b/dev-lang/rust/rust-1.42.0.ebuild
@@ -46,16 +46,17 @@ IUSE="clippy cpu_flags_x86_sse2 debug doc libressl miri nightly parallel-compile
# How to use it:
# 1. List all the working slots (with min versions) in ||, newest first.
-# 2. Update the := to specify *max* version, e.g. < 10.
-# 3. Specify LLVM_MAX_SLOT, e.g. 9.
+# 2. Update the := to specify *max* version, e.g. < 11.
+# 3. Specify LLVM_MAX_SLOT, e.g. 10.
LLVM_DEPEND="
|| (
+ sys-devel/llvm:10[${LLVM_TARGET_USEDEPS// /,}]
sys-devel/llvm:9[${LLVM_TARGET_USEDEPS// /,}]
- wasm? ( =sys-devel/lld-9* )
+ wasm? ( >=sys-devel/lld-9 )
)
- <sys-devel/llvm-10:=
+ <sys-devel/llvm-11:=
"
-LLVM_MAX_SLOT=9
+LLVM_MAX_SLOT=10
BOOTSTRAP_DEPEND="|| ( >=dev-lang/rust-1.$(($(ver_cut 2) - 1)).0-r1 >=dev-lang/rust-bin-1.$(($(ver_cut 2) - 1)) )"