summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2016-03-26 09:48:49 -0500
committerDoug Goldstein <cardoe@gentoo.org>2016-03-26 09:48:49 -0500
commit46316e3b6fbe3c00d7bd8dda70c195d80da2eb6e (patch)
treed8abeb56d917509df023dd5896bf05bcfddc642d /dev-lang
parentdev-lang/rust: version bump (diff)
downloadgentoo-46316e3b6fbe3c00d7bd8dda70c195d80da2eb6e.tar.gz
gentoo-46316e3b6fbe3c00d7bd8dda70c195d80da2eb6e.tar.bz2
gentoo-46316e3b6fbe3c00d7bd8dda70c195d80da2eb6e.zip
dev-lang/rust: fix llvm dependency
Technically prior to LLVM 3.7, Gentoo still supports static linking which is what the Rust build does by default so LLVM is not a run-time depend. Package-Manager: portage-2.2.26 Signed-off-by: Doug Goldstein <cardoe@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/rust/rust-1.7.0.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-lang/rust/rust-1.7.0.ebuild b/dev-lang/rust/rust-1.7.0.ebuild
index f2c2cb2699b1..c17bed8f61ac 100644
--- a/dev-lang/rust/rust-1.7.0.ebuild
+++ b/dev-lang/rust/rust-1.7.0.ebuild
@@ -35,15 +35,14 @@ KEYWORDS="~amd64 ~x86"
IUSE="clang debug doc libcxx +system-llvm"
REQUIRED_USE="libcxx? ( clang )"
-RDEPEND="libcxx? ( sys-libs/libcxx )
- system-llvm? ( >=sys-devel/llvm-3.6.0:=[multitarget]
- <sys-devel/llvm-3.7.0:=[multitarget] )
-"
+RDEPEND="libcxx? ( sys-libs/libcxx )"
DEPEND="${RDEPEND}
${PYTHON_DEPS}
>=dev-lang/perl-5.0
clang? ( sys-devel/clang )
+ system-llvm? ( >=sys-devel/llvm-3.6.0[multitarget]
+ <sys-devel/llvm-3.7.0[multitarget] )
"
PDEPEND=">=app-eselect/eselect-rust-0.3_pre20150425"