summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-01-17 08:04:11 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-01-17 08:04:38 +0000
commit47b988b3b8b66dbaec48a57d17a7769b4b8425bf (patch)
treedb1c271f1579d8e788bc8164005d08a371528e4c /dev-lang
parentdev-python/xarray: Use HTTPS (diff)
downloadgentoo-47b988b3b8b66dbaec48a57d17a7769b4b8425bf.tar.gz
gentoo-47b988b3b8b66dbaec48a57d17a7769b4b8425bf.tar.bz2
gentoo-47b988b3b8b66dbaec48a57d17a7769b4b8425bf.zip
dev-lang/erlang: fix lib/asn1 depend, bug #705500
The build failure is reproducible on a 4-core CPU when using massive parallelism: ``` $ make -j21 -l4 ... GEN asn1ct_eval_ext.erl {"init terminating in do_boot", {undef,[{asn1ct_func,start_link,[],[]}, {prepare_templates,gen_asn1ct_eval,1, [{file,"prepare_templates.erl"},{line,58}]}, {init,start_it,1,[]},{init,start_em,1,[]}]}} init terminating in do_boot () Crash dump is being written to: erl_crash.dump...done make[2]: *** [Makefile:139: asn1ct_eval_ext.erl] Error 1 ``` Here `asn1ct_eval_ext.erl` attempts to load `asn1ct_func.beam` via `prepare_templates.erl` before it's compiled into `.beam` file. The change pulls in a dependency on `asn1ct_func.beam`. Reported-by: WGH Closes: https://bugs.gentoo.org/705500 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/erlang/erlang-22.1.4.ebuild3
-rw-r--r--dev-lang/erlang/erlang-22.1.8-r1.ebuild3
-rw-r--r--dev-lang/erlang/erlang-22.2.1-r1.ebuild3
-rw-r--r--dev-lang/erlang/erlang-22.2.2.ebuild1
-rw-r--r--dev-lang/erlang/erlang-22.2.ebuild3
-rw-r--r--dev-lang/erlang/files/erlang-22.1.4-asn1-dep.patch15
6 files changed, 24 insertions, 4 deletions
diff --git a/dev-lang/erlang/erlang-22.1.4.ebuild b/dev-lang/erlang/erlang-22.1.4.ebuild
index 83d78ce48e10..a6aec6a1a12f 100644
--- a/dev-lang/erlang/erlang-22.1.4.ebuild
+++ b/dev-lang/erlang/erlang-22.1.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -51,6 +51,7 @@ S="${WORKDIR}/otp-OTP-${PV}"
PATCHES=(
"${FILESDIR}/18.2.1-wx3.0.patch"
"${FILESDIR}/${PN}-22.0-dont-ignore-LDFLAGS.patch"
+ "${FILESDIR}/${PN}-22.1.4-asn1-dep.patch"
)
SITEFILE=50"${PN}"-gentoo.el
diff --git a/dev-lang/erlang/erlang-22.1.8-r1.ebuild b/dev-lang/erlang/erlang-22.1.8-r1.ebuild
index 3ffd63edd06e..5d1d119a7576 100644
--- a/dev-lang/erlang/erlang-22.1.8-r1.ebuild
+++ b/dev-lang/erlang/erlang-22.1.8-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -51,6 +51,7 @@ S="${WORKDIR}/otp-OTP-${PV}"
PATCHES=(
"${FILESDIR}/18.2.1-wx3.0.patch"
"${FILESDIR}/${PN}-22.0-dont-ignore-LDFLAGS.patch"
+ "${FILESDIR}/${PN}-22.1.4-asn1-dep.patch"
)
SITEFILE=50"${PN}"-gentoo.el
diff --git a/dev-lang/erlang/erlang-22.2.1-r1.ebuild b/dev-lang/erlang/erlang-22.2.1-r1.ebuild
index 3ffd63edd06e..5d1d119a7576 100644
--- a/dev-lang/erlang/erlang-22.2.1-r1.ebuild
+++ b/dev-lang/erlang/erlang-22.2.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -51,6 +51,7 @@ S="${WORKDIR}/otp-OTP-${PV}"
PATCHES=(
"${FILESDIR}/18.2.1-wx3.0.patch"
"${FILESDIR}/${PN}-22.0-dont-ignore-LDFLAGS.patch"
+ "${FILESDIR}/${PN}-22.1.4-asn1-dep.patch"
)
SITEFILE=50"${PN}"-gentoo.el
diff --git a/dev-lang/erlang/erlang-22.2.2.ebuild b/dev-lang/erlang/erlang-22.2.2.ebuild
index 97a529061f4c..c52ed00f231a 100644
--- a/dev-lang/erlang/erlang-22.2.2.ebuild
+++ b/dev-lang/erlang/erlang-22.2.2.ebuild
@@ -52,6 +52,7 @@ PATCHES=(
"${FILESDIR}/18.2.1-wx3.0.patch"
"${FILESDIR}/${PN}-22.0-dont-ignore-LDFLAGS.patch"
"${FILESDIR}/${PN}-22.2.2-gcc-10.patch"
+ "${FILESDIR}/${PN}-22.1.4-asn1-dep.patch"
)
SITEFILE=50"${PN}"-gentoo.el
diff --git a/dev-lang/erlang/erlang-22.2.ebuild b/dev-lang/erlang/erlang-22.2.ebuild
index 3ffd63edd06e..5d1d119a7576 100644
--- a/dev-lang/erlang/erlang-22.2.ebuild
+++ b/dev-lang/erlang/erlang-22.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -51,6 +51,7 @@ S="${WORKDIR}/otp-OTP-${PV}"
PATCHES=(
"${FILESDIR}/18.2.1-wx3.0.patch"
"${FILESDIR}/${PN}-22.0-dont-ignore-LDFLAGS.patch"
+ "${FILESDIR}/${PN}-22.1.4-asn1-dep.patch"
)
SITEFILE=50"${PN}"-gentoo.el
diff --git a/dev-lang/erlang/files/erlang-22.1.4-asn1-dep.patch b/dev-lang/erlang/files/erlang-22.1.4-asn1-dep.patch
new file mode 100644
index 000000000000..84c9b81ad770
--- /dev/null
+++ b/dev-lang/erlang/files/erlang-22.1.4-asn1-dep.patch
@@ -0,0 +1,15 @@
+https://bugs.gentoo.org/705500
+https://github.com/erlang/otp/pull/2508
+
+--- a/lib/asn1/src/Makefile
++++ b/lib/asn1/src/Makefile
+@@ -190,7 +190,8 @@ asn1rtt_%.$(EMULATOR): asn1rtt_%.erl
+ $(V_ERLC) +debug_info $<
+
+ $(EVAL_CT_MODULES:%=%.erl): prepare_templates.$(EMULATOR) \
+- $(EBIN)/asn1ct_rtt.$(EMULATOR)
++ $(EBIN)/asn1ct_rtt.$(EMULATOR) \
++ $(EBIN)/asn1ct_func.$(EMULATOR)
+
+ #
+ # Dependencies