summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-12-28 21:12:39 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-12-28 21:14:05 +0000
commit47eaa6c9ce342607d3185ee5c10fdf0b763ef52e (patch)
tree71a992f76dbfd6e78448d27229edb38e4dd6b7a2 /dev-lang
parentdev-perl/Time-Period: ppc/x86 stable ALLARCHES re bug #588344 (diff)
downloadgentoo-47eaa6c9ce342607d3185ee5c10fdf0b763ef52e.tar.gz
gentoo-47eaa6c9ce342607d3185ee5c10fdf0b763ef52e.tar.bz2
gentoo-47eaa6c9ce342607d3185ee5c10fdf0b763ef52e.zip
dev-lang/ghc: add dependency on ncurses-5 ABI for ghc[binary], bug #603632
all existing GHC versions were built agains ncurses-5. Pull in this binary depend when uses choses to install ghc binary as-is. Reported-by: Chris Henhawke Bug: https://bugs.gentoo.org/603632 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ghc/ghc-7.10.2-r1.ebuild11
-rw-r--r--dev-lang/ghc/ghc-7.10.2.ebuild11
-rw-r--r--dev-lang/ghc/ghc-7.10.3.ebuild9
-rw-r--r--dev-lang/ghc/ghc-7.8.3.ebuild11
-rw-r--r--dev-lang/ghc/ghc-7.8.4.ebuild11
5 files changed, 49 insertions, 4 deletions
diff --git a/dev-lang/ghc/ghc-7.10.2-r1.ebuild b/dev-lang/ghc/ghc-7.10.2-r1.ebuild
index c010b36d0746..13af9a4d9d02 100644
--- a/dev-lang/ghc/ghc-7.10.2-r1.ebuild
+++ b/dev-lang/ghc/ghc-7.10.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -90,6 +90,15 @@ RDEPEND="
kernel_linux? ( >=sys-devel/binutils-2.17:* )
kernel_SunOS? ( >=sys-devel/binutils-2.17:* )
"
+# gentoo binaries are built against ncurses-5
+RDEPEND+="
+ binary? (
+ || (
+ sys-libs/ncurses:0/5
+ sys-libs/ncurses:5/5
+ )
+ )
+"
# force dependency on >=gmp-5, even if >=gmp-4.1 would be enough. this is due to
# that we want the binaries to use the latest versioun available, and not to be
diff --git a/dev-lang/ghc/ghc-7.10.2.ebuild b/dev-lang/ghc/ghc-7.10.2.ebuild
index 719778ce02fe..7b04d8389d98 100644
--- a/dev-lang/ghc/ghc-7.10.2.ebuild
+++ b/dev-lang/ghc/ghc-7.10.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -90,6 +90,15 @@ RDEPEND="
kernel_linux? ( >=sys-devel/binutils-2.17:* )
kernel_SunOS? ( >=sys-devel/binutils-2.17:* )
"
+# gentoo binaries are built against ncurses-5
+RDEPEND+="
+ binary? (
+ || (
+ sys-libs/ncurses:0/5
+ sys-libs/ncurses:5/5
+ )
+ )
+"
# force dependency on >=gmp-5, even if >=gmp-4.1 would be enough. this is due to
# that we want the binaries to use the latest versioun available, and not to be
diff --git a/dev-lang/ghc/ghc-7.10.3.ebuild b/dev-lang/ghc/ghc-7.10.3.ebuild
index 78ebfbf12d46..b2d4287ec304 100644
--- a/dev-lang/ghc/ghc-7.10.3.ebuild
+++ b/dev-lang/ghc/ghc-7.10.3.ebuild
@@ -87,6 +87,15 @@ RDEPEND="
kernel_linux? ( >=sys-devel/binutils-2.17:* )
kernel_SunOS? ( >=sys-devel/binutils-2.17:* )
"
+# gentoo binaries are built against ncurses-5
+RDEPEND+="
+ binary? (
+ || (
+ sys-libs/ncurses:0/5
+ sys-libs/ncurses:5/5
+ )
+ )
+"
# force dependency on >=gmp-5, even if >=gmp-4.1 would be enough. this is due to
# that we want the binaries to use the latest versioun available, and not to be
diff --git a/dev-lang/ghc/ghc-7.8.3.ebuild b/dev-lang/ghc/ghc-7.8.3.ebuild
index 8bc6574929bf..30b7aa5a54a3 100644
--- a/dev-lang/ghc/ghc-7.8.3.ebuild
+++ b/dev-lang/ghc/ghc-7.8.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -79,6 +79,15 @@ RDEPEND="
kernel_linux? ( >=sys-devel/binutils-2.17 )
kernel_SunOS? ( >=sys-devel/binutils-2.17 )
"
+# gentoo binaries are built against ncurses-5
+RDEPEND+="
+ binary? (
+ || (
+ sys-libs/ncurses:0/5
+ sys-libs/ncurses:5/5
+ )
+ )
+"
# force dependency on >=gmp-5, even if >=gmp-4.1 would be enough. this is due to
# that we want the binaries to use the latest versioun available, and not to be
diff --git a/dev-lang/ghc/ghc-7.8.4.ebuild b/dev-lang/ghc/ghc-7.8.4.ebuild
index aa9c5ccff19a..941a063117f5 100644
--- a/dev-lang/ghc/ghc-7.8.4.ebuild
+++ b/dev-lang/ghc/ghc-7.8.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -80,6 +80,15 @@ RDEPEND="
kernel_linux? ( >=sys-devel/binutils-2.17 )
kernel_SunOS? ( >=sys-devel/binutils-2.17 )
"
+# gentoo binaries are built against ncurses-5
+RDEPEND+="
+ binary? (
+ || (
+ sys-libs/ncurses:0/5
+ sys-libs/ncurses:5/5
+ )
+ )
+"
# force dependency on >=gmp-5, even if >=gmp-4.1 would be enough. this is due to
# that we want the binaries to use the latest versioun available, and not to be