summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-09-29 02:12:08 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-09-29 02:22:31 +0200
commit4c2510d5609c70c412205a24328bb4642351ee19 (patch)
treec3abc62df20d758b6ecef573b557a08c768b5689 /dev-lang
parentapp-shells/fzf: add 0.34.0 (diff)
downloadgentoo-4c2510d5609c70c412205a24328bb4642351ee19.tar.gz
gentoo-4c2510d5609c70c412205a24328bb4642351ee19.tar.bz2
gentoo-4c2510d5609c70c412205a24328bb4642351ee19.zip
dev-lang/nim: bump to 1.6.8
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/nim/Manifest1
-rw-r--r--dev-lang/nim/nim-1.6.8.ebuild108
2 files changed, 109 insertions, 0 deletions
diff --git a/dev-lang/nim/Manifest b/dev-lang/nim/Manifest
index c1274dd207ae..33d52848817b 100644
--- a/dev-lang/nim/Manifest
+++ b/dev-lang/nim/Manifest
@@ -1,4 +1,5 @@
DIST nim-1.6.2.tar.xz 5181616 BLAKE2B adedbcaad1b135b6f99459894856190103e2d2b678849e0418f77c02a54fde44224456ea13949f3fe9f5f020a90adde46593497895674bd9ae892b17708df292 SHA512 052b62c987035f7633f965356993cd4eec686f4f4f5c675cf966d82cb30fcf574045887a4402bcc20e487299fb5e8f65a921951c2dc21ac334e695e31d95d992
DIST nim-1.6.4.tar.xz 5130208 BLAKE2B d0f297581677bbb9fb185a8b4198f48bb58efe81a1624f62051bc1e0a93f879a0cec172f11a41784ca715ba3c151dc5307e96c15c54908aa40df406040891d6c SHA512 f4d082f37f0e675e8cdb4340d67f2e58b5e6ac5bb51dab1ded5417097f3b86d71fa585ef12ee1c3cd5b17285589cbe9d5658fcb29c98547f7967a1b6f0cb4646
DIST nim-1.6.6.tar.xz 5149956 BLAKE2B 2fd1b40f1ecc1200255052d9e013c55287d3e01337146d0b1386d0f3fc9c14fda1e8e82ee289e782c77a573c1ae0985ea7f900f61e6b9824a9eb4b5c803c7f71 SHA512 6ea8d3f61adae48184dd0e3ac393296fd3bd5ead818e7dee949f43eccbd0b6229ebfc474353ddd63cc734f82c3247998fbfe88362061983f978ad8d0ab7fa677
+DIST nim-1.6.8.tar.xz 5219880 BLAKE2B 16eac6f302b4ef1df14deaa0350e0e5553c7613515cc3e79cbe025af70955bef29c8261a1f91ba901023d9c53f9f00d62116301eb5a4ee4bb5314bb1e25a5755 SHA512 dd046dd393136fdcb78f463e267756bdb990b08e80e3a8be7fec1995b47a930447468e12bb9a59db6ec5546117f62ff4ccd032959879ef2d1d06a7bc5c438f83
DIST nim-patches-1.6.6.tar.gz 1975 BLAKE2B 75490f4c61f4d920aadb2ad5908cb2773e270f80cee95f937ede8125bad5688b71840ed7f48659db892e4017437a0454b38eab18ae8b13c6b48207d0a7714371 SHA512 4d1590e7d05ad64432b943f8da9edb2b05213400181d1e07a0e40f479afbceb1997d0ea0f05a73d550afe60cf4b657f7e34840907ea16c3b9e96824e9f29e0e5
diff --git a/dev-lang/nim/nim-1.6.8.ebuild b/dev-lang/nim/nim-1.6.8.ebuild
new file mode 100644
index 000000000000..00b90b784ff9
--- /dev/null
+++ b/dev-lang/nim/nim-1.6.8.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 edo multiprocessing toolchain-funcs xdg-utils
+
+DESCRIPTION="compiled, garbage-collected systems programming language"
+HOMEPAGE="https://nim-lang.org/"
+SRC_URI="
+ https://nim-lang.org/download/${P}.tar.xz
+ experimental? (
+ https://git.sr.ht/~cyber/${PN}-patches/archive/1.6.6.tar.gz
+ -> ${PN}-patches-1.6.6.tar.gz
+ )
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug experimental"
+RESTRICT="test" # need to sort out depends and numerous failures
+
+# BDEPEND="sys-process/parallel"
+# BDEPEND="test? ( net-libs/nodejs )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.20.0-paths.patch
+ "${FILESDIR}"/${PN}-1.6.6-csources-flags.patch
+)
+
+# Borrowed from nim-utils.eclass (guru overlay).
+nim_gen_config() {
+ cat > nim.cfg <<- EOF || die "Failed to create Nim config"
+ cc:"gcc"
+ gcc.exe:"$(tc-getCC)"
+ gcc.linkerexe:"$(tc-getCC)"
+ gcc.cpp.exe:"$(tc-getCXX)"
+ gcc.cpp.linkerexe:"$(tc-getCXX)"
+ gcc.options.speed:"${CFLAGS}"
+ gcc.options.size:"${CFLAGS}"
+ gcc.options.debug:"${CFLAGS}"
+ gcc.options.always:"${CPPFLAGS}"
+ gcc.options.linker:"${LDFLAGS}"
+ gcc.cpp.options.speed:"${CXXFLAGS}"
+ gcc.cpp.options.size:"${CXXFLAGS}"
+ gcc.cpp.options.debug:"${CXXFLAGS}"
+ gcc.cpp.options.always:"${CPPFLAGS}"
+ gcc.cpp.options.linker:"${LDFLAGS}"
+
+ $([[ "${NOCOLOR}" == true || "${NOCOLOR}" == yes ]] && echo '--colors:"off"')
+ -d:"$(usex debug debug release)"
+ --parallelBuild:"$(makeopts_jobs)"
+ EOF
+}
+
+src_prepare() {
+ default
+
+ # note: there are consumers in the ::guru overlay
+ use experimental && eapply "${WORKDIR}"/${PN}-patches-1.6.6
+}
+
+src_configure() {
+ xdg_environment_reset # bug 667182
+
+ unset NIMBLE_DIR
+ tc-export CC CXX LD
+
+ nim_gen_config
+}
+
+src_compile() {
+ local -x PATH="${S}/bin:${PATH}"
+
+ # Build from C sources
+ # Compiling with sys-process/parallel fails for some reason but hopefully
+ # we'll be able to enable it later...
+ edo bash build.sh # --parallel "$(makeopts_jobs)"
+
+ edo ./bin/nim compile koch
+ edo ./koch boot -d:nimUseLinenoise --skipParentCfg:off
+ edo ./koch tools
+}
+
+src_test() {
+ local -x PATH="${S}/bin:${PATH}"
+
+ edo ./koch test
+}
+
+src_install() {
+ local -x PATH="${S}/bin:${PATH}"
+
+ edo ./koch install "${ED}"
+
+ # "./koch install" installs only "nim" binary
+ # but not the rest
+ exeinto /usr/bin
+ local exe
+ for exe in bin/* ; do
+ [[ "${exe}" == bin/nim ]] && continue
+ doexe "${exe}"
+ done
+
+ newbashcomp tools/nim.bash-completion nim
+ newbashcomp dist/nimble/nimble.bash-completion nimble
+}