summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-26 08:48:29 +0100
committerSam James <sam@gentoo.org>2023-05-26 08:48:29 +0100
commit4c6957bd00ba63468d93f40982d77a378858569d (patch)
treefa2a1e81b63506e9631bd6d17fc119788b5e39a1 /dev-lang
parentnet-im/mattermost-desktop-bin: add 5.4.0_rc1 (diff)
downloadgentoo-4c6957bd00ba63468d93f40982d77a378858569d.tar.gz
gentoo-4c6957bd00ba63468d93f40982d77a378858569d.tar.bz2
gentoo-4c6957bd00ba63468d93f40982d77a378858569d.zip
dev-lang/python: add USE=debug to control assertions
Note that we don't do pydebug for this as it forces optimisations to be disabled (-O0, not just some). For newer Pythons, fwiw, pydebug is ABI compatible with release pythons, but still not worth it. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-3.10.11.ebuild3
-rw-r--r--dev-lang/python/python-3.11.3.ebuild3
-rw-r--r--dev-lang/python/python-3.12.0_alpha7.ebuild3
-rw-r--r--dev-lang/python/python-3.12.0_beta1.ebuild3
-rw-r--r--dev-lang/python/python-3.8.16_p4.ebuild3
-rw-r--r--dev-lang/python/python-3.9.16_p3-r1.ebuild3
6 files changed, 12 insertions, 6 deletions
diff --git a/dev-lang/python/python-3.10.11.ebuild b/dev-lang/python/python-3.10.11.ebuild
index c5dd75f19046..b30e6ea4d97f 100644
--- a/dev-lang/python/python-3.10.11.ebuild
+++ b/dev-lang/python/python-3.10.11.ebuild
@@ -30,7 +30,7 @@ LICENSE="PSF-2"
SLOT="${PYVER}"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="
- bluetooth build +ensurepip examples gdbm hardened libedit lto
+ bluetooth build debug +ensurepip examples gdbm hardened libedit lto
+ncurses pgo +readline +sqlite +ssl test tk valgrind +xml
"
RESTRICT="!test? ( test )"
@@ -232,6 +232,7 @@ src_configure() {
--with-system-ffi
--with-wheel-pkg-dir="${EPREFIX}"/usr/lib/python/ensurepip
+ $(use_with debug assertions)
$(use_with lto)
$(use_enable pgo optimizations)
$(use_with readline readline "$(usex libedit editline readline)")
diff --git a/dev-lang/python/python-3.11.3.ebuild b/dev-lang/python/python-3.11.3.ebuild
index fed1bebc47f5..389e56a6a6f4 100644
--- a/dev-lang/python/python-3.11.3.ebuild
+++ b/dev-lang/python/python-3.11.3.ebuild
@@ -30,7 +30,7 @@ LICENSE="PSF-2"
SLOT="${PYVER}"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="
- bluetooth build +ensurepip examples gdbm hardened libedit lto
+ bluetooth build debug +ensurepip examples gdbm hardened libedit lto
+ncurses pgo +readline +sqlite +ssl test tk valgrind
"
RESTRICT="!test? ( test )"
@@ -221,6 +221,7 @@ src_configure() {
--with-pkg-config=yes
--with-wheel-pkg-dir="${EPREFIX}"/usr/lib/python/ensurepip
+ $(use_with debug assertions)
$(use_with lto)
$(use_enable pgo optimizations)
$(use_with readline readline "$(usex libedit editline readline)")
diff --git a/dev-lang/python/python-3.12.0_alpha7.ebuild b/dev-lang/python/python-3.12.0_alpha7.ebuild
index 95d394d31c55..41b53e19a104 100644
--- a/dev-lang/python/python-3.12.0_alpha7.ebuild
+++ b/dev-lang/python/python-3.12.0_alpha7.ebuild
@@ -30,7 +30,7 @@ LICENSE="PSF-2"
SLOT="${PYVER}"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
IUSE="
- bluetooth build +ensurepip examples gdbm hardened libedit lto
+ bluetooth build debug +ensurepip examples gdbm hardened libedit lto
+ncurses pgo +readline +sqlite +ssl test tk valgrind
"
RESTRICT="!test? ( test )"
@@ -215,6 +215,7 @@ src_configure() {
--with-pkg-config=yes
--with-wheel-pkg-dir="${EPREFIX}"/usr/lib/python/ensurepip
+ $(use_with debug assertions)
$(use_with lto)
$(use_enable pgo optimizations)
$(use_with readline readline "$(usex libedit editline readline)")
diff --git a/dev-lang/python/python-3.12.0_beta1.ebuild b/dev-lang/python/python-3.12.0_beta1.ebuild
index 09f88d48b332..14f92570e8f9 100644
--- a/dev-lang/python/python-3.12.0_beta1.ebuild
+++ b/dev-lang/python/python-3.12.0_beta1.ebuild
@@ -30,7 +30,7 @@ LICENSE="PSF-2"
SLOT="${PYVER}"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
IUSE="
- bluetooth build +ensurepip examples gdbm hardened libedit lto
+ bluetooth build debug +ensurepip examples gdbm hardened libedit lto
+ncurses pgo +readline +sqlite +ssl test tk valgrind
"
RESTRICT="!test? ( test )"
@@ -215,6 +215,7 @@ src_configure() {
--with-pkg-config=yes
--with-wheel-pkg-dir="${EPREFIX}"/usr/lib/python/ensurepip
+ $(use_with debug assertions)
$(use_with lto)
$(use_enable pgo optimizations)
$(use_with readline readline "$(usex libedit editline readline)")
diff --git a/dev-lang/python/python-3.8.16_p4.ebuild b/dev-lang/python/python-3.8.16_p4.ebuild
index 9c310fbeef4a..67ca3cbba43e 100644
--- a/dev-lang/python/python-3.8.16_p4.ebuild
+++ b/dev-lang/python/python-3.8.16_p4.ebuild
@@ -30,7 +30,7 @@ LICENSE="PSF-2"
SLOT="${PYVER}"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="
- bluetooth build +ensurepip examples gdbm hardened lto +ncurses pgo
+ bluetooth build debug +ensurepip examples gdbm hardened lto +ncurses pgo
+readline +sqlite +ssl test tk valgrind wininst +xml
"
RESTRICT="!test? ( test )"
@@ -182,6 +182,7 @@ src_configure() {
--with-system-ffi
--with-wheel-pkg-dir="${EPREFIX}"/usr/lib/python/ensurepip
+ $(use_with debug assertions)
$(use_with valgrind)
)
diff --git a/dev-lang/python/python-3.9.16_p3-r1.ebuild b/dev-lang/python/python-3.9.16_p3-r1.ebuild
index d40463a1e9b8..e9ff013485fb 100644
--- a/dev-lang/python/python-3.9.16_p3-r1.ebuild
+++ b/dev-lang/python/python-3.9.16_p3-r1.ebuild
@@ -30,7 +30,7 @@ LICENSE="PSF-2"
SLOT="${PYVER}"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="
- bluetooth build +ensurepip examples gdbm hardened lto +ncurses pgo
+ bluetooth build debug +ensurepip examples gdbm hardened lto +ncurses pgo
+readline +sqlite +ssl test tk valgrind +xml
"
RESTRICT="!test? ( test )"
@@ -221,6 +221,7 @@ src_configure() {
--with-system-ffi
--with-wheel-pkg-dir="${EPREFIX}"/usr/lib/python/ensurepip
+ $(use_with debug assertions)
$(use_with lto)
$(use_enable pgo optimizations)
$(use_with valgrind)