summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-11-27 21:01:30 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-11-27 21:02:02 +0100
commit54d516476fe0434a45676f12db6a6d2eddb20533 (patch)
tree216134474acd7d8ede6615d6fb555e0830908518 /dev-lang
parentprofiles/base: mask sys-devel/gcc[cet] in base (diff)
downloadgentoo-54d516476fe0434a45676f12db6a6d2eddb20533.tar.gz
gentoo-54d516476fe0434a45676f12db6a6d2eddb20533.tar.bz2
gentoo-54d516476fe0434a45676f12db6a6d2eddb20533.zip
dev-lang/idris2: new package; add version 0.5.1_p20211112
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/idris2/Manifest1
-rw-r--r--dev-lang/idris2/idris2-0.5.1_p20211112.ebuild108
-rw-r--r--dev-lang/idris2/metadata.xml27
3 files changed, 136 insertions, 0 deletions
diff --git a/dev-lang/idris2/Manifest b/dev-lang/idris2/Manifest
new file mode 100644
index 000000000000..ceffb317d5de
--- /dev/null
+++ b/dev-lang/idris2/Manifest
@@ -0,0 +1 @@
+DIST idris2-0.5.1_p20211112.tar.gz 6202861 BLAKE2B 189bf28c7a33281494edea9b2c0821a934000fe9ca6e929b3318fe33576553142e5ad8d81598249cc384c6e342491ccef0998f33a4f2940b80264f5a3e4b32b2 SHA512 3b419ddbdc4aa3a28d92bf204448090c168d6a844d570886f982129f9e650c7112bbf95b727baf6c9f0f2fd6200c75eb68b6b71fd8684e01365eaf964dea1ea1
diff --git a/dev-lang/idris2/idris2-0.5.1_p20211112.ebuild b/dev-lang/idris2/idris2-0.5.1_p20211112.ebuild
new file mode 100644
index 000000000000..8069d5960163
--- /dev/null
+++ b/dev-lang/idris2/idris2-0.5.1_p20211112.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+COMMIT_HASH="ba180706d607945d8b419301f4362471d97a306a"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Purely functional programming language with first class types"
+HOMEPAGE="https://idris-lang.org/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/idris-lang/Idris2.git"
+else
+ SRC_URI="https://github.com/idris-lang/Idris2/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN^}-${COMMIT_HASH}"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="+chez doc racket test-full"
+REQUIRED_USE="^^ ( chez racket )"
+
+RDEPEND="
+ dev-libs/gmp
+ chez? ( dev-scheme/chez[threads] )
+ racket? ( dev-scheme/racket[threads] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? ( dev-python/sphinx_rtd_theme )
+ test-full? (
+ dev-scheme/chez[threads]
+ dev-scheme/racket[threads]
+ net-libs/nodejs
+ )
+"
+
+# Generated via "SCHEME", not CC
+QA_FLAGS_IGNORED="usr/lib/idris2/bin/idris2_app/idris2
+ usr/lib/idris2/bin/idris2_app/idris2-boot"
+QA_PRESTRIPPED="${QA_FLAGS_IGNORED}"
+
+src_prepare() {
+ # Clean up environment of Idris and Racket variables
+ unset IDRIS2_DATA IDRIS2_INC_CGS IDRIS2_LIBS IDRIS2_PACKAGE_PATH
+ unset IDRIS2_PATH IDRIS2_PREFIX
+ unset PLTUSERHOME
+
+ tc-export AR CC CXX LD RANLIB
+ export CFLAGS
+ sed -i '/^CFLAGS/d' ./support/*/Makefile || die
+
+ # Fix "PREFIX"
+ sed -i 's|$(HOME)/.idris2|/usr/lib/idris2|g' ./config.mk || die
+
+ # Bad tests
+ # > Missing incremental compile data, reverting to whole program compilation
+ sed -i 's|"chez033",||g' ./tests/Main.idr || die
+
+ default
+}
+
+src_configure() {
+ export IDRIS2_VERSION=${PV}
+ export SCHEME=$(usex chez chezscheme racket)
+
+ if use chez; then
+ export IDRIS2_CG=chez
+ export BOOTSTRAP_TARGET=bootstrap
+ elif use racket; then
+ export IDRIS2_CG=racket
+ export BOOTSTRAP_TARGET=bootstrap-racket
+ else
+ die "Neither chez nor racket was chosen"
+ fi
+}
+
+src_compile() {
+ # > jobserver unavailable
+ # This is caused by Makefile using a script which in turn calls make
+ # https://github.com/idris-lang/Idris2/issues/2152
+ emake SCHEME=${SCHEME} ${BOOTSTRAP_TARGET} -j1
+
+ use doc && emake -C ./docs html
+}
+
+src_test() {
+ emake SCHEME=${SCHEME} bootstrap-test
+}
+
+src_install() {
+ # "DESTDIR" variable is not respected
+ emake IDRIS2_PREFIX="${D}/usr/lib/idris2" PREFIX="${D}/usr/lib/idris2" install
+
+ dosym ../lib/${PN}/bin/${PN} /usr/bin/${PN}
+
+ einstalldocs
+
+ # Install documentation
+ if use doc; then
+ insinto /usr/share/doc/${PF}/
+ doins -r ./docs/build/html
+ fi
+}
diff --git a/dev-lang/idris2/metadata.xml b/dev-lang/idris2/metadata.xml
new file mode 100644
index 000000000000..0c84b056b4e8
--- /dev/null
+++ b/dev-lang/idris2/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>scheme@gentoo.org</email>
+ <name>Gentoo Scheme Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Idris is a programming language designed to encourage Type-Driven
+ Development.
+ In type-driven development, types are tools for constructing programs.
+ We treat the type as the plan for a program, and use the compiler
+ and type checker as our assistant, guiding us to a complete program that
+ satisfies the type. The more expressive the type is that we give up front,
+ the more confidence we can have that the resulting program will be correct.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/idris-lang/Idris2/issues</bugs-to>
+ <remote-id type="github">idris-lang/Idris2></remote-id>
+ </upstream>
+ <use>
+ <flag name="chez">build using <pkg>dev-scheme/chez</pkg></flag>
+ <flag name="racket">build using <pkg>dev-scheme/racket</pkg></flag>
+ <flag name="test-full">pull in depedndencies to run all tests</flag>
+ </use>
+</pkgmetadata>