summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-11-04 15:24:39 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-11-04 15:24:39 +0100
commit59e5b94ccd20a044eaa752ca5077c7d6d2b065b4 (patch)
tree9a94544db6a266b1e58adb63901597d1fa61262d /dev-lang
parentros-meta/bond_core: Bump to 1.8.1. (diff)
downloadgentoo-59e5b94ccd20a044eaa752ca5077c7d6d2b065b4.tar.gz
gentoo-59e5b94ccd20a044eaa752ca5077c7d6d2b065b4.tar.bz2
gentoo-59e5b94ccd20a044eaa752ca5077c7d6d2b065b4.zip
dev-lang/perl: Darwinism: Survival of the fittest command line switches. Bug 636370
Closes: https://bugs.gentoo.org/636370 Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/perl/perl-5.26.1-r1.ebuild7
-rw-r--r--dev-lang/perl/perl-5.26.9999.ebuild7
-rw-r--r--dev-lang/perl/perl-5.28.9999.ebuild7
3 files changed, 18 insertions, 3 deletions
diff --git a/dev-lang/perl/perl-5.26.1-r1.ebuild b/dev-lang/perl/perl-5.26.1-r1.ebuild
index cf6794475736..f4f6054d3728 100644
--- a/dev-lang/perl/perl-5.26.1-r1.ebuild
+++ b/dev-lang/perl/perl-5.26.1-r1.ebuild
@@ -347,6 +347,12 @@ src_configure() {
# Perl has problems compiling with -Os in your flags with glibc
use elibc_uclibc || replace-flags "-Os" "-O2"
+ # xlocale.h is going away in glibc-2.26, so it's counterproductive
+ # if we use it and include it in CORE/perl.h ... Perl builds just
+ # fine with glibc and locale.h only.
+ # However, the darwin prefix people have no locale.h ...
+ use elibc_glibc && myconf -Ui_xlocale
+
# This flag makes compiling crash in interesting ways
filter-flags "-malign-double"
@@ -511,7 +517,6 @@ src_configure() {
-Dsh="${EPREFIX}"/bin/sh \
-Dtargetsh="${EPREFIX}"/bin/sh \
-Uusenm \
- -Ui_xlocale \
"${myconf[@]}" \
"${EXTRA_ECONF[@]}"
diff --git a/dev-lang/perl/perl-5.26.9999.ebuild b/dev-lang/perl/perl-5.26.9999.ebuild
index e8cc6de7891f..3dc88edc18b6 100644
--- a/dev-lang/perl/perl-5.26.9999.ebuild
+++ b/dev-lang/perl/perl-5.26.9999.ebuild
@@ -347,6 +347,12 @@ src_configure() {
# Perl has problems compiling with -Os in your flags with glibc
use elibc_uclibc || replace-flags "-Os" "-O2"
+ # xlocale.h is going away in glibc-2.26, so it's counterproductive
+ # if we use it and include it in CORE/perl.h ... Perl builds just
+ # fine with glibc and locale.h only.
+ # However, the darwin prefix people have no locale.h ...
+ use elibc_glibc && myconf -Ui_xlocale
+
# This flag makes compiling crash in interesting ways
filter-flags "-malign-double"
@@ -511,7 +517,6 @@ src_configure() {
-Dsh="${EPREFIX}"/bin/sh \
-Dtargetsh="${EPREFIX}"/bin/sh \
-Uusenm \
- -Ui_xlocale \
"${myconf[@]}" \
"${EXTRA_ECONF[@]}"
diff --git a/dev-lang/perl/perl-5.28.9999.ebuild b/dev-lang/perl/perl-5.28.9999.ebuild
index 610c42927718..70e967b70d3e 100644
--- a/dev-lang/perl/perl-5.28.9999.ebuild
+++ b/dev-lang/perl/perl-5.28.9999.ebuild
@@ -347,6 +347,12 @@ src_configure() {
# Perl has problems compiling with -Os in your flags with glibc
use elibc_uclibc || replace-flags "-Os" "-O2"
+ # xlocale.h is going away in glibc-2.26, so it's counterproductive
+ # if we use it and include it in CORE/perl.h ... Perl builds just
+ # fine with glibc and locale.h only.
+ # However, the darwin prefix people have no locale.h ...
+ use elibc_glibc && myconf -Ui_xlocale
+
# This flag makes compiling crash in interesting ways
filter-flags "-malign-double"
@@ -511,7 +517,6 @@ src_configure() {
-Dsh="${EPREFIX}"/bin/sh \
-Dtargetsh="${EPREFIX}"/bin/sh \
-Uusenm \
- -Ui_xlocale \
"${myconf[@]}" \
"${EXTRA_ECONF[@]}"