summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-01-03 20:44:01 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-01-03 21:29:57 +0100
commit5ae313ebe4d74328743a7acd759b08fdc472f281 (patch)
tree8b723aa5897bd7b0782c36389c4a5943405f641b /dev-lang
parentgames-emulation/ppsspp: bump to 1.14.4 (diff)
downloadgentoo-5ae313ebe4d74328743a7acd759b08fdc472f281.tar.gz
gentoo-5ae313ebe4d74328743a7acd759b08fdc472f281.tar.bz2
gentoo-5ae313ebe4d74328743a7acd759b08fdc472f281.zip
dev-lang/nim: drop old 1.6.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/nim/Manifest1
-rw-r--r--dev-lang/nim/nim-1.6.4.ebuild92
2 files changed, 0 insertions, 93 deletions
diff --git a/dev-lang/nim/Manifest b/dev-lang/nim/Manifest
index 9266eadbb25f..c47f0791449f 100644
--- a/dev-lang/nim/Manifest
+++ b/dev-lang/nim/Manifest
@@ -1,5 +1,4 @@
DIST nim-1.6.10.tar.xz 5216284 BLAKE2B d5b7bdc488086260b84700e3022ff7fc45b98d78574a3d2e288c95968a580fa644e47612dc60d6e63f5e85687f5b59a28128be746abc55bd6d4527344dc3ab14 SHA512 2ba6c4db68030ace2b4dd9b7f85d2b7c882c62e8f7f68bd0b82f548c91c300ab0e03c66f56c678127058f56b75a5550dec48d68eb6d666a179994cd1a6e2cc47
-DIST nim-1.6.4.tar.xz 5130208 BLAKE2B d0f297581677bbb9fb185a8b4198f48bb58efe81a1624f62051bc1e0a93f879a0cec172f11a41784ca715ba3c151dc5307e96c15c54908aa40df406040891d6c SHA512 f4d082f37f0e675e8cdb4340d67f2e58b5e6ac5bb51dab1ded5417097f3b86d71fa585ef12ee1c3cd5b17285589cbe9d5658fcb29c98547f7967a1b6f0cb4646
DIST nim-1.6.6.tar.xz 5149956 BLAKE2B 2fd1b40f1ecc1200255052d9e013c55287d3e01337146d0b1386d0f3fc9c14fda1e8e82ee289e782c77a573c1ae0985ea7f900f61e6b9824a9eb4b5c803c7f71 SHA512 6ea8d3f61adae48184dd0e3ac393296fd3bd5ead818e7dee949f43eccbd0b6229ebfc474353ddd63cc734f82c3247998fbfe88362061983f978ad8d0ab7fa677
DIST nim-1.6.8.tar.xz 5219880 BLAKE2B 16eac6f302b4ef1df14deaa0350e0e5553c7613515cc3e79cbe025af70955bef29c8261a1f91ba901023d9c53f9f00d62116301eb5a4ee4bb5314bb1e25a5755 SHA512 dd046dd393136fdcb78f463e267756bdb990b08e80e3a8be7fec1995b47a930447468e12bb9a59db6ec5546117f62ff4ccd032959879ef2d1d06a7bc5c438f83
DIST nim-patches-1.6.6.tar.gz 1975 BLAKE2B 75490f4c61f4d920aadb2ad5908cb2773e270f80cee95f937ede8125bad5688b71840ed7f48659db892e4017437a0454b38eab18ae8b13c6b48207d0a7714371 SHA512 4d1590e7d05ad64432b943f8da9edb2b05213400181d1e07a0e40f479afbceb1997d0ea0f05a73d550afe60cf4b657f7e34840907ea16c3b9e96824e9f29e0e5
diff --git a/dev-lang/nim/nim-1.6.4.ebuild b/dev-lang/nim/nim-1.6.4.ebuild
deleted file mode 100644
index 11af93abf307..000000000000
--- a/dev-lang/nim/nim-1.6.4.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit bash-completion-r1 multiprocessing toolchain-funcs
-
-DESCRIPTION="compiled, garbage-collected systems programming language"
-HOMEPAGE="https://nim-lang.org/"
-SRC_URI="https://nim-lang.org/download/${P}.tar.xz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="debug +readline"
-RESTRICT="test" # need to sort out depends and numerous failures
-
-RDEPEND="readline? ( sys-libs/readline:0= )"
-DEPEND="${RDEPEND}"
-# BDEPEND="test? ( net-libs/nodejs )"
-
-PATCHES=( "${FILESDIR}"/${PN}-0.20.0-paths.patch )
-
-# Generated by nim
-QA_FLAGS_IGNORED="
-usr/bin/atlas
-usr/bin/nim
-usr/bin/nim_dbg
-usr/bin/nimble
-usr/bin/nimgrep
-usr/bin/nimpretty
-usr/bin/nimsuggest
-usr/bin/testament
-"
-
-_run() {
- echo "Running: ${@}"
- PATH="${S}/bin:${PATH}" "${@}" || die "Failed: \"${*}\""
-}
-
-nim_use_enable() {
- [[ -z "${2}" ]] && die "usage: nim_use_enable <USE flag> <compiler flag>"
- use "${1}" && echo "-d:${2}"
-}
-
-src_configure() {
- export XDG_CACHE_HOME="${T}/cache" # 667182
- unset NIMBLE_DIR
- tc-export CC CXX LD
-
- local build_type
- if use debug ; then
- build_type="debug"
- else
- build_type="release"
- fi
- export NIM_OPTS=( --parallelBuild:$(makeopts_jobs) -d:${build_type} )
-
- # Override defaults
- echo "gcc.exe = \"$(tc-getCC)\"" >> config/nim.cfg || die
- echo "gcc.linkerexe = \"$(tc-getCC)\"" >> config/nim.cfg || die
- echo "gcc.cpp.exe = \"$(tc-getCXX)\"" >> config/nim.cfg || die
- echo "gcc.cpp.linkerexe = \"$(tc-getCXX)\"" >> config/nim.cfg || die
-}
-
-src_compile() {
- _run bash ./build.sh
-
- _run ./bin/nim ${NIM_OPTS[@]} compile koch
- _run ./koch boot ${NIM_OPTS[@]} $(nim_use_enable readline useGnuReadline)
- _run ./koch tools ${NIM_OPTS[@]}
-}
-
-src_test() {
- _run ./koch test
-}
-
-src_install() {
- _run ./koch install "${ED}"
-
- # "./koch install" installs only "nim" binary
- # but not the rest
- exeinto /usr/bin
- local exe
- for exe in bin/* ; do
- [[ "${exe}" == bin/nim ]] && continue
- doexe "${exe}"
- done
-
- newbashcomp tools/nim.bash-completion nim
- newbashcomp dist/nimble/nimble.bash-completion nimble
-}