summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2016-03-10 02:47:49 +0200
committerMart Raudsepp <leio@gentoo.org>2016-03-10 02:47:49 +0200
commit6400680685f10e734104cad1414753c9c7ff9f93 (patch)
tree72e4d29f8831b51e2b1907bf3ba02e2ba0dfbcdb /dev-lang
parentdev-python/pip: Restore dependency on dev-python/setuptools (diff)
downloadgentoo-6400680685f10e734104cad1414753c9c7ff9f93.tar.gz
gentoo-6400680685f10e734104cad1414753c9c7ff9f93.tar.bz2
gentoo-6400680685f10e734104cad1414753c9c7ff9f93.zip
dev-lang/orc: bump to 0.4.25
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/orc/Manifest1
-rw-r--r--dev-lang/orc/orc-0.4.25.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-lang/orc/Manifest b/dev-lang/orc/Manifest
index a486c2267f53..088496133558 100644
--- a/dev-lang/orc/Manifest
+++ b/dev-lang/orc/Manifest
@@ -1,2 +1,3 @@
DIST orc-0.4.23.tar.xz 450076 SHA256 767eaebce2941737b43368225ec54598b3055ca78b4dc50c4092f5fcdc0bdfe7 SHA512 e12bca0dcc7230da825834f50b88ff531a6aed83a29ccc5b57e969adb1af7ceb2c1d4dd04cd248e38db92fded6edc809c7deba42cd1ddeacd62b0e922950d92e WHIRLPOOL 62df2cbc9943b7c7e625519d0f16bf1becbce78b26ccaebbc315ac43f2ceee689b6ad6632ce5e49123aa59d97ec73c3268a3fd6b81f94ca4dcf97de7a3a222e5
DIST orc-0.4.24.tar.xz 455880 SHA256 338cd493b5247300149821c6312bdf7422a3593ae98691fc75d7e4fe727bd39b SHA512 f40f692873a4fa506379a1b9e3ed1d329ee42470fb0b083aec5f993c1b6f756e63b772dbf664ca3328531c2f9be141ca43ed79a49572c1f02d82f85aa4306216 WHIRLPOOL 2d41972933ede160a9b85f6ed2ee4aabefc51557f2f65d30f9c65b32e4fcc6e14b8bf55609859b5084997bdc875a1249114de31ec59d944e993fc9e2f0651bc1
+DIST orc-0.4.25.tar.xz 467184 SHA256 c1b1d54a58f26d483f0b3881538984789fe5d5460ab8fab74a1cacbd3d1c53d1 SHA512 13f636e3ab86e725e15f885462db1944744b8389f263b7afa2279c0e68fb8e71344a646ecb8b7a7fce03e93ab78351a1b79d5eaef106ab8e1d808e82b514316a WHIRLPOOL 4d186f632a828856f73d8174aaea4ac60f4e9d8accbba65da50e8348f06748ea3961fab697f5c44d883711399f7b7af8a46aeecb8d594cc5f1225580c6091011
diff --git a/dev-lang/orc/orc-0.4.25.ebuild b/dev-lang/orc/orc-0.4.25.ebuild
new file mode 100644
index 000000000000..f8a9c491e1f5
--- /dev/null
+++ b/dev-lang/orc/orc-0.4.25.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+inherit autotools-multilib flag-o-matic gnome2-utils pax-utils
+
+DESCRIPTION="The Oil Runtime Compiler, a just-in-time compiler for array operations"
+HOMEPAGE="http://gstreamer.freedesktop.org/"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="BSD BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples pax_kernel static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ >=dev-util/gtk-doc-am-1.12
+"
+
+src_prepare() {
+ if ! use examples; then
+ sed -e '/SUBDIRS/ s:examples::' \
+ -i Makefile.am Makefile.in || die
+ fi
+
+ gnome2_environment_reset #556160
+}
+
+src_configure() {
+ # any optimisation on PPC/Darwin yields in a complaint from the assembler
+ # Parameter error: r0 not allowed for parameter %lu (code as 0 not r0)
+ # the same for Intel/Darwin, although the error message there is different
+ # but along the same lines
+ [[ ${CHOST} == *-darwin* ]] && filter-flags -O*
+ autotools-multilib_src_configure
+}
+
+src_install() {
+ autotools-multilib_src_install
+ if use pax_kernel; then
+ pax-mark m "${ED}"usr/bin/orc-bugreport
+ pax-mark m "${ED}"usr/bin/orcc
+ pax-mark m "${ED}"usr/$(get_libdir)/liborc*.so*
+ fi
+}
+
+pkg_postinst() {
+ if use pax_kernel; then
+ ewarn "Please run \"revdep-pax\" after installation".
+ ewarn "It's provided by sys-apps/elfix."
+ fi
+}