summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-12-08 04:32:12 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-12-08 11:10:58 +0100
commit6c21e4a628238d17435a65cbf087dada1951d0bb (patch)
tree95e7cda5f8a4ef36a57a29aa8ba271dfe6e7af7e /dev-lang
parentdev-lang/typescript: drop old 4.8.3-r1 (diff)
downloadgentoo-6c21e4a628238d17435a65cbf087dada1951d0bb.tar.gz
gentoo-6c21e4a628238d17435a65cbf087dada1951d0bb.tar.bz2
gentoo-6c21e4a628238d17435a65cbf087dada1951d0bb.zip
dev-lang/typescript: bump to 4.9.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/typescript/Manifest1
-rw-r--r--dev-lang/typescript/typescript-4.9.4.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-lang/typescript/Manifest b/dev-lang/typescript/Manifest
index 58d75cf4916d..ce953be856b7 100644
--- a/dev-lang/typescript/Manifest
+++ b/dev-lang/typescript/Manifest
@@ -1,2 +1,3 @@
DIST typescript-4.8.4.tgz 11944158 BLAKE2B aa3d97ba50209dd7e313e28d3dcb81e17a93d33ce4a1401186a34bb05e23e972232245df1c8832f44ba418883eb1aa88ee4fbba2a581ee533f99c48823bb59f5 SHA512 40287ef39982cbe8742067dff2be575b339549b04ef8a7de62b31087b349e7c42e8f0704db6bbe3544a6531a85fae9fbd0ff465cac5ad8708d8934cc2649f28d
DIST typescript-4.9.3.tgz 11618300 BLAKE2B 8a11cae27e9873750ebc1c4d9f0116f0ac291b17138df277188d754d36a33668476acbef56b9903c082372e2780253728ef5a9cc2cf57d872014b6fad2842cd2 SHA512 0887c6cd37a56ca3449cba4b7461607722a11b6dc229d2a040f38173e39436b909dafafe292cec495e64ab989684441ba24faabb1806ceb02d1960b253bb479c
+DIST typescript-4.9.4.tgz 11619457 BLAKE2B 97f19fe325ba7f74d845779eb94919895c44a9603ecec9f1aec5d332a49976f1b1133686a2969205e01c49dfe460c8f8b3eac384134d592478e49af1748a08fb SHA512 533f9d4d7633c575dbb05a4cf3a5a1ddd282c6b42a51c54cc70539e28af09498cea4eddaa3c2fb8f9947f9d59f4f0802c08b8cf4643692f568b736093174c166
diff --git a/dev-lang/typescript/typescript-4.9.4.ebuild b/dev-lang/typescript/typescript-4.9.4.ebuild
new file mode 100644
index 000000000000..02196457057b
--- /dev/null
+++ b/dev-lang/typescript/typescript-4.9.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Superset of JavaScript with optional static typing, classes and interfaces"
+HOMEPAGE="https://www.typescriptlang.org/
+ https://github.com/microsoft/TypeScript/"
+SRC_URI="https://registry.npmjs.org/${PN}/-/${P}.tgz"
+S="${WORKDIR}"/package
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+
+RDEPEND="net-libs/nodejs"
+BDEPEND=">=net-libs/nodejs-16[npm]"
+
+src_compile() {
+ # Skip, nothing to compile here.
+ :
+}
+
+src_install() {
+ local myopts=(
+ --audit false
+ --color false
+ --foreground-scripts
+ --global
+ --offline
+ --omit dev
+ --prefix "${ED}"/usr
+ --progress false
+ --verbose
+ )
+ npm ${myopts[@]} install "${DISTDIR}"/${P}.tgz || die "npm install failed"
+
+ dodoc *.md *.txt
+}