summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-03-12 17:27:21 +0100
committerMichał Górny <mgorny@gentoo.org>2016-03-12 17:33:16 +0100
commit7dc8797ff5ddcca23b400cc88ca7e1de0a90b936 (patch)
treed15ee3e235f7c28017f2212fe205b5c384269771 /dev-lang
parentdev-lang/ekopath: Convert to EAPI=6 (diff)
downloadgentoo-7dc8797ff5ddcca23b400cc88ca7e1de0a90b936.tar.gz
gentoo-7dc8797ff5ddcca23b400cc88ca7e1de0a90b936.tar.bz2
gentoo-7dc8797ff5ddcca23b400cc88ca7e1de0a90b936.zip
dev-lang/ekopath: Add slotted variants of the old versions
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ekopath/ekopath-6.0.619_p20151213-r1.ebuild63
-rw-r--r--dev-lang/ekopath/ekopath-6.0.619_p20151213-r100.ebuild4
-rw-r--r--dev-lang/ekopath/ekopath-6.0.637_p20151231-r1.ebuild63
-rw-r--r--dev-lang/ekopath/ekopath-6.0.637_p20151231-r100.ebuild4
-rw-r--r--dev-lang/ekopath/ekopath-6.0.661_p20160124-r1.ebuild63
-rw-r--r--dev-lang/ekopath/ekopath-6.0.661_p20160124-r100.ebuild4
-rw-r--r--dev-lang/ekopath/ekopath-6.0.705_p20160303-r1.ebuild63
-rw-r--r--dev-lang/ekopath/ekopath-6.0.705_p20160303-r100.ebuild4
-rw-r--r--dev-lang/ekopath/ekopath-6.0.713_p20160311-r1.ebuild63
-rw-r--r--dev-lang/ekopath/ekopath-6.0.713_p20160311-r100.ebuild4
10 files changed, 325 insertions, 10 deletions
diff --git a/dev-lang/ekopath/ekopath-6.0.619_p20151213-r1.ebuild b/dev-lang/ekopath/ekopath-6.0.619_p20151213-r1.ebuild
new file mode 100644
index 000000000000..f71706c8bc6d
--- /dev/null
+++ b/dev-lang/ekopath/ekopath-6.0.619_p20151213-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit pax-utils versionator
+
+MY_PV=$(get_version_component_range 1-3)
+MY_P=${PN}-${MY_PV}
+DATE=$(get_version_component_range 4)
+DATE=${DATE#p}
+DATE=${DATE:0:4}-${DATE:4:2}-${DATE:6}
+INSTALLER=${PN}-${DATE}-installer.run
+
+DESCRIPTION="PathScale EKOPath Compiler Suite"
+HOMEPAGE="http://www.pathscale.com/ekopath-compiler-suite"
+SRC_URI="http://c591116.r16.cf2.rackcdn.com/${PN}/nightly/Linux/${INSTALLER}"
+
+LICENSE="all-rights-reserved"
+SLOT="${MY_PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="!!app-arch/rpm"
+RDEPEND="!dev-lang/ekopath:0/${MY_PV}"
+
+RESTRICT="bindist mirror"
+
+QA_PREBUILT="opt/${MY_P}/*"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}/${INSTALLER}" "${S}/" || die
+ chmod +x "${S}/${INSTALLER}" || die
+}
+
+src_install() {
+ # EI_PAX marking is obsolete and PT_PAX breaks the binary.
+ # We must use XT_PAX to run the installer.
+ if [[ ${PAX_MARKINGS} == "XT" ]]; then
+ pax-mark m "${INSTALLER}"
+ fi
+
+ ./"${INSTALLER}" \
+ --prefix "${ED%/}/opt/${MY_P}" \
+ --mode unattended || die
+
+ if [[ ! -d ${ED%/}/opt/${MY_P}/lib/${MY_PV} ]]; then
+ local guess
+ cd "${ED%/}/opt/${MY_P}/lib" && guess=( * )
+
+ if [[ ${guess[@]} ]]; then
+ die "Incorrect release version in PV, guessing it should be: ${guess[*]}"
+ else
+ die "No libdir installed"
+ fi
+ fi
+ [[ -x ${ED%}/opt/${MY_P}/bin/pathcc ]] || die "No pathcc executable was installed, your hardware is unsupported most likely"
+
+ rm -r "${ED}/opt/${MY_P}"/uninstall* || die
+}
diff --git a/dev-lang/ekopath/ekopath-6.0.619_p20151213-r100.ebuild b/dev-lang/ekopath/ekopath-6.0.619_p20151213-r100.ebuild
index 447e726cd4c2..6a39c1078870 100644
--- a/dev-lang/ekopath/ekopath-6.0.619_p20151213-r100.ebuild
+++ b/dev-lang/ekopath/ekopath-6.0.619_p20151213-r100.ebuild
@@ -18,12 +18,12 @@ HOMEPAGE="http://www.pathscale.com/ekopath-compiler-suite"
SRC_URI="http://c591116.r16.cf2.rackcdn.com/${PN}/nightly/Linux/${INSTALLER}"
LICENSE="all-rights-reserved"
-SLOT="0"
+SLOT="0/${MY_PV}"
KEYWORDS="~amd64"
IUSE=""
DEPEND="!!app-arch/rpm"
-RDEPEND=""
+RDEPEND="!dev-lang/ekopath:${MY_PV}"
RESTRICT="bindist mirror"
diff --git a/dev-lang/ekopath/ekopath-6.0.637_p20151231-r1.ebuild b/dev-lang/ekopath/ekopath-6.0.637_p20151231-r1.ebuild
new file mode 100644
index 000000000000..f71706c8bc6d
--- /dev/null
+++ b/dev-lang/ekopath/ekopath-6.0.637_p20151231-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit pax-utils versionator
+
+MY_PV=$(get_version_component_range 1-3)
+MY_P=${PN}-${MY_PV}
+DATE=$(get_version_component_range 4)
+DATE=${DATE#p}
+DATE=${DATE:0:4}-${DATE:4:2}-${DATE:6}
+INSTALLER=${PN}-${DATE}-installer.run
+
+DESCRIPTION="PathScale EKOPath Compiler Suite"
+HOMEPAGE="http://www.pathscale.com/ekopath-compiler-suite"
+SRC_URI="http://c591116.r16.cf2.rackcdn.com/${PN}/nightly/Linux/${INSTALLER}"
+
+LICENSE="all-rights-reserved"
+SLOT="${MY_PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="!!app-arch/rpm"
+RDEPEND="!dev-lang/ekopath:0/${MY_PV}"
+
+RESTRICT="bindist mirror"
+
+QA_PREBUILT="opt/${MY_P}/*"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}/${INSTALLER}" "${S}/" || die
+ chmod +x "${S}/${INSTALLER}" || die
+}
+
+src_install() {
+ # EI_PAX marking is obsolete and PT_PAX breaks the binary.
+ # We must use XT_PAX to run the installer.
+ if [[ ${PAX_MARKINGS} == "XT" ]]; then
+ pax-mark m "${INSTALLER}"
+ fi
+
+ ./"${INSTALLER}" \
+ --prefix "${ED%/}/opt/${MY_P}" \
+ --mode unattended || die
+
+ if [[ ! -d ${ED%/}/opt/${MY_P}/lib/${MY_PV} ]]; then
+ local guess
+ cd "${ED%/}/opt/${MY_P}/lib" && guess=( * )
+
+ if [[ ${guess[@]} ]]; then
+ die "Incorrect release version in PV, guessing it should be: ${guess[*]}"
+ else
+ die "No libdir installed"
+ fi
+ fi
+ [[ -x ${ED%}/opt/${MY_P}/bin/pathcc ]] || die "No pathcc executable was installed, your hardware is unsupported most likely"
+
+ rm -r "${ED}/opt/${MY_P}"/uninstall* || die
+}
diff --git a/dev-lang/ekopath/ekopath-6.0.637_p20151231-r100.ebuild b/dev-lang/ekopath/ekopath-6.0.637_p20151231-r100.ebuild
index 447e726cd4c2..6a39c1078870 100644
--- a/dev-lang/ekopath/ekopath-6.0.637_p20151231-r100.ebuild
+++ b/dev-lang/ekopath/ekopath-6.0.637_p20151231-r100.ebuild
@@ -18,12 +18,12 @@ HOMEPAGE="http://www.pathscale.com/ekopath-compiler-suite"
SRC_URI="http://c591116.r16.cf2.rackcdn.com/${PN}/nightly/Linux/${INSTALLER}"
LICENSE="all-rights-reserved"
-SLOT="0"
+SLOT="0/${MY_PV}"
KEYWORDS="~amd64"
IUSE=""
DEPEND="!!app-arch/rpm"
-RDEPEND=""
+RDEPEND="!dev-lang/ekopath:${MY_PV}"
RESTRICT="bindist mirror"
diff --git a/dev-lang/ekopath/ekopath-6.0.661_p20160124-r1.ebuild b/dev-lang/ekopath/ekopath-6.0.661_p20160124-r1.ebuild
new file mode 100644
index 000000000000..f71706c8bc6d
--- /dev/null
+++ b/dev-lang/ekopath/ekopath-6.0.661_p20160124-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit pax-utils versionator
+
+MY_PV=$(get_version_component_range 1-3)
+MY_P=${PN}-${MY_PV}
+DATE=$(get_version_component_range 4)
+DATE=${DATE#p}
+DATE=${DATE:0:4}-${DATE:4:2}-${DATE:6}
+INSTALLER=${PN}-${DATE}-installer.run
+
+DESCRIPTION="PathScale EKOPath Compiler Suite"
+HOMEPAGE="http://www.pathscale.com/ekopath-compiler-suite"
+SRC_URI="http://c591116.r16.cf2.rackcdn.com/${PN}/nightly/Linux/${INSTALLER}"
+
+LICENSE="all-rights-reserved"
+SLOT="${MY_PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="!!app-arch/rpm"
+RDEPEND="!dev-lang/ekopath:0/${MY_PV}"
+
+RESTRICT="bindist mirror"
+
+QA_PREBUILT="opt/${MY_P}/*"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}/${INSTALLER}" "${S}/" || die
+ chmod +x "${S}/${INSTALLER}" || die
+}
+
+src_install() {
+ # EI_PAX marking is obsolete and PT_PAX breaks the binary.
+ # We must use XT_PAX to run the installer.
+ if [[ ${PAX_MARKINGS} == "XT" ]]; then
+ pax-mark m "${INSTALLER}"
+ fi
+
+ ./"${INSTALLER}" \
+ --prefix "${ED%/}/opt/${MY_P}" \
+ --mode unattended || die
+
+ if [[ ! -d ${ED%/}/opt/${MY_P}/lib/${MY_PV} ]]; then
+ local guess
+ cd "${ED%/}/opt/${MY_P}/lib" && guess=( * )
+
+ if [[ ${guess[@]} ]]; then
+ die "Incorrect release version in PV, guessing it should be: ${guess[*]}"
+ else
+ die "No libdir installed"
+ fi
+ fi
+ [[ -x ${ED%}/opt/${MY_P}/bin/pathcc ]] || die "No pathcc executable was installed, your hardware is unsupported most likely"
+
+ rm -r "${ED}/opt/${MY_P}"/uninstall* || die
+}
diff --git a/dev-lang/ekopath/ekopath-6.0.661_p20160124-r100.ebuild b/dev-lang/ekopath/ekopath-6.0.661_p20160124-r100.ebuild
index 447e726cd4c2..6a39c1078870 100644
--- a/dev-lang/ekopath/ekopath-6.0.661_p20160124-r100.ebuild
+++ b/dev-lang/ekopath/ekopath-6.0.661_p20160124-r100.ebuild
@@ -18,12 +18,12 @@ HOMEPAGE="http://www.pathscale.com/ekopath-compiler-suite"
SRC_URI="http://c591116.r16.cf2.rackcdn.com/${PN}/nightly/Linux/${INSTALLER}"
LICENSE="all-rights-reserved"
-SLOT="0"
+SLOT="0/${MY_PV}"
KEYWORDS="~amd64"
IUSE=""
DEPEND="!!app-arch/rpm"
-RDEPEND=""
+RDEPEND="!dev-lang/ekopath:${MY_PV}"
RESTRICT="bindist mirror"
diff --git a/dev-lang/ekopath/ekopath-6.0.705_p20160303-r1.ebuild b/dev-lang/ekopath/ekopath-6.0.705_p20160303-r1.ebuild
new file mode 100644
index 000000000000..f71706c8bc6d
--- /dev/null
+++ b/dev-lang/ekopath/ekopath-6.0.705_p20160303-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit pax-utils versionator
+
+MY_PV=$(get_version_component_range 1-3)
+MY_P=${PN}-${MY_PV}
+DATE=$(get_version_component_range 4)
+DATE=${DATE#p}
+DATE=${DATE:0:4}-${DATE:4:2}-${DATE:6}
+INSTALLER=${PN}-${DATE}-installer.run
+
+DESCRIPTION="PathScale EKOPath Compiler Suite"
+HOMEPAGE="http://www.pathscale.com/ekopath-compiler-suite"
+SRC_URI="http://c591116.r16.cf2.rackcdn.com/${PN}/nightly/Linux/${INSTALLER}"
+
+LICENSE="all-rights-reserved"
+SLOT="${MY_PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="!!app-arch/rpm"
+RDEPEND="!dev-lang/ekopath:0/${MY_PV}"
+
+RESTRICT="bindist mirror"
+
+QA_PREBUILT="opt/${MY_P}/*"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}/${INSTALLER}" "${S}/" || die
+ chmod +x "${S}/${INSTALLER}" || die
+}
+
+src_install() {
+ # EI_PAX marking is obsolete and PT_PAX breaks the binary.
+ # We must use XT_PAX to run the installer.
+ if [[ ${PAX_MARKINGS} == "XT" ]]; then
+ pax-mark m "${INSTALLER}"
+ fi
+
+ ./"${INSTALLER}" \
+ --prefix "${ED%/}/opt/${MY_P}" \
+ --mode unattended || die
+
+ if [[ ! -d ${ED%/}/opt/${MY_P}/lib/${MY_PV} ]]; then
+ local guess
+ cd "${ED%/}/opt/${MY_P}/lib" && guess=( * )
+
+ if [[ ${guess[@]} ]]; then
+ die "Incorrect release version in PV, guessing it should be: ${guess[*]}"
+ else
+ die "No libdir installed"
+ fi
+ fi
+ [[ -x ${ED%}/opt/${MY_P}/bin/pathcc ]] || die "No pathcc executable was installed, your hardware is unsupported most likely"
+
+ rm -r "${ED}/opt/${MY_P}"/uninstall* || die
+}
diff --git a/dev-lang/ekopath/ekopath-6.0.705_p20160303-r100.ebuild b/dev-lang/ekopath/ekopath-6.0.705_p20160303-r100.ebuild
index 447e726cd4c2..6a39c1078870 100644
--- a/dev-lang/ekopath/ekopath-6.0.705_p20160303-r100.ebuild
+++ b/dev-lang/ekopath/ekopath-6.0.705_p20160303-r100.ebuild
@@ -18,12 +18,12 @@ HOMEPAGE="http://www.pathscale.com/ekopath-compiler-suite"
SRC_URI="http://c591116.r16.cf2.rackcdn.com/${PN}/nightly/Linux/${INSTALLER}"
LICENSE="all-rights-reserved"
-SLOT="0"
+SLOT="0/${MY_PV}"
KEYWORDS="~amd64"
IUSE=""
DEPEND="!!app-arch/rpm"
-RDEPEND=""
+RDEPEND="!dev-lang/ekopath:${MY_PV}"
RESTRICT="bindist mirror"
diff --git a/dev-lang/ekopath/ekopath-6.0.713_p20160311-r1.ebuild b/dev-lang/ekopath/ekopath-6.0.713_p20160311-r1.ebuild
new file mode 100644
index 000000000000..f71706c8bc6d
--- /dev/null
+++ b/dev-lang/ekopath/ekopath-6.0.713_p20160311-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit pax-utils versionator
+
+MY_PV=$(get_version_component_range 1-3)
+MY_P=${PN}-${MY_PV}
+DATE=$(get_version_component_range 4)
+DATE=${DATE#p}
+DATE=${DATE:0:4}-${DATE:4:2}-${DATE:6}
+INSTALLER=${PN}-${DATE}-installer.run
+
+DESCRIPTION="PathScale EKOPath Compiler Suite"
+HOMEPAGE="http://www.pathscale.com/ekopath-compiler-suite"
+SRC_URI="http://c591116.r16.cf2.rackcdn.com/${PN}/nightly/Linux/${INSTALLER}"
+
+LICENSE="all-rights-reserved"
+SLOT="${MY_PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="!!app-arch/rpm"
+RDEPEND="!dev-lang/ekopath:0/${MY_PV}"
+
+RESTRICT="bindist mirror"
+
+QA_PREBUILT="opt/${MY_P}/*"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}/${INSTALLER}" "${S}/" || die
+ chmod +x "${S}/${INSTALLER}" || die
+}
+
+src_install() {
+ # EI_PAX marking is obsolete and PT_PAX breaks the binary.
+ # We must use XT_PAX to run the installer.
+ if [[ ${PAX_MARKINGS} == "XT" ]]; then
+ pax-mark m "${INSTALLER}"
+ fi
+
+ ./"${INSTALLER}" \
+ --prefix "${ED%/}/opt/${MY_P}" \
+ --mode unattended || die
+
+ if [[ ! -d ${ED%/}/opt/${MY_P}/lib/${MY_PV} ]]; then
+ local guess
+ cd "${ED%/}/opt/${MY_P}/lib" && guess=( * )
+
+ if [[ ${guess[@]} ]]; then
+ die "Incorrect release version in PV, guessing it should be: ${guess[*]}"
+ else
+ die "No libdir installed"
+ fi
+ fi
+ [[ -x ${ED%}/opt/${MY_P}/bin/pathcc ]] || die "No pathcc executable was installed, your hardware is unsupported most likely"
+
+ rm -r "${ED}/opt/${MY_P}"/uninstall* || die
+}
diff --git a/dev-lang/ekopath/ekopath-6.0.713_p20160311-r100.ebuild b/dev-lang/ekopath/ekopath-6.0.713_p20160311-r100.ebuild
index 447e726cd4c2..6a39c1078870 100644
--- a/dev-lang/ekopath/ekopath-6.0.713_p20160311-r100.ebuild
+++ b/dev-lang/ekopath/ekopath-6.0.713_p20160311-r100.ebuild
@@ -18,12 +18,12 @@ HOMEPAGE="http://www.pathscale.com/ekopath-compiler-suite"
SRC_URI="http://c591116.r16.cf2.rackcdn.com/${PN}/nightly/Linux/${INSTALLER}"
LICENSE="all-rights-reserved"
-SLOT="0"
+SLOT="0/${MY_PV}"
KEYWORDS="~amd64"
IUSE=""
DEPEND="!!app-arch/rpm"
-RDEPEND=""
+RDEPEND="!dev-lang/ekopath:${MY_PV}"
RESTRICT="bindist mirror"