summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Marineau <mike@marineau.org>2015-08-21 13:31:08 -0700
committerWilliam Hubbs <williamh@gentoo.org>2015-08-23 10:30:44 -0500
commit8bfc361e10505f53ee14c8f232d342aa68536758 (patch)
tree6031b1c48149364d1694ae4a8586ae2e009c4f7e /dev-lang
parentdev-tcltk/blt: Stable for HPPA PPC64 (bug #556122). (diff)
downloadgentoo-8bfc361e10505f53ee14c8f232d342aa68536758.tar.gz
gentoo-8bfc361e10505f53ee14c8f232d342aa68536758.tar.bz2
gentoo-8bfc361e10505f53ee14c8f232d342aa68536758.zip
dev-lang/go-bootstrap: avoid stripping test data files
Go includes a number of pre-built object files for testing. Since they are not actually executed and may not even be native to the local system stripping them is meaningless. This syncs up STRIP_MASK with the same list used by the latest go ebuilds. One file, src/debug/dwarf/testdata/typedef.elf, includes a build-id which causes a conflict with the go-1.4 when FEATURES=splitdebug is enabled. Fixes bug #549598
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/go-bootstrap/go-bootstrap-1.4.2.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-lang/go-bootstrap/go-bootstrap-1.4.2.ebuild b/dev-lang/go-bootstrap/go-bootstrap-1.4.2.ebuild
index 2610ffedd636..faba1caae7c3 100644
--- a/dev-lang/go-bootstrap/go-bootstrap-1.4.2.ebuild
+++ b/dev-lang/go-bootstrap/go-bootstrap-1.4.2.ebuild
@@ -26,9 +26,11 @@ RDEPEND=""
QA_MULTILIB_PATHS="usr/lib/go1.4/pkg/tool/.*/.*"
# The go language uses *.a files which are _NOT_ libraries and should not be
-# stripped.
-STRIP_MASK="/usr/lib/go1.4/pkg/linux*/*.a
- /usr/lib/go1.4/pkg/freebsd*/*.a /usr/lib/go1.4/pkg/darwin*/*.a"
+# stripped. The test data objects should also be left alone and unstripped.
+STRIP_MASK="/usr/lib/go1.4/pkg/*.a
+ /usr/lib/go1.4/src/debug/elf/testdata/*
+ /usr/lib/go1.4/src/debug/dwarf/testdata/*
+ /usr/lib/go1.4/src/runtime/race/*.syso"
S="${WORKDIR}"/go
@@ -63,7 +65,7 @@ src_install()
{
dodir /usr/lib/go1.4
exeinto /usr/lib/go1.4/bin
-doexe bin/*
+ doexe bin/*
insinto /usr/lib/go1.4
doins -r lib pkg src
fperms -R +x /usr/lib/go1.4/pkg/tool