summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2022-02-07 16:55:45 +0800
committerYixun Lan <dlan@gentoo.org>2022-02-07 16:55:45 +0800
commit992a3fd5df31571b945e98a3a89d500aa4501c11 (patch)
tree7283e8b02aa14a0bc2ee8db6df4c11c414f01b74 /dev-lang
parentdev-lang/tcc: keyword ~riscv (diff)
downloadgentoo-992a3fd5df31571b945e98a3a89d500aa4501c11.tar.gz
gentoo-992a3fd5df31571b945e98a3a89d500aa4501c11.tar.bz2
gentoo-992a3fd5df31571b945e98a3a89d500aa4501c11.zip
dev-lang/tcc: drop old
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/tcc/Manifest1
-rw-r--r--dev-lang/tcc/tcc-0.9.27.ebuild65
2 files changed, 0 insertions, 66 deletions
diff --git a/dev-lang/tcc/Manifest b/dev-lang/tcc/Manifest
index fb3b05d6eecc..67b6967077d6 100644
--- a/dev-lang/tcc/Manifest
+++ b/dev-lang/tcc/Manifest
@@ -1,2 +1 @@
-DIST tcc-0.9.27.tar.bz2 634999 BLAKE2B 9a76dac9f54fa0b64a72e874cfec9a4bd9b938d244d064b2e76bd31acfb9e48fdbdb8895132634be1dee4302293405bf75606a6804c8178afa8fd30daa53b73a SHA512 835184292d97c07f0ff7b36ec550e855e649b04e23c7e2a1c706d223409eb60708dc1ae969f28eba45e56c8b96ae56936b93caf9d8a13ac5adf119014d5367a7
DIST tcc-0.9.27_p20211022.tar.gz 893631 BLAKE2B f1a82498db65a9944f04a6c35897db6ceeea0e5d14ac383acc6b334fb2aa921a0e7b4badf647c101d064ceae1ee8d79ab91674a2d0faa2899b831a57e6148174 SHA512 5f40a0d31d63e876d1fb233758d9f58be2f14807bbc0847b7df3eb6bb8df0946100b58edb5a29caea8770201d02275daf0a3ca7668141151e931204ad7100fb3
diff --git a/dev-lang/tcc/tcc-0.9.27.ebuild b/dev-lang/tcc/tcc-0.9.27.ebuild
deleted file mode 100644
index 7090fdeb01d1..000000000000
--- a/dev-lang/tcc/tcc-0.9.27.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit toolchain-funcs
-
-DESCRIPTION="A very small C compiler for ix86/amd64"
-HOMEPAGE="https://bellard.org/tcc/"
-SRC_URI="https://download.savannah.gnu.org/releases/tinycc/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux"
-
-DEPEND="dev-lang/perl" # doc generation
-RDEPEND=""
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-src_prepare() {
- # Don't strip
- sed -i -e 's|$(INSTALL) -s|$(INSTALL)|' Makefile || die
-
- # Fix examples
- sed -i -e '1{
- i#! /usr/bin/tcc -run
- /^#!/d
- }' examples/ex*.c || die
- sed -i -e '1s/$/ -lX11/' examples/ex4.c || die
-
- # Fix texi2html invocation
- sed -i -e 's/-number//' Makefile || die
- sed -i -e 's/--sections//' Makefile || die
-
- eapply_user
-}
-
-src_configure() {
- use test && unset CFLAGS LDFLAGS # Tests run with CC=tcc etc, they will fail hard otherwise
- # better fixes welcome, it feels wrong to hack the env like this
- # not autotools, so call configure directly
- ./configure --cc="$(tc-getCC)" \
- --prefix="${EPREFIX}/usr" \
- --libdir="${EPREFIX}/usr/$(get_libdir)" \
- --docdir="${EPREFIX}/usr/share/doc/${PF}"
-}
-
-src_compile() {
- emake AR="$(tc-getAR)"
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- dodoc Changelog README TODO VERSION
- #dohtml tcc-doc.html
- exeinto /usr/share/doc/${PF}/examples
- doexe examples/ex*.c
-}
-
-src_test() {
- # this is using tcc bits that don't know as-needed etc.
- TCCFLAGS="" emake test
-}