summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-06-22 15:36:20 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-06-22 15:39:32 +0100
commitab0db23548a85d0e57d7578db139e4bde7d20ea6 (patch)
tree68f68700f6443b49cf22ba739a48fd7ecae8bc9d /dev-lang
parentsys-kernel/vanilla-sources: Automated version bump to {4.4.183,4.9.183,4.14.1... (diff)
downloadgentoo-ab0db23548a85d0e57d7578db139e4bde7d20ea6.tar.gz
gentoo-ab0db23548a85d0e57d7578db139e4bde7d20ea6.tar.bz2
gentoo-ab0db23548a85d0e57d7578db139e4bde7d20ea6.zip
dev-lang/mmix: block against media-sound/mmix, bug #426874
Reported-by: Diego Elio Pettenò Bug: https://bugs.gentoo.org/426874 Package-Manager: Portage-2.3.67, Repoman-2.3.15 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/mmix/mmix-20160804-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-lang/mmix/mmix-20160804-r1.ebuild b/dev-lang/mmix/mmix-20160804-r1.ebuild
new file mode 100644
index 000000000000..3d8f806d1bb8
--- /dev/null
+++ b/dev-lang/mmix/mmix-20160804-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Donald Knuth's MMIX Assembler and Simulator"
+HOMEPAGE="https://www-cs-faculty.stanford.edu/~knuth/mmix.html http://mmix.cs.hm.edu"
+SRC_URI="http://mmix.cs.hm.edu/src/${P}.tgz"
+
+DEPEND="virtual/tex-base
+ doc? ( dev-texlive/texlive-plaingeneric )"
+# media-sound/mmix and dev-lang/mmix both install 'mmix' binary, bug #426874
+RDEPEND="!!media-sound/mmix"
+
+SLOT="0"
+LICENSE="${PN}"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+S="${WORKDIR}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-20110420-makefile.patch
+ "${FILESDIR}"/${PN}-20131017-format-security.patch
+)
+
+src_compile() {
+ export VARTEXFONTS=${T}/fonts
+ emake all \
+ CFLAGS="${CFLAGS}" \
+ CC="$(tc-getCC)"
+
+ if use doc ; then
+ emake doc
+ fi
+}
+
+src_install() {
+ dobin ${PN} ${PN}al m${PN} mmotype abstime
+ dodoc README ${PN}.1
+
+ if use doc ; then
+ insinto /usr/share/doc/${PF}
+ doins *.ps
+ fi
+}