summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2020-09-14 18:09:21 +0200
committerKeri Harris <keri@gentoo.org>2020-09-14 18:09:40 +0200
commitb0f66d83976eedc5f6dc6a37c2296a95d063f9c8 (patch)
treea8f962a4bbb2c2a3af97c2d21369027d6152247a /dev-lang
parentgui-apps/waybar: style fixups (diff)
downloadgentoo-b0f66d83976eedc5f6dc6a37c2296a95d063f9c8.tar.gz
gentoo-b0f66d83976eedc5f6dc6a37c2296a95d063f9c8.tar.bz2
gentoo-b0f66d83976eedc5f6dc6a37c2296a95d063f9c8.zip
dev-lang/mercury: avoid ICE when compiling Mercury trail grades
Package-Manager: Portage-3.0.4, Repoman-2.3.22 Signed-off-by: Keri Harris <keri@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/mercury/mercury-20.06.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-lang/mercury/mercury-20.06.ebuild b/dev-lang/mercury/mercury-20.06.ebuild
index 0eb603a48829..3757ae56109d 100644
--- a/dev-lang/mercury/mercury-20.06.ebuild
+++ b/dev-lang/mercury/mercury-20.06.ebuild
@@ -68,6 +68,11 @@ src_compile() {
echo "EXTRA_LD_LIBFLAGS = ${LDFLAGS}" >> Mmake.params
echo "EXTRA_MLFLAGS = --no-strip" >> Mmake.params
+ if use trail; then
+ echo "CFLAGS-int = -O0" >> Mmake.params
+ echo "CFLAGS-uint = -O0" >> Mmake.params
+ fi
+
echo "EXTRA_LD_LIBFLAGS += -Wl,-soname=libgc.so" >> boehm_gc/Mmake.boehm_gc.params
echo "EXTRA_LD_LIBFLAGS += -Wl,-soname=libmer_rt.so" >> runtime/Mmake.runtime.params
echo "EXTRA_LD_LIBFLAGS += -Wl,-soname=libmer_std.so" >> library/Mmake.library.params