summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-11-30 22:53:25 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-11-30 22:53:36 +0000
commitb435de6c181413d73aa1e94f4f9de76e9adaaeee (patch)
tree032c18a922aadec74814eddd3a3774437f082190 /dev-lang
parentnet-misc/youtube-dl: Old. (diff)
downloadgentoo-b435de6c181413d73aa1e94f4f9de76e9adaaeee.tar.gz
gentoo-b435de6c181413d73aa1e94f4f9de76e9adaaeee.tar.bz2
gentoo-b435de6c181413d73aa1e94f4f9de76e9adaaeee.zip
dev-lang/mono: fix makedev() declaration on glibc-2.24
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/mono/files/mono-4.8.0.371-makedev.patch34
-rw-r--r--dev-lang/mono/mono-4.8.0.371.ebuild6
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-lang/mono/files/mono-4.8.0.371-makedev.patch b/dev-lang/mono/files/mono-4.8.0.371-makedev.patch
new file mode 100644
index 000000000000..7a4a44b3e72d
--- /dev/null
+++ b/dev-lang/mono/files/mono-4.8.0.371-makedev.patch
@@ -0,0 +1,34 @@
+https://bugs.gentoo.org/575232
+diff --git a/configure.ac b/configure.ac
+index fa5977b..2832c69 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -416,6 +416,10 @@ AC_HEADER_STDC
+ AC_LIBTOOL_WIN32_DLL
+ # This causes monodis to not link correctly
+ #AC_DISABLE_FAST_INSTALL
++
++#lookup makedev() header
++AC_HEADER_MAJOR
++
+ AM_PROG_LIBTOOL
+ # Use dolt (http://dolt.freedesktop.org/) instead of libtool for building.
+ DOLT
+diff --git a/mono/io-layer/processes.c b/mono/io-layer/processes.c
+index 53c271a..7ff8d03 100644
+--- a/mono/io-layer/processes.c
++++ b/mono/io-layer/processes.c
+@@ -45,6 +45,13 @@
+ #include <utime.h>
+ #endif
+
++/* makedev() macro */
++#ifdef MAJOR_IN_MKDEV
++#include <sys/mkdev.h>
++#elif defined MAJOR_IN_SYSMACROS
++#include <sys/sysmacros.h>
++#endif
++
+ /* sys/resource.h (for rusage) is required when using osx 10.3 (but not 10.4) */
+ #ifdef __APPLE__
+ #include <TargetConditionals.h>
diff --git a/dev-lang/mono/mono-4.8.0.371.ebuild b/dev-lang/mono/mono-4.8.0.371.ebuild
index fa00af0ed76b..4a4e5123ef82 100644
--- a/dev-lang/mono/mono-4.8.0.371.ebuild
+++ b/dev-lang/mono/mono-4.8.0.371.ebuild
@@ -4,7 +4,7 @@
EAPI=6
-inherit eutils linux-info mono-env flag-o-matic pax-utils versionator multilib-minimal
+inherit autotools eutils linux-info mono-env flag-o-matic pax-utils versionator multilib-minimal
DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
HOMEPAGE="http://www.mono-project.com/Main_Page"
@@ -33,6 +33,8 @@ DEPEND="${COMMONDEPEND}
!dev-lang/mono-basic
"
+PATCHES=("${FILESDIR}"/${PN}-4.8.0.371-makedev.patch)
+
S="${WORKDIR}/${PN}-$(get_version_component_range 1-3)"
pkg_pretend() {
@@ -73,6 +75,8 @@ src_prepare() {
#append-flags -fPIC
default
+ # PATCHES contains configure.ac patch
+ eautoreconf
multilib_copy_sources
}