summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2022-01-19 20:32:00 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-01-19 20:36:38 -0800
commitbff66eedb4ae530ef21187d617daeba5472320a1 (patch)
tree0e627b9ed1827f146286151c39f8d4899ac07d87 /dev-lang
parentapp-text/zathura: fix build with meson 0.61 (diff)
downloadgentoo-bff66eedb4ae530ef21187d617daeba5472320a1.tar.gz
gentoo-bff66eedb4ae530ef21187d617daeba5472320a1.tar.bz2
gentoo-bff66eedb4ae530ef21187d617daeba5472320a1.zip
dev-lang/rust: pass -fcf-protection=none on i586
while building for i586 targets we need to explicitly opt out of cet in internal llvm build. we don't even support bootstrapping this target right now as there is no self-hosting version, but may support in the future via our own tarball. Bug: https://bugs.gentoo.org/741708 Issue: https://github.com/rust-lang/rust/issues/93059 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/rust/rust-1.58.0.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-lang/rust/rust-1.58.0.ebuild b/dev-lang/rust/rust-1.58.0.ebuild
index 2b3cee83c811..05df5cfc5f9d 100644
--- a/dev-lang/rust/rust-1.58.0.ebuild
+++ b/dev-lang/rust/rust-1.58.0.ebuild
@@ -314,6 +314,14 @@ src_configure() {
targets = "${LLVM_TARGETS// /;}"
experimental-targets = ""
link-shared = $(toml_usex system-llvm)
+ $(case "${rust_target}" in
+ i586-*-linux-*)
+ # https://github.com/rust-lang/rust/issues/93059
+ echo 'cflags = "-fcf-protection=none"'
+ echo 'cxxflags = "-fcf-protection=none"'
+ echo 'ldflags = "-fcf-protection=none"'
+ ;;
+ esac)
[build]
build-stage = 2
test-stage = 2