summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-16 05:25:27 +0100
committerSam James <sam@gentoo.org>2021-10-16 05:25:27 +0100
commitce30bdc044eed3100d4e24a662ff91125a44e9e6 (patch)
tree2ee121ba81e9d96a5a155dc7bed25f385fb55399 /dev-lang
parentnet-libs/mbedtls: skip evaluation/development PSA tests (diff)
downloadgentoo-ce30bdc044eed3100d4e24a662ff91125a44e9e6.tar.gz
gentoo-ce30bdc044eed3100d4e24a662ff91125a44e9e6.tar.bz2
gentoo-ce30bdc044eed3100d4e24a662ff91125a44e9e6.zip
dev-lang/cfortran: add 20210827
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/cfortran/Manifest2
-rw-r--r--dev-lang/cfortran/cfortran-20210827.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-lang/cfortran/Manifest b/dev-lang/cfortran/Manifest
index 9add37c3da65..f800e5391758 100644
--- a/dev-lang/cfortran/Manifest
+++ b/dev-lang/cfortran/Manifest
@@ -1,4 +1,6 @@
DIST cfortran_20110621-1.debian.tar.xz 13352 BLAKE2B 0039dd4b5973e5cd13a136c51e8719ffa8e104db0d716cbd247fe440643dfce5308767d182abbcbafbd1de791e8cb4384c479660fe8b592477968d40c54078e8 SHA512 51387a17e4f69e5f5e53e188b5397a08d578aba42fdc446d4901e59be32bb0e5f07d871daa809e9de6051b4d9213b4312e25f70970db9173e4f33a0e66b4b44b
DIST cfortran_20110621.orig.tar.gz 129061 BLAKE2B 16c0cae1675923c1f6f13fe5a2a65ff86a2a80e4b3c3956c04cbc2df562dad8426b90c8a3a34919c28a7bee29f7430ffe8b415e28a484421aa8f58430456b934 SHA512 59b4285bb5392916880503bdd1cead5602944ebbf615d3c40bb7232770d6a74d3138a0b2abbab4fed9ea9bd2a56b2d3097d9609833c07d773dc43b8be0a3258a
+DIST cfortran_20210827-1.debian.tar.xz 8096 BLAKE2B 719b9cda29149e88342a54931af7f3b85a3cccc5dd5c573d9cce24fd67975141062fa538243ad40cb259464a53f3c77280a6097f01cb67f49b5e650cf49ab78f SHA512 86eb0692679dc0f3ec06d5f8c36c2ba242a52a01eb9bf1f9830dd2a689014ab2f0733c2c6210033e982d644bc4babf8420354f05079dfed30361a822b62aa845
+DIST cfortran_20210827.orig.tar.gz 94493 BLAKE2B 9ba0a22d1231702d04e484c21b566967a44684691fe08f7dc156e7b58946ab72694040e1513d51754993f82c4b80e58b365c25ad99acfb875cd2bf5db29dd7f6 SHA512 df12086f7718d205f3d0e40fafc1584339020e2be8ce5a96a314448018eac8d76fa7ae888c353e36f10e7347add609c2fe00558ec369e0ede2580973c21e5963
DIST cfortran_4.4-14.diff.gz 23084 BLAKE2B 8e760b3697869c12e94925c4781318fbe7640f0563a2464bf5d9f51a4afcb4bf9c281bab189542f2342d6dbc6f5524b4a48d9f844459d190e9182a96ebefbf9b SHA512 1e0b267efc17c2ba30ca1108d59ef87d1a401e6b88bea2c7045458f8cfad6ec9a05f6bf4a08c1d6cb314c790a4969a1f0fdf0c7b6abc28bae544928aad5b0218
DIST cfortran_4.4.orig.tar.gz 120119 BLAKE2B df4e0650e2718ed0c2009fb1b85330266308b0b584fcdc85e08cad0913bf063ab38824724b43a005a63a6e6bd5152b35115a68659487a992b96d0d38792e6d0a SHA512 969d0db566ecd7ed7945cac7f8ceea1cbd94ab427734ba83882acf97022c83b1417e32515d847fee89144137f58f7041cf5164fc397f3d7526f3aa958f8b038c
diff --git a/dev-lang/cfortran/cfortran-20210827.ebuild b/dev-lang/cfortran/cfortran-20210827.ebuild
new file mode 100644
index 000000000000..d389fc9ca6b7
--- /dev/null
+++ b/dev-lang/cfortran/cfortran-20210827.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+FORTRAN_NEEDED=test
+
+inherit autotools fortran-2
+
+DEB_PR="1"
+
+# https://github.com/bastien-roucaries/cfortran is for the Debian fork
+DESCRIPTION="Header file allowing to call Fortran routines from C and C++"
+HOMEPAGE="https://www-zeus.desy.de/~burow/cfortran/ https://github.com/bastien-roucaries/cfortran"
+SRC_URI="mirror://debian/pool/main/c/${PN}/${PN}_${PV}.orig.tar.gz"
+SRC_URI+=" mirror://debian/pool/main/c/${PN}/${PN}_${PV}-${DEB_PR}.debian.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ default
+
+ if [[ -d "${WORKDIR}"/debian/patches ]] ; then
+ eapply "${WORKDIR}"/debian/patches/
+ fi
+
+ eautoreconf
+
+ if use examples; then
+ # The examples are also used as tests and it's tricky to clean up
+ # afterwards, just save a clean copy (sans Makefiles, as they only
+ # cover the test phase) before the tests are run.
+ cp -ar eg eg_src || die "Failed to preserve a clean copy of examples"
+ rm -f eg_src/Makefile{,.am,.in}
+ fi
+}
+
+src_install() {
+ default
+
+ # For compatibility with older versions
+ dodir /usr/include/cfortran
+ dosym -r /usr/include/cfortran.h /usr/include/cfortran/cfortran.h
+
+ docinto debian
+ dodoc "${WORKDIR}"/debian/{NEWS,changelog,copyright}
+
+ if use examples; then
+ docinto examples
+ dodoc -r cfortest.c cfortex.f eg_src/*
+ fi
+}