summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-04-10 14:23:15 +0200
committerMichał Górny <mgorny@gentoo.org>2016-04-10 14:33:59 +0200
commitd0e4e349084fb85652f9186a4e1dc12f9a000474 (patch)
treedb640c7c8e4c0da83ac7adf91579214d77ab1c18 /dev-lang
parentsci-geosciences/mapnik: remove old (diff)
downloadgentoo-d0e4e349084fb85652f9186a4e1dc12f9a000474.tar.gz
gentoo-d0e4e349084fb85652f9186a4e1dc12f9a000474.tar.bz2
gentoo-d0e4e349084fb85652f9186a4e1dc12f9a000474.zip
dev-lang/ekopath: Snapshot bump
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ekopath/Manifest1
-rw-r--r--dev-lang/ekopath/ekopath-6.0.756_p20160409-r1.ebuild63
-rw-r--r--dev-lang/ekopath/ekopath-6.0.756_p20160409-r100.ebuild74
3 files changed, 138 insertions, 0 deletions
diff --git a/dev-lang/ekopath/Manifest b/dev-lang/ekopath/Manifest
index 229fc1da9605..af2acd6cd773 100644
--- a/dev-lang/ekopath/Manifest
+++ b/dev-lang/ekopath/Manifest
@@ -5,3 +5,4 @@ DIST ekopath-2016-03-03-installer.run 57856781 SHA256 0db16cf44f38e170e80230e08c
DIST ekopath-2016-03-11-installer.run 57858541 SHA256 ff4dc9eca6c877a5a28e4249b783b742f2038d9e01fd1ad795bcbd5ad0059fa2 SHA512 339dd9cd2048629c4f1ef95e062b7029094b563cba9d078bebbd2b0d584da4840e3d824203767ee820da5dbd64b31dc1297529fe59ecdd028b1bad2dd602b3ed WHIRLPOOL ea7492fac3fffd611633d8b975fe73e2dcc3869d575de2fc5f9fc0e1694400e393f04728a63f372d2fd3f18a80ccb8d23ef518627e7d9474f4859b7d181af5ea
DIST ekopath-2016-03-16-installer.run 57139166 SHA256 051f93cbb809471abc611cabc670b2d91ab2944a8f09e19ba2a64a1c99b76074 SHA512 356ffc628078e5e524ac5962b3c23c22f8d81fc5c7916ab5707755b853a27a89b7e6677b832a8cc6568499b2852c5c7916b57bad70ee3c027a595eacb4074c96 WHIRLPOOL c7d85d9c5b99b9527b6ed2aa434dac8aa90c8aaff73fa8300d67ba573b1fd0570d7ff33494a89ea20a9075557c6a1f7030efaa2b3ed86f0b70b919000177cfa1
DIST ekopath-2016-03-24-installer.run 57140247 SHA256 4a1139432cd0eba1490bab6b18cb3d227e6b6ad9eb354be22a55b6914e436220 SHA512 314fb763972d53b9e0b95e02ff542deb663743185643a20845cca3d7098a264d857c6738e59c63490d1bbe7653d7fdd3e8463087c7755c8d0ae6bd73b53c308f WHIRLPOOL 83013389230b8cf1d5254822074e0bbdcf0de48e309900153fa5f58e2ab35d1f0577e1003d3f12ae34cbfe96ad77fa1d0b0d95f94c9d16b07381a49abb7ff6ac
+DIST ekopath-2016-04-09-installer.run 57165340 SHA256 ccdfe4aca6063d8cf885b3878b0ab12505aa765db081f4a0278e392f883dee46 SHA512 cdb8647d36ea8ca411cc2378d87c0a2edf34c834206905350a6cdde5ae0ed14f56f716ebb7ad28129b634088f94e0304c1cef3df1beaac38c3ccc87d5387dce0 WHIRLPOOL 299ac5494f17dc680a794f4cda3417e232c2fe6768df2ee5ba48356be0d929f7ed821b32b5e179c9fd0334081bcca61dddac577b6b8a63201723b1172f94a005
diff --git a/dev-lang/ekopath/ekopath-6.0.756_p20160409-r1.ebuild b/dev-lang/ekopath/ekopath-6.0.756_p20160409-r1.ebuild
new file mode 100644
index 000000000000..f71706c8bc6d
--- /dev/null
+++ b/dev-lang/ekopath/ekopath-6.0.756_p20160409-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit pax-utils versionator
+
+MY_PV=$(get_version_component_range 1-3)
+MY_P=${PN}-${MY_PV}
+DATE=$(get_version_component_range 4)
+DATE=${DATE#p}
+DATE=${DATE:0:4}-${DATE:4:2}-${DATE:6}
+INSTALLER=${PN}-${DATE}-installer.run
+
+DESCRIPTION="PathScale EKOPath Compiler Suite"
+HOMEPAGE="http://www.pathscale.com/ekopath-compiler-suite"
+SRC_URI="http://c591116.r16.cf2.rackcdn.com/${PN}/nightly/Linux/${INSTALLER}"
+
+LICENSE="all-rights-reserved"
+SLOT="${MY_PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="!!app-arch/rpm"
+RDEPEND="!dev-lang/ekopath:0/${MY_PV}"
+
+RESTRICT="bindist mirror"
+
+QA_PREBUILT="opt/${MY_P}/*"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}/${INSTALLER}" "${S}/" || die
+ chmod +x "${S}/${INSTALLER}" || die
+}
+
+src_install() {
+ # EI_PAX marking is obsolete and PT_PAX breaks the binary.
+ # We must use XT_PAX to run the installer.
+ if [[ ${PAX_MARKINGS} == "XT" ]]; then
+ pax-mark m "${INSTALLER}"
+ fi
+
+ ./"${INSTALLER}" \
+ --prefix "${ED%/}/opt/${MY_P}" \
+ --mode unattended || die
+
+ if [[ ! -d ${ED%/}/opt/${MY_P}/lib/${MY_PV} ]]; then
+ local guess
+ cd "${ED%/}/opt/${MY_P}/lib" && guess=( * )
+
+ if [[ ${guess[@]} ]]; then
+ die "Incorrect release version in PV, guessing it should be: ${guess[*]}"
+ else
+ die "No libdir installed"
+ fi
+ fi
+ [[ -x ${ED%}/opt/${MY_P}/bin/pathcc ]] || die "No pathcc executable was installed, your hardware is unsupported most likely"
+
+ rm -r "${ED}/opt/${MY_P}"/uninstall* || die
+}
diff --git a/dev-lang/ekopath/ekopath-6.0.756_p20160409-r100.ebuild b/dev-lang/ekopath/ekopath-6.0.756_p20160409-r100.ebuild
new file mode 100644
index 000000000000..6a39c1078870
--- /dev/null
+++ b/dev-lang/ekopath/ekopath-6.0.756_p20160409-r100.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit pax-utils versionator
+
+MY_PV=$(get_version_component_range 1-3)
+MY_P=${PN}-${MY_PV}
+DATE=$(get_version_component_range 4)
+DATE=${DATE#p}
+DATE=${DATE:0:4}-${DATE:4:2}-${DATE:6}
+INSTALLER=${PN}-${DATE}-installer.run
+
+DESCRIPTION="PathScale EKOPath Compiler Suite"
+HOMEPAGE="http://www.pathscale.com/ekopath-compiler-suite"
+SRC_URI="http://c591116.r16.cf2.rackcdn.com/${PN}/nightly/Linux/${INSTALLER}"
+
+LICENSE="all-rights-reserved"
+SLOT="0/${MY_PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="!!app-arch/rpm"
+RDEPEND="!dev-lang/ekopath:${MY_PV}"
+
+RESTRICT="bindist mirror"
+
+QA_PREBUILT="opt/${MY_P}/*"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}/${INSTALLER}" "${S}/" || die
+ chmod +x "${S}/${INSTALLER}" || die
+}
+
+src_configure() {
+ cat > 99${PN} <<-EOF || die
+ PATH=${EROOT%/}/opt/${PN}/bin
+ ROOTPATH=${EROOT%/}/opt/${PN}/bin
+ LDPATH=${EROOT%/}/opt/${PN}/lib:${EROOT%/}/opt/${PN}/lib/${MY_PV}/x8664/64
+ MANPATH=${EROOT%/}/opt/${PN}/docs/man
+ EOF
+}
+
+src_install() {
+ # EI_PAX marking is obsolete and PT_PAX breaks the binary.
+ # We must use XT_PAX to run the installer.
+ if [[ ${PAX_MARKINGS} == "XT" ]]; then
+ pax-mark m "${INSTALLER}"
+ fi
+
+ ./"${INSTALLER}" \
+ --prefix "${ED%/}/opt/${MY_P}" \
+ --mode unattended || die
+
+ if [[ ! -d ${ED%/}/opt/${MY_P}/lib/${MY_PV} ]]; then
+ local guess
+ cd "${ED%/}/opt/${MY_P}/lib" && guess=( * )
+
+ if [[ ${guess[@]} ]]; then
+ die "Incorrect release version in PV, guessing it should be: ${guess[*]}"
+ else
+ die "No libdir installed"
+ fi
+ fi
+ [[ -x ${ED%}/opt/${MY_P}/bin/pathcc ]] || die "No pathcc executable was installed, your hardware is unsupported most likely"
+
+ rm -r "${ED}/opt/${MY_P}"/uninstall* || die
+ dosym ${MY_P} /opt/${PN}
+ doenvd 99${PN}
+}