summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-29 19:21:07 +0000
committerSam James <sam@gentoo.org>2021-03-29 20:14:48 +0000
commitd7b186250b9c9173907974603885d48b00a65576 (patch)
treea466d1c8762e6ec293e57d417e874123c6e59a96 /dev-lang
parentx11-misc/projecteur: drop old version (diff)
downloadgentoo-d7b186250b9c9173907974603885d48b00a65576.tar.gz
gentoo-d7b186250b9c9173907974603885d48b00a65576.tar.bz2
gentoo-d7b186250b9c9173907974603885d48b00a65576.zip
dev-lang/mono: fix multilib non-native install by disabling AOT
Closes: https://bugs.gentoo.org/779025 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/mono/mono-6.12.0.122.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-lang/mono/mono-6.12.0.122.ebuild b/dev-lang/mono/mono-6.12.0.122.ebuild
index 2e2781d0640e..5c928b7089e4 100644
--- a/dev-lang/mono/mono-6.12.0.122.ebuild
+++ b/dev-lang/mono/mono-6.12.0.122.ebuild
@@ -90,6 +90,14 @@ multilib_src_configure() {
$(use_enable nls)
)
+ # Workaround(?) for bug #779025
+ # May be able to do a real fix by adjusting path used?
+ if multilib_is_native_abi ; then
+ myeconfargs+=( --enable-system-aot )
+ else
+ myeconfargs+=( --disable-system-aot )
+ fi
+
econf "${myeconfargs[@]}"
}