summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2020-04-02 11:36:49 +0200
committerKeri Harris <keri@gentoo.org>2020-04-02 11:38:23 +0200
commitde675aa379ca516c9fd09e49bdb3cea34eec11e4 (patch)
tree89006be7718e7dc513dd7679945b307c0122e626 /dev-lang
parentdev-python/django: Bump to 2.2.12 (diff)
downloadgentoo-de675aa379ca516c9fd09e49bdb3cea34eec11e4.tar.gz
gentoo-de675aa379ca516c9fd09e49bdb3cea34eec11e4.tar.bz2
gentoo-de675aa379ca516c9fd09e49bdb3cea34eec11e4.zip
dev-lang/mercury-extras: fix mercury lib search paths. Closes #715838
Signed-off-by: Keri Harris <keri@gentoo.org> Package-Manager: Portage-2.3.89, Repoman-2.3.11
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/mercury-extras/mercury-extras-20.01.1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-lang/mercury-extras/mercury-extras-20.01.1.ebuild b/dev-lang/mercury-extras/mercury-extras-20.01.1.ebuild
index 8a9593959aee..7595eae754b7 100644
--- a/dev-lang/mercury-extras/mercury-extras-20.01.1.ebuild
+++ b/dev-lang/mercury-extras/mercury-extras-20.01.1.ebuild
@@ -158,7 +158,7 @@ mercury_pkg_compile() {
mmake -j1 \
MLFLAGS=--no-strip \
CFLAGS="${CFLAGS}" \
- LD_LIBFLAGS="${LDFLAGS} -L/usr/$(get_libdir)" \
+ LD_LIBFLAGS="${LDFLAGS}" \
${mercury_mmc_target} || die "mmake ${mercury_pkg} failed"
}
@@ -183,7 +183,7 @@ mercury_pkg_install() {
mmake -j1 \
MLFLAGS=--no-strip \
CFLAGS="${CFLAGS}" \
- LD_LIBFLAGS="${LDFLAGS} -L/usr/$(get_libdir)" \
+ LD_LIBFLAGS="${LDFLAGS}" \
INSTALL_LIBDIR="${D}/usr/$(get_libdir)/mercury/extras" \
lib${mercury_pkg_name}.install || die "mmake ${mercury_pkg} failed"
fi