summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-01-14 13:51:19 +0100
committerDavid Seifert <soap@gentoo.org>2023-01-14 13:51:19 +0100
commited468028e725c9580a7b2ee02d6b7b9375f7a0b2 (patch)
tree3a39616d9a763db526cec9d2562da20ec1c456a8 /dev-lang
parentsci-mathematics/form: bump to 4.3.0 (diff)
downloadgentoo-ed468028e725c9580a7b2ee02d6b7b9375f7a0b2.tar.gz
gentoo-ed468028e725c9580a7b2ee02d6b7b9375f7a0b2.tar.bz2
gentoo-ed468028e725c9580a7b2ee02d6b7b9375f7a0b2.zip
*/*: remove py3.8 from PYTHON_COMPAT
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/gdl/gdl-1.0.1-r1.ebuild4
-rw-r--r--dev-lang/ghc/ghc-8.10.6-r1.ebuild4
-rw-r--r--dev-lang/ghc/ghc-9.0.2-r2.ebuild4
-rw-r--r--dev-lang/hy/hy-0.20.0.ebuild4
-rw-r--r--dev-lang/ispc/ispc-1.17.0-r2.ebuild4
-rw-r--r--dev-lang/ispc/ispc-1.18.0.ebuild2
-rw-r--r--dev-lang/jerryscript/jerryscript-2.4.0-r4.ebuild4
-rw-r--r--dev-lang/jsonnet/jsonnet-0.19.0-r1.ebuild4
-rw-r--r--dev-lang/jsonnet/jsonnet-0.19.1.ebuild4
-rw-r--r--dev-lang/python-exec/python-exec-2.4.10.ebuild4
-rw-r--r--dev-lang/qu-prolog/qu-prolog-10.6.ebuild4
-rw-r--r--dev-lang/qu-prolog/qu-prolog-10.7.ebuild4
-rw-r--r--dev-lang/rust/rust-1.65.0.ebuild4
-rw-r--r--dev-lang/rust/rust-1.66.1.ebuild2
-rw-r--r--dev-lang/spidermonkey/spidermonkey-102.6.0.ebuild4
-rw-r--r--dev-lang/spidermonkey/spidermonkey-78.15.0.ebuild4
-rw-r--r--dev-lang/spidermonkey/spidermonkey-91.13.0-r1.ebuild4
-rw-r--r--dev-lang/yap/yap-7.0.1.ebuild4
-rw-r--r--dev-lang/yap/yap-7.1.0.ebuild4
19 files changed, 36 insertions, 36 deletions
diff --git a/dev-lang/gdl/gdl-1.0.1-r1.ebuild b/dev-lang/gdl/gdl-1.0.1-r1.ebuild
index 07455093cffe..08bc06d11634 100644
--- a/dev-lang/gdl/gdl-1.0.1-r1.ebuild
+++ b/dev-lang/gdl/gdl-1.0.1-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
WX_GTK_VER="3.0-gtk3"
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit cmake python-single-r1 toolchain-funcs virtualx wxwidgets
diff --git a/dev-lang/ghc/ghc-8.10.6-r1.ebuild b/dev-lang/ghc/ghc-8.10.6-r1.ebuild
index 40a6e8f7868b..32dcc0691043 100644
--- a/dev-lang/ghc/ghc-8.10.6-r1.ebuild
+++ b/dev-lang/ghc/ghc-8.10.6-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,7 +13,7 @@ if [[ ${CTARGET} = ${CHOST} ]] ; then
fi
fi
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{9..10} )
inherit python-any-r1
inherit autotools bash-completion-r1 flag-o-matic ghc-package
inherit multilib multiprocessing pax-utils toolchain-funcs prefix
diff --git a/dev-lang/ghc/ghc-9.0.2-r2.ebuild b/dev-lang/ghc/ghc-9.0.2-r2.ebuild
index 363423eb235e..224ca5ec3652 100644
--- a/dev-lang/ghc/ghc-9.0.2-r2.ebuild
+++ b/dev-lang/ghc/ghc-9.0.2-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,7 +13,7 @@ if [[ ${CTARGET} = ${CHOST} ]] ; then
fi
fi
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{9..10} )
inherit python-any-r1
inherit autotools bash-completion-r1 flag-o-matic ghc-package
inherit multiprocessing pax-utils toolchain-funcs prefix
diff --git a/dev-lang/hy/hy-0.20.0.ebuild b/dev-lang/hy/hy-0.20.0.ebuild
index 81083bb93717..02ccc372ca88 100644
--- a/dev-lang/hy/hy-0.20.0.ebuild
+++ b/dev-lang/hy/hy-0.20.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_COMPAT=( python3_{9..10} )
inherit distutils-r1
diff --git a/dev-lang/ispc/ispc-1.17.0-r2.ebuild b/dev-lang/ispc/ispc-1.17.0-r2.ebuild
index 804e3471c52c..e61bd13adf34 100644
--- a/dev-lang/ispc/ispc-1.17.0-r2.ebuild
+++ b/dev-lang/ispc/ispc-1.17.0-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{9..10} )
LLVM_MAX_SLOT=14
inherit cmake python-any-r1 llvm
diff --git a/dev-lang/ispc/ispc-1.18.0.ebuild b/dev-lang/ispc/ispc-1.18.0.ebuild
index 0222c2396d5d..6f2ee56c5a5e 100644
--- a/dev-lang/ispc/ispc-1.18.0.ebuild
+++ b/dev-lang/ispc/ispc-1.18.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{9..10} )
LLVM_MAX_SLOT=14
inherit cmake python-any-r1 llvm
diff --git a/dev-lang/jerryscript/jerryscript-2.4.0-r4.ebuild b/dev-lang/jerryscript/jerryscript-2.4.0-r4.ebuild
index 53553aaabb7d..0664595d496f 100644
--- a/dev-lang/jerryscript/jerryscript-2.4.0-r4.ebuild
+++ b/dev-lang/jerryscript/jerryscript-2.4.0-r4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2021-2022 Gentoo Authors
+# Copyright 2021-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{9..10} )
inherit cmake python-single-r1
DESCRIPTION="Ultra-lightweight JavaScript engine for the Internet of Things"
diff --git a/dev-lang/jsonnet/jsonnet-0.19.0-r1.ebuild b/dev-lang/jsonnet/jsonnet-0.19.0-r1.ebuild
index 158665c276fc..71ae56d81023 100644
--- a/dev-lang/jsonnet/jsonnet-0.19.0-r1.ebuild
+++ b/dev-lang/jsonnet/jsonnet-0.19.0-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_OPTIONAL=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
inherit cmake toolchain-funcs flag-o-matic distutils-r1
diff --git a/dev-lang/jsonnet/jsonnet-0.19.1.ebuild b/dev-lang/jsonnet/jsonnet-0.19.1.ebuild
index 586f1b3b4915..c2eeb2521f6c 100644
--- a/dev-lang/jsonnet/jsonnet-0.19.1.ebuild
+++ b/dev-lang/jsonnet/jsonnet-0.19.1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_OPTIONAL=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
inherit cmake toolchain-funcs flag-o-matic distutils-r1
diff --git a/dev-lang/python-exec/python-exec-2.4.10.ebuild b/dev-lang/python-exec/python-exec-2.4.10.ebuild
index 1e2d60a1c74b..6fa6041405b7 100644
--- a/dev-lang/python-exec/python-exec-2.4.10.ebuild
+++ b/dev-lang/python-exec/python-exec-2.4.10.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
inherit python-any-r1
DESCRIPTION="Python script wrapper"
diff --git a/dev-lang/qu-prolog/qu-prolog-10.6.ebuild b/dev-lang/qu-prolog/qu-prolog-10.6.ebuild
index a805e8388a22..cc10e9da950d 100644
--- a/dev-lang/qu-prolog/qu-prolog-10.6.ebuild
+++ b/dev-lang/qu-prolog/qu-prolog-10.6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6..11} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit autotools multilib python-any-r1 qmake-utils
diff --git a/dev-lang/qu-prolog/qu-prolog-10.7.ebuild b/dev-lang/qu-prolog/qu-prolog-10.7.ebuild
index 707ab8e46073..9a5c4599174f 100644
--- a/dev-lang/qu-prolog/qu-prolog-10.7.ebuild
+++ b/dev-lang/qu-prolog/qu-prolog-10.7.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit autotools python-any-r1 qmake-utils
diff --git a/dev-lang/rust/rust-1.65.0.ebuild b/dev-lang/rust/rust-1.65.0.ebuild
index 632d1f35ebcb..bb793aa16865 100644
--- a/dev-lang/rust/rust-1.65.0.ebuild
+++ b/dev-lang/rust/rust-1.65.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit bash-completion-r1 check-reqs estack flag-o-matic llvm multiprocessing \
multilib multilib-build python-any-r1 rust-toolchain toolchain-funcs verify-sig
diff --git a/dev-lang/rust/rust-1.66.1.ebuild b/dev-lang/rust/rust-1.66.1.ebuild
index d7edce02ab0c..72b2df232530 100644
--- a/dev-lang/rust/rust-1.66.1.ebuild
+++ b/dev-lang/rust/rust-1.66.1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit bash-completion-r1 check-reqs estack flag-o-matic llvm multiprocessing \
multilib multilib-build python-any-r1 rust-toolchain toolchain-funcs verify-sig
diff --git a/dev-lang/spidermonkey/spidermonkey-102.6.0.ebuild b/dev-lang/spidermonkey/spidermonkey-102.6.0.ebuild
index 7d8a0709d1d4..a344baa4cc82 100644
--- a/dev-lang/spidermonkey/spidermonkey-102.6.0.ebuild
+++ b/dev-lang/spidermonkey/spidermonkey-102.6.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
@@ -9,7 +9,7 @@ SPIDERMONKEY_PATCHSET="spidermonkey-102-patches-04j.tar.xz"
LLVM_MAX_SLOT=15
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{9..11} )
PYTHON_REQ_USE="ssl,xml(+)"
WANT_AUTOCONF="2.1"
diff --git a/dev-lang/spidermonkey/spidermonkey-78.15.0.ebuild b/dev-lang/spidermonkey/spidermonkey-78.15.0.ebuild
index 8af327dd9b6e..e1b0b7fca8c6 100644
--- a/dev-lang/spidermonkey/spidermonkey-78.15.0.ebuild
+++ b/dev-lang/spidermonkey/spidermonkey-78.15.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -9,7 +9,7 @@ SPIDERMONKEY_PATCHSET="spidermonkey-78-patches-04.tar.xz"
LLVM_MAX_SLOT=14
-PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_COMPAT=( python3_{9..10} )
PYTHON_REQ_USE="ssl"
WANT_AUTOCONF="2.1"
diff --git a/dev-lang/spidermonkey/spidermonkey-91.13.0-r1.ebuild b/dev-lang/spidermonkey/spidermonkey-91.13.0-r1.ebuild
index 6221d9f6b500..250141098f5f 100644
--- a/dev-lang/spidermonkey/spidermonkey-91.13.0-r1.ebuild
+++ b/dev-lang/spidermonkey/spidermonkey-91.13.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
@@ -9,7 +9,7 @@ SPIDERMONKEY_PATCHSET="spidermonkey-91-patches-05j.tar.xz"
LLVM_MAX_SLOT=15
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{9..11} )
PYTHON_REQ_USE="ssl,xml(+)"
WANT_AUTOCONF="2.1"
diff --git a/dev-lang/yap/yap-7.0.1.ebuild b/dev-lang/yap/yap-7.0.1.ebuild
index fbb2e1d54c02..b132001c0d2e 100644
--- a/dev-lang/yap/yap-7.0.1.ebuild
+++ b/dev-lang/yap/yap-7.0.1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PV_COMMIT=5bebd8e3aae655690ddf33dfb32289766910fa25
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit cmake flag-o-matic python-single-r1
diff --git a/dev-lang/yap/yap-7.1.0.ebuild b/dev-lang/yap/yap-7.1.0.ebuild
index 918c059d79ea..20b46409d1cc 100644
--- a/dev-lang/yap/yap-7.1.0.ebuild
+++ b/dev-lang/yap/yap-7.1.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PV_COMMIT=77bb2ba5eadfb95b67abccd22b298cfb75dd3328
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit cmake flag-o-matic python-single-r1