summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-11 07:04:11 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-11 07:06:18 -0400
commitf40b8f3444f962cf41f8a8f677e5c3c6e8c9eacd (patch)
tree9a2f686e1d8cebca6be7dacc5d26409cf0ee7218 /dev-lang
parentdev-python/pytest-html: add 3.1.1 (diff)
downloadgentoo-f40b8f3444f962cf41f8a8f677e5c3c6e8c9eacd.tar.gz
gentoo-f40b8f3444f962cf41f8a8f677e5c3c6e8c9eacd.tar.bz2
gentoo-f40b8f3444f962cf41f8a8f677e5c3c6e8c9eacd.zip
dev-lang/ispc: remove upstreamed -Werror patch for live ebuild
Closes: https://bugs.gentoo.org/795294 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ispc/files/ispc-9999-werror.patch13
-rw-r--r--dev-lang/ispc/ispc-9999.ebuild1
2 files changed, 0 insertions, 14 deletions
diff --git a/dev-lang/ispc/files/ispc-9999-werror.patch b/dev-lang/ispc/files/ispc-9999-werror.patch
deleted file mode 100644
index 0e860a95de26..000000000000
--- a/dev-lang/ispc/files/ispc-9999-werror.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 13e66268..27ff8364 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -352,7 +352,7 @@ target_include_directories(${PROJECT_NAME} PRIVATE
- set_source_files_properties(${FLEX_OUTPUT} PROPERTIES COMPILE_FLAGS "/wd4005 /wd4003")
- set_source_files_properties(${BISON_OUTPUT} PROPERTIES COMPILE_FLAGS "/wd4005 /wd4065")
- else()
-- target_compile_options(${PROJECT_NAME} PRIVATE -Wall -Wno-sign-compare -Wno-unused-function -Werror ${LLVM_CPP_FLAGS})
-+ target_compile_options(${PROJECT_NAME} PRIVATE -Wall -Wno-sign-compare -Wno-unused-function ${LLVM_CPP_FLAGS})
- # The change implementing -Wno-unused-but-set-variable in clang was reverted, so commenting out for now.
- #if (${LLVM_VERSION_NUMBER} VERSION_GREATER_EQUAL "13.0.0")
- # set_source_files_properties(${BISON_CPP_OUTPUT} PROPERTIES COMPILE_FLAGS "-Wno-unused-but-set-variable")
diff --git a/dev-lang/ispc/ispc-9999.ebuild b/dev-lang/ispc/ispc-9999.ebuild
index 23b20156fd2b..8cc95c5d7497 100644
--- a/dev-lang/ispc/ispc-9999.ebuild
+++ b/dev-lang/ispc/ispc-9999.ebuild
@@ -37,7 +37,6 @@ BDEPEND="
PATCHES=(
"${FILESDIR}/${PN}-1.13.0-cmake-gentoo-release.patch"
"${FILESDIR}/${PN}-9999-llvm.patch"
- "${FILESDIR}/${PN}-9999-werror.patch"
)
CMAKE_BUILD_TYPE="RelWithDebInfo"