summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-01-14 00:19:18 +0100
committerJeroen Roovers <jer@gentoo.org>2019-01-14 01:04:53 +0100
commit50509dd21d74690f368892b196c1af6c6187f123 (patch)
tree5c422a67651daf030363dc0c5e5fda0825165bf2 /dev-libs/9libs/9libs-1.0-r4.ebuild
parentdev-libs/9libs: Set CC in src_configure not src_compile (diff)
downloadgentoo-50509dd21d74690f368892b196c1af6c6187f123.tar.gz
gentoo-50509dd21d74690f368892b196c1af6c6187f123.tar.bz2
gentoo-50509dd21d74690f368892b196c1af6c6187f123.zip
dev-libs/9libs: Add USE=X,static-libs
Package-Manager: Portage-2.3.55, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'dev-libs/9libs/9libs-1.0-r4.ebuild')
-rw-r--r--dev-libs/9libs/9libs-1.0-r4.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-libs/9libs/9libs-1.0-r4.ebuild b/dev-libs/9libs/9libs-1.0-r4.ebuild
new file mode 100644
index 000000000000..84c7b9323a14
--- /dev/null
+++ b/dev-libs/9libs/9libs-1.0-r4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools toolchain-funcs
+
+DESCRIPTION="A package of Plan 9 compatibility libraries"
+HOMEPAGE="https://www.netlib.org/research/9libs/9libs-1.0.README"
+SRC_URI="https://www.netlib.org/research/9libs/${P}.tar.bz2"
+
+LICENSE="PLAN9"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs X"
+
+DEPEND="
+ X? (
+ >=x11-libs/libX11-1.0.0[static-libs?]
+ >=x11-libs/libXt-1.0.0[static-libs?]
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+DOCS=(
+ README
+)
+PATCHES=(
+ "${FILESDIR}"/${PN}-va_list.patch # Bug 385387
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with X x) \
+ --enable-shared \
+ --includedir=/usr/include/9libs
+}
+
+src_install() {
+ default
+
+ # rename some man pages to avoid collisions with dev-libs/libevent
+ local f
+ for f in add balloc bitblt cachechars event frame graphics rgbpix; do
+ mv "${D}"/usr/share/man/man3/${f}.{3,3g} || die
+ done
+
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die
+ fi
+}