summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2021-06-24 17:35:39 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-07-08 13:42:19 +0300
commitdc51531bfd51c2792c0855fc4168eed258ce6834 (patch)
tree0fbfdd644a43be9c915fc05c4e6ecad24f14a4d0 /dev-libs/OpenNI2/OpenNI2-9999.ebuild
parentdev-libs/OpenNI: remove obsolete (diff)
downloadgentoo-dc51531bfd51c2792c0855fc4168eed258ce6834.tar.gz
gentoo-dc51531bfd51c2792c0855fc4168eed258ce6834.tar.bz2
gentoo-dc51531bfd51c2792c0855fc4168eed258ce6834.zip
dev-libs/OpenNI2: min java 1.8
Bug: https://bugs.gentoo.org/787356 Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/OpenNI2/OpenNI2-9999.ebuild')
-rw-r--r--dev-libs/OpenNI2/OpenNI2-9999.ebuild22
1 files changed, 13 insertions, 9 deletions
diff --git a/dev-libs/OpenNI2/OpenNI2-9999.ebuild b/dev-libs/OpenNI2/OpenNI2-9999.ebuild
index 13ff01010ca9..210a3efeea3a 100644
--- a/dev-libs/OpenNI2/OpenNI2-9999.ebuild
+++ b/dev-libs/OpenNI2/OpenNI2-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -9,7 +9,7 @@ if [ "${PV#9999}" != "${PV}" ] ; then
EGIT_REPO_URI="https://github.com/occipital/openni2"
fi
-inherit ${SCM} toolchain-funcs epatch multilib java-pkg-opt-2 flag-o-matic
+inherit ${SCM} toolchain-funcs multilib java-pkg-opt-2 flag-o-matic
if [ "${PV#9999}" != "${PV}" ] ; then
SRC_URI=""
@@ -30,17 +30,20 @@ RDEPEND="
virtual/libudev
virtual/jpeg:0
opengl? ( media-libs/freeglut )
- java? ( >=virtual/jre-1.5:* )
+ java? ( virtual/jre:1.8 )
"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
- java? ( >=virtual/jdk-1.5:* )"
+ java? ( virtual/jdk:1.8 )"
+
+PATCHES=(
+ "${FILESDIR}/jpeg.patch"
+ "${FILESDIR}/rpath.patch"
+ "${FILESDIR}/soname.patch"
+)
src_prepare() {
- epatch \
- "${FILESDIR}/jpeg.patch" \
- "${FILESDIR}/rpath.patch" \
- "${FILESDIR}/soname.patch"
+ default
rm -rf ThirdParty/LibJPEG
for i in ThirdParty/PSCommon/BuildSystem/Platform.* ; do
@@ -85,7 +88,8 @@ src_install() {
dodoc CHANGES.txt NOTICE README.md ReleaseNotes.txt Source/Documentation/Text/*.txt
if use doc ; then
- dohtml -r "${S}/Source/Documentation/html/"*
+ docinto html
+ dodoc -r "${S}/Source/Documentation/html/"*
fi
dodir /usr/$(get_libdir)/pkgconfig