summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/OpenNI2/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/OpenNI2/files')
-rw-r--r--dev-libs/OpenNI2/files/jpeg.patch90
-rw-r--r--dev-libs/OpenNI2/files/libopenni2.pc.in10
-rw-r--r--dev-libs/OpenNI2/files/pthread.patch26
-rw-r--r--dev-libs/OpenNI2/files/rpath.patch13
-rw-r--r--dev-libs/OpenNI2/files/soname.patch13
5 files changed, 152 insertions, 0 deletions
diff --git a/dev-libs/OpenNI2/files/jpeg.patch b/dev-libs/OpenNI2/files/jpeg.patch
new file mode 100644
index 000000000000..e7f4f35ea7dd
--- /dev/null
+++ b/dev-libs/OpenNI2/files/jpeg.patch
@@ -0,0 +1,90 @@
+Index: OpenNI2-9999/Source/Core/Makefile
+===================================================================
+--- OpenNI2-9999.orig/Source/Core/Makefile
++++ OpenNI2-9999/Source/Core/Makefile
+@@ -5,14 +5,12 @@ BIN_DIR = ../../Bin
+ INC_DIRS = \
+ ../../Include \
+ ../../ThirdParty/PSCommon/XnLib/Include \
+- ../Drivers/OniFile/Formats \
+- ../../ThirdParty/LibJPEG
++ ../Drivers/OniFile/Formats
+
+ SRC_FILES = \
+ *.cpp \
+ ../Drivers/OniFile/Formats/XnCodec.cpp \
+- ../Drivers/OniFile/Formats/XnStreamCompression.cpp \
+- ../../ThirdParty/LibJPEG/*.c \
++ ../Drivers/OniFile/Formats/XnStreamCompression.cpp
+
+ ifeq ("$(OSTYPE)","Darwin")
+ INC_DIRS += /opt/local/include
+@@ -23,7 +21,7 @@ endif
+ LIB_NAME = OpenNI2
+
+ LIB_DIRS = ../../ThirdParty/PSCommon/XnLib/Bin/$(PLATFORM)-$(CFG)
+-USED_LIBS = XnLib dl pthread
++USED_LIBS = XnLib jpeg dl pthread
+ ifneq ("$(OSTYPE)","Darwin")
+ USED_LIBS += rt
+ endif
+Index: OpenNI2-9999/Source/Drivers/OniFile/Makefile
+===================================================================
+--- OpenNI2-9999.orig/Source/Drivers/OniFile/Makefile
++++ OpenNI2-9999/Source/Drivers/OniFile/Makefile
+@@ -6,14 +6,12 @@ INC_DIRS = \
+ . \
+ ../../../Include \
+ ../../../ThirdParty/PSCommon/XnLib/Include \
+- ../../../ThirdParty/LibJPEG \
+ Formats
+
+ SRC_FILES = \
+ *.cpp \
+ Formats/*.cpp \
+- XnLibExtensions/*.cpp \
+- ../../../ThirdParty/LibJPEG/*.c
++ XnLibExtensions/*.cpp
+
+
+ ifeq ("$(OSTYPE)","Darwin")
+@@ -25,7 +23,7 @@ endif
+ LIB_NAME = OniFile
+
+ LIB_DIRS = ../../../ThirdParty/PSCommon/XnLib/Bin/$(PLATFORM)-$(CFG)
+-USED_LIBS = XnLib pthread
++USED_LIBS = XnLib jpeg pthread
+ ifneq ("$(OSTYPE)","Darwin")
+ USED_LIBS += rt
+ endif
+Index: OpenNI2-9999/Source/Drivers/PS1080/Makefile
+===================================================================
+--- OpenNI2-9999.orig/Source/Drivers/PS1080/Makefile
++++ OpenNI2-9999/Source/Drivers/PS1080/Makefile
+@@ -7,7 +7,6 @@ INC_DIRS = \
+ Include \
+ ../../../Include \
+ ../../../ThirdParty/PSCommon/XnLib/Include \
+- ../../../ThirdParty/LibJPEG \
+ ../../DepthUtils
+
+ SRC_FILES = \
+@@ -16,8 +15,7 @@ SRC_FILES = \
+ DriverImpl/*.cpp\
+ Formats/*.cpp \
+ Include/*.cpp \
+- Sensor/*.cpp \
+- ../../../ThirdParty/LibJPEG/*.c
++ Sensor/*.cpp
+
+
+ ifeq ("$(OSTYPE)","Darwin")
+@@ -30,7 +28,7 @@ LIB_NAME = PS1080
+
+ LIB_DIRS += ../../../ThirdParty/PSCommon/XnLib/Bin/$(PLATFORM)-$(CFG)
+ LIB_DIRS += $(BIN_DIR)/$(PLATFORM)-$(CFG)
+-USED_LIBS = XnLib dl pthread DepthUtils
++USED_LIBS = XnLib jpeg dl pthread DepthUtils
+ ifneq ("$(OSTYPE)","Darwin")
+ USED_LIBS += rt usb-1.0 udev
+ else
diff --git a/dev-libs/OpenNI2/files/libopenni2.pc.in b/dev-libs/OpenNI2/files/libopenni2.pc.in
new file mode 100644
index 000000000000..550b13df60df
--- /dev/null
+++ b/dev-libs/OpenNI2/files/libopenni2.pc.in
@@ -0,0 +1,10 @@
+prefix=/usr
+exec_prefix=${prefix}
+libdir=${exec_prefix}/@libdir@
+includedir=${prefix}/include/openni2
+
+Name: OpenNI2
+Description: A general purpose driver for all OpenNI cameras.
+Version: @version@
+Cflags: -I${includedir}
+Libs: -L${libdir} -lOpenNI2 -L${libdir}/OpenNI2/Drivers -lDummyDevice -lOniFile -lPS1080
diff --git a/dev-libs/OpenNI2/files/pthread.patch b/dev-libs/OpenNI2/files/pthread.patch
new file mode 100644
index 000000000000..62d8a0c86789
--- /dev/null
+++ b/dev-libs/OpenNI2/files/pthread.patch
@@ -0,0 +1,26 @@
+commit 716cffb2888bb2a0fa3264a22085caf8ce26368f
+Author: Pedro Asad <pasad@cos.ufrj.br>
+Date: Wed Oct 8 18:18:57 2014 -0300
+
+ Added a missing -lpthread flag to one Makefile
+
+ The lack of the -lpthread flag on Source/Tools/NiViewer/Makefile prevented the
+ whole project from compiling correctly on Ubuntu 14.04 64 bit. Just added the
+ missing flag to this Makefile, according to the same solution for issue 47 of
+ the old OpenNI2 Github repository, that boils down to a similar problem and
+ can be found here, on Github
+ https://github.com/OpenNI/OpenNI2/issues/47
+
+diff --git a/Source/Tools/NiViewer/Makefile b/Source/Tools/NiViewer/Makefile
+index 1eba049..1b5714d 100644
+--- a/Source/Tools/NiViewer/Makefile
++++ b/Source/Tools/NiViewer/Makefile
+@@ -26,7 +26,7 @@ else
+ endif
+
+ LIB_DIRS += ../../../ThirdParty/PSCommon/XnLib/Bin/$(PLATFORM)-$(CFG)
+-USED_LIBS += OpenNI2 XnLib
++USED_LIBS += OpenNI2 XnLib pthread
+
+ EXE_NAME = NiViewer
+
diff --git a/dev-libs/OpenNI2/files/rpath.patch b/dev-libs/OpenNI2/files/rpath.patch
new file mode 100644
index 000000000000..9203733ee80e
--- /dev/null
+++ b/dev-libs/OpenNI2/files/rpath.patch
@@ -0,0 +1,13 @@
+Index: OpenNI2-9999/ThirdParty/PSCommon/BuildSystem/CommonCppMakefile
+===================================================================
+--- OpenNI2-9999.orig/ThirdParty/PSCommon/BuildSystem/CommonCppMakefile
++++ OpenNI2-9999/ThirdParty/PSCommon/BuildSystem/CommonCppMakefile
+@@ -93,8 +93,6 @@ ifneq "$(LIB_NAME)" ""
+ endif
+ ifneq "$(EXE_NAME)" ""
+ OUTPUT_NAME = $(EXE_NAME)
+- # We want the executables to look for the .so's locally first:
+- LDFLAGS += -Wl,-rpath ./
+ OUTPUT_COMMAND = $(CXX) -o $(OUTPUT_FILE) $(OBJ_FILES) $(LDFLAGS)
+ endif
+ ifneq "$(SLIB_NAME)" ""
diff --git a/dev-libs/OpenNI2/files/soname.patch b/dev-libs/OpenNI2/files/soname.patch
new file mode 100644
index 000000000000..248ac631af58
--- /dev/null
+++ b/dev-libs/OpenNI2/files/soname.patch
@@ -0,0 +1,13 @@
+Index: OpenNI2-9999/ThirdParty/PSCommon/BuildSystem/CommonCppMakefile
+===================================================================
+--- OpenNI2-9999.orig/ThirdParty/PSCommon/BuildSystem/CommonCppMakefile
++++ OpenNI2-9999/ThirdParty/PSCommon/BuildSystem/CommonCppMakefile
+@@ -84,7 +84,7 @@ ifneq "$(LIB_NAME)" ""
+ ifneq ("$(OSTYPE)","Darwin")
+ LDFLAGS += -Wl,--no-undefined
+ OUTPUT_NAME = lib$(LIB_NAME).so
+- OUTPUT_COMMAND = $(CXX) -o $(OUTPUT_FILE) $(OBJ_FILES) $(LDFLAGS) -shared
++ OUTPUT_COMMAND = $(CXX) -o $(OUTPUT_FILE) $(OBJ_FILES) -Wl,-soname,$(OUTPUT_NAME) $(LDFLAGS) -shared
+ else
+ LDFLAGS += -undefined error
+ OUTPUT_NAME = lib$(LIB_NAME).dylib