summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-01-12 23:22:20 +0000
committerJames Le Cuirot <chewi@gentoo.org>2016-01-12 23:23:08 +0000
commit7ca2e0ce77d6447536aa56d3bc047619c9d1abbc (patch)
treef12038a756e8dae2718f0c3fc4860bfae878cc87 /dev-libs/antlr-c/antlr-c-3.5.2.ebuild
parentprofiles: Update nginx useflag description (diff)
downloadgentoo-7ca2e0ce77d6447536aa56d3bc047619c9d1abbc.tar.gz
gentoo-7ca2e0ce77d6447536aa56d3bc047619c9d1abbc.tar.bz2
gentoo-7ca2e0ce77d6447536aa56d3bc047619c9d1abbc.zip
dev-libs/antlr-c: Version bump to 3.5.2
Adds multilib support. This version also includes important fixes for mysql-workbench. See bug #570600. Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-libs/antlr-c/antlr-c-3.5.2.ebuild')
-rw-r--r--dev-libs/antlr-c/antlr-c-3.5.2.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/dev-libs/antlr-c/antlr-c-3.5.2.ebuild b/dev-libs/antlr-c/antlr-c-3.5.2.ebuild
new file mode 100644
index 000000000000..3449cd48aa5d
--- /dev/null
+++ b/dev-libs/antlr-c/antlr-c-3.5.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils autotools multilib-minimal
+
+MY_PN="${PN%-c}"
+DESCRIPTION="The ANTLR3 C Runtime"
+HOMEPAGE="http://www.antlr3.org/"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}3/archive/${PV}.tar.gz -> ${MY_PN}-${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug debugger doc static-libs"
+
+DEPEND="doc? ( app-doc/doxygen[dot] )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_PN}3-${PV}/runtime/C"
+PATCHES=( "${FILESDIR}/3.5-cflags.patch" )
+MULTILIB_WRAPPED_HEADERS=( /usr/include/antlr3config.h )
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_prepare() {
+ default
+ sed -i '/^QUIET/s/NO/YES/' doxyfile || die
+ eautoreconf
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local econfargs=(
+ --enable-shared
+ $(use_enable debug debuginfo)
+ $(use_enable debugger antlrdebug)
+ $(use_enable static-libs static)
+ )
+
+ case "${ABI}" in
+ *64*) econfargs+=( --enable-64bit ) ;;
+ *) econfargs+=( --disable-64bit ) ;;
+ esac
+
+ econf "${econfargs[@]}"
+}
+
+src_compile() {
+ multilib-minimal_src_compile
+
+ if use doc; then
+ einfo "Generating API documentation ..."
+ cd "${S}" || die
+ doxygen -u doxyfile || die
+ doxygen doxyfile || die
+ fi
+}
+
+src_install() {
+ multilib-minimal_src_install
+ prune_libtool_files
+ use doc && dohtml -r "${S}/api/"
+}