summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/antlr-c
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/antlr-c')
-rw-r--r--dev-libs/antlr-c/Manifest1
-rw-r--r--dev-libs/antlr-c/antlr-c-3.5.ebuild66
-rw-r--r--dev-libs/antlr-c/files/antlr-c-3.3-cflags.patch14
-rw-r--r--dev-libs/antlr-c/metadata.xml13
4 files changed, 94 insertions, 0 deletions
diff --git a/dev-libs/antlr-c/Manifest b/dev-libs/antlr-c/Manifest
new file mode 100644
index 000000000000..7218aff34540
--- /dev/null
+++ b/dev-libs/antlr-c/Manifest
@@ -0,0 +1 @@
+DIST antlr-3.5.tar.gz 6791279 SHA256 6be17690f782c899cda68be812df5c40911aed057bf0192b0c37d2711cba8fc8 SHA512 a7014bc5d178add8a1f8e44a19ec60fed934f79f38fd702c7d7c3bb6a8c803492063911f86a445b696d10956f6f902144a5244046e83d70cffdc1717400c38a7 WHIRLPOOL c364d9ffac34de2e80a04233c73cab54b468eb958d924a305ccfc534587996edd4ee78a8fbb9416f2cad404dc43f44da9f9717e32e3f33da900c450c41a046ea
diff --git a/dev-libs/antlr-c/antlr-c-3.5.ebuild b/dev-libs/antlr-c/antlr-c-3.5.ebuild
new file mode 100644
index 000000000000..3ac3af37cca4
--- /dev/null
+++ b/dev-libs/antlr-c/antlr-c-3.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit autotools-utils eutils
+
+MY_P="antlr-${PV}"
+DESCRIPTION="The ANTLR3 C Runtime"
+HOMEPAGE="https://github.com/antlr/antlr3/tree/master/runtime/C"
+SRC_URI="https://github.com/antlr/antlr3/archive/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug debugger doc static-libs"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+S="${WORKDIR}/antlr3-${MY_P}/runtime/C"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+PATCHES=( "${FILESDIR}/${PN}-3.3-cflags.patch" )
+
+src_prepare() {
+ sed -i -e '/^QUIET/s/NO/YES/' doxyfile || die 'sed on doxyfile failed'
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ $(use_enable debug debuginfo)
+ $(use_enable debugger antlrdebug)
+ )
+ if use amd64 || use ia64; then
+ myeconfargs+=( --enable-64bit )
+ else
+ myeconfargs+=( --disable-64bit )
+ fi
+
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+
+ if use doc; then
+ einfo "Generating documentation API ..."
+ doxygen -u doxyfile
+ doxygen doxyfile || die "doxygen failed"
+ fi
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use doc; then
+ dohtml api/*
+ fi
+}
diff --git a/dev-libs/antlr-c/files/antlr-c-3.3-cflags.patch b/dev-libs/antlr-c/files/antlr-c-3.3-cflags.patch
new file mode 100644
index 000000000000..854513311827
--- /dev/null
+++ b/dev-libs/antlr-c/files/antlr-c-3.3-cflags.patch
@@ -0,0 +1,14 @@
+diff -ur libantlr3c-3.3-SNAPSHOT.old//configure.ac libantlr3c-3.3-SNAPSHOT/configure.ac
+--- libantlr3c-3.3-SNAPSHOT.old//configure.ac 2011-04-03 10:40:51.277000042 +0300
++++ libantlr3c-3.3-SNAPSHOT/configure.ac 2011-04-03 10:41:22.092000042 +0300
+@@ -134,8 +134,8 @@
+ ;;
+ esac
+
+-CFLAGS="$CCFLAGS64 $CPPCMNTFLAGS $OPTIMFLAGS $DEBUGFLAGS $WARNFLAGS"
+-AC_MSG_RESULT([$CFLAGS])
++AM_CFLAGS="$CCFLAGS64 $CPPCMNTFLAGS $OPTIMFLAGS $DEBUGFLAGS $WARNFLAGS"
++AC_MSG_RESULT([$AM_CFLAGS])
+ AC_SUBST([OBJECT_MODE])
+
+ AS_IF([test "x$enable_antlrdebug" = xno], [AC_DEFINE([ANTLR3_NODEBUGGER], [1], [Define if ANTLR debugger not required])], [])
diff --git a/dev-libs/antlr-c/metadata.xml b/dev-libs/antlr-c/metadata.xml
new file mode 100644
index 000000000000..de8439db372e
--- /dev/null
+++ b/dev-libs/antlr-c/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="debugger">Compiles debug info into the library</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">antlr/antlr3</remote-id>
+ </upstream>
+</pkgmetadata>