summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-01-09 12:55:46 +0200
committerMart Raudsepp <leio@gentoo.org>2020-01-09 12:56:15 +0200
commit63450d83b1b97b0de249f85f7130ffb07f1b28f0 (patch)
tree169671964536351ff850f6afdacb78646af36c57 /dev-libs/appstream-glib
parentdev-libs/libksba: Maintainer change (diff)
downloadgentoo-63450d83b1b97b0de249f85f7130ffb07f1b28f0.tar.gz
gentoo-63450d83b1b97b0de249f85f7130ffb07f1b28f0.tar.bz2
gentoo-63450d83b1b97b0de249f85f7130ffb07f1b28f0.zip
dev-libs/appstream-glib: bump to 0.7.16
Closes: https://bugs.gentoo.org/700808 Package-Manager: Portage-2.3.79, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-libs/appstream-glib')
-rw-r--r--dev-libs/appstream-glib/Manifest1
-rw-r--r--dev-libs/appstream-glib/appstream-glib-0.7.16.ebuild68
-rw-r--r--dev-libs/appstream-glib/files/0.7.16-fix-tests-run-in-2020.patch37
3 files changed, 106 insertions, 0 deletions
diff --git a/dev-libs/appstream-glib/Manifest b/dev-libs/appstream-glib/Manifest
index cdc084aafc6c..6355cb7c261a 100644
--- a/dev-libs/appstream-glib/Manifest
+++ b/dev-libs/appstream-glib/Manifest
@@ -1,2 +1,3 @@
DIST appstream-glib-0.7.15.tar.xz 2240040 BLAKE2B e1b58e0ce6523354490e529381302aa603e4ac1886c37e9c261ab612f76490ae4ea8fd22eff9c2bc1981d5ceb77ff8c4f8279e091dc62bd4df39d2c32623c1ea SHA512 bab0c73e54d90fbf22295f616d4a09332f94b90a3fa0cb38f1b654c6d9a459c9557dd81c677f486361dbf4f1dd23651306fe34b1cdd15254694269a8c9e8a927
+DIST appstream-glib-0.7.16.tar.xz 2243684 BLAKE2B 101a964822cc2421608e04a342b89248d16fff006c1843433f5db11703533fb7d0b2cb390d1e2f85274c51d0bd989502fc453700dfb9c32005a7b7c64cb59348 SHA512 a2991dbd26deeb1fb1daef1811c38ff5b55b2fae0bf2d8cc612c2e370613cb6b0468cf287ab3b575f6e6e3203aabcca12dd95474f70a54d6052a34dcb27b951b
DIST appstream-glib-0.7.9.tar.xz 2245728 BLAKE2B fb6f54329bed91f1acaa6218b111fd4527dff7ed412a89cb44a6e4f6cdfb7e0fe4e6f9fb37b6cdc2efa75164dccef323b6d7428a63b08369b941d36b0b9071f0 SHA512 d78cb6f11cad01d67cb33f16e987485177d20b78a8b21cfbabb64ce7b18b813c0d2d1de2faeea199fdc31d12633e899a5596a6cf133cb831a4377d641f79eb7d
diff --git a/dev-libs/appstream-glib/appstream-glib-0.7.16.ebuild b/dev-libs/appstream-glib/appstream-glib-0.7.16.ebuild
new file mode 100644
index 000000000000..ec8fc78191ff
--- /dev/null
+++ b/dev-libs/appstream-glib/appstream-glib-0.7.16.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit xdg meson
+
+DESCRIPTION="Provides GObjects and helper methods to read and write AppStream metadata"
+HOMEPAGE="https://people.freedesktop.org/~hughsient/appstream-glib/"
+SRC_URI="https://people.freedesktop.org/~hughsient/${PN}/releases/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/8" # soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="gtk-doc fonts +introspection stemmer"
+
+RDEPEND="
+ >=dev-libs/glib-2.45.8:2
+ sys-apps/util-linux
+ app-arch/libarchive
+ >=net-libs/libsoup-2.51.92:2.4
+ >=dev-libs/json-glib-1.1.2
+ >=x11-libs/gdk-pixbuf-2.31.5:2[introspection?]
+
+ fonts? ( x11-libs/gtk+:3
+ >=media-libs/freetype-2.4:2 )
+ >=media-libs/fontconfig-2.11:1.0
+ dev-libs/libyaml
+ stemmer? ( dev-libs/snowball-stemmer )
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+# libxml2 required for glib-compile-resources
+DEPEND="${RDEPEND}
+ dev-util/gperf
+
+ dev-libs/libxml2:2
+ app-text/docbook-xml-dtd:4.2
+ dev-libs/libxslt
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.9
+ app-text/docbook-xml-dtd:4.3
+ )
+ >=sys-devel/gettext-0.19.8
+"
+# ${PN} superseeds appdata-tools
+RDEPEND="${RDEPEND}
+ !<dev-util/appdata-tools-0.1.8-r1
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-fix-tests-run-in-2020.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ -Ddep11=true
+ -Dbuilder=true
+ -Drpm=false
+ -Dalpm=false
+ $(meson_use fonts)
+ $(meson_use stemmer)
+ -Dman=true
+ $(meson_use gtk-doc)
+ $(meson_use introspection)
+ )
+ meson_src_configure
+}
diff --git a/dev-libs/appstream-glib/files/0.7.16-fix-tests-run-in-2020.patch b/dev-libs/appstream-glib/files/0.7.16-fix-tests-run-in-2020.patch
new file mode 100644
index 000000000000..40ffe3edb6d1
--- /dev/null
+++ b/dev-libs/appstream-glib/files/0.7.16-fix-tests-run-in-2020.patch
@@ -0,0 +1,37 @@
+From 953c8e529d7291e60a95e580967ed79ce2c9ccf0 Mon Sep 17 00:00:00 2001
+From: Richard Hughes <richard@hughsie.com>
+Date: Mon, 6 Jan 2020 11:04:56 +0000
+Subject: [PATCH] trivial: Fix CI by moving 'future' back a bit
+
+2020 seemed like such a long time in the future all those years ago...
+---
+ data/tests/broken.appdata.xml | 2 +-
+ libappstream-glib/as-app-validate.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/data/tests/broken.appdata.xml b/data/tests/broken.appdata.xml
+index f7a5386e..cf80f5b4 100644
+--- a/data/tests/broken.appdata.xml
++++ b/data/tests/broken.appdata.xml
+@@ -40,7 +40,7 @@
+ <p>This is a duplicate release on the same day!</p>
+ </description>
+ </release>
+- <release date="2020-01-01" version="0.6.2">
++ <release date="2050-01-01" version="0.6.2">
+ <description>
+ <p>This is a release in the future!</p>
+ </description>
+diff --git a/libappstream-glib/as-app-validate.c b/libappstream-glib/as-app-validate.c
+index c1103ace..f50e4e41 100644
+--- a/libappstream-glib/as-app-validate.c
++++ b/libappstream-glib/as-app-validate.c
+@@ -864,7 +864,7 @@ as_app_validate_release (AsApp *app,
+ AS_PROBLEM_KIND_ATTRIBUTE_MISSING,
+ "<release> has no timestamp");
+ }
+- if (timestamp > 20120101 && timestamp < 20251231) {
++ if (timestamp > 20120101 && timestamp < 20351231) {
+ ai_app_validate_add (helper,
+ AS_PROBLEM_KIND_ATTRIBUTE_INVALID,
+ "<release> timestamp should be a UNIX time");