summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-01-14 11:12:37 +0100
committerJohannes Huber <johu@gentoo.org>2017-01-14 11:12:37 +0100
commitfa87e35f256a5f3b87ea3e7f1e7c2122cc470659 (patch)
tree846dc194e633fae099a9be3893e898c43caac1e3 /dev-libs/appstream/appstream-0.10.5.ebuild
parentdev-ruby/rspec: add ruby24 (diff)
downloadgentoo-fa87e35f256a5f3b87ea3e7f1e7c2122cc470659.tar.gz
gentoo-fa87e35f256a5f3b87ea3e7f1e7c2122cc470659.tar.bz2
gentoo-fa87e35f256a5f3b87ea3e7f1e7c2122cc470659.zip
dev-libs/appstream: New package
Import from kde overlay. Ebuild by me. Requuired for Plasma 5.9 + KDE Frameworks 5.30. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-libs/appstream/appstream-0.10.5.ebuild')
-rw-r--r--dev-libs/appstream/appstream-0.10.5.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-libs/appstream/appstream-0.10.5.ebuild b/dev-libs/appstream/appstream-0.10.5.ebuild
new file mode 100644
index 000000000000..55829e7de5e2
--- /dev/null
+++ b/dev-libs/appstream/appstream-0.10.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_AUTODEPS="false"
+KDE_TEST="true"
+inherit kde5
+
+if [[ ${KDE_BUILD_TYPE} = live ]]; then
+ EGIT_REPO_URI="https://github.com/ximion/${PN}"
+else
+ inherit versionator
+ MY_PV="$(replace_all_version_separators '_')"
+ MY_P="APPSTREAM_${MY_PV}"
+ SRC_URI="https://github.com/ximion/${PN}/archive/${MY_P}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${MY_P}"
+fi
+
+DESCRIPTION="Cross-distro effort for providing metadata for software in the Linux ecosystem"
+HOMEPAGE="https://www.freedesktop.org/wiki/Distributions/AppStream/"
+
+LICENSE="LGPL-2.1+ GPL-2+"
+# check APPSTREAM_LIB_API_LEVEL
+SLOT="0/4"
+IUSE="apt doc qt5"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/libxml2:2
+ dev-libs/libyaml
+ dev-libs/snowball-stemmer
+ qt5? ( dev-qt/qtcore:5 )
+"
+DEPEND="${RDEPEND}
+ dev-util/itstool
+ sys-devel/gettext
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DSTEMMING=ON
+ -DL18N=ON
+ -DVAPI=OFF
+ -DMAINTAINER=OFF
+ -DSANITIZERS=OFF
+ -DDOCUMENTATION=OFF
+ -DAPT_SUPPORT=$(usex apt)
+ -DINSTALL_PREBUILT_DOCS=$(usex doc)
+ -DQT=$(usex qt5)
+ )
+
+ kde5_src_configure
+}