summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@prydeworx.com>2020-12-08 08:52:44 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-12-13 12:50:20 +0200
commit7c7499b49249dde455f921a924bbea6e812a1e09 (patch)
tree4c7f1bcdd69f21da471bcfd7c6e87322f8ae97de /dev-libs/aws-c-common
parentdev-libs/jansson: remove dependency on sphinx < 3.0 (diff)
downloadgentoo-7c7499b49249dde455f921a924bbea6e812a1e09.tar.gz
gentoo-7c7499b49249dde455f921a924bbea6e812a1e09.tar.bz2
gentoo-7c7499b49249dde455f921a924bbea6e812a1e09.zip
dev-libs/aws-c-common: Version 0.4.62 Bump; Block cmake-3.19.{0,1}
This commit updates to version 0.4.62 with the following enhancements * Print CMake version when configuring. [0] * Re-adding SOVERSION to CMakeLists.txt [1] * Disabled MSVC 2015's non-constant aggregate initializer warning [2] * Do not use addr2line by default, backtrace_symbols will do the job [3] * Fixed memtrace/stack decoding test so it works more robustly * Removes an unnecessary API hopefully before anyone uses it externally Also block dev-util/cmake-3.19.0 and dev-util/cmake-3.19.1, which introduced a regression causing configure phase to fail. [4] [0] https://github.com/awslabs/aws-c-common/pull/701 [1] https://github.com/awslabs/aws-c-common/pull/702 [2] https://github.com/awslabs/aws-c-common/pull/738 [3] https://github.com/awslabs/aws-c-common/pull/739 [4] https://gitlab.kitware.com/cmake/cmake/-/issues/21529 Closes: https://bugs.gentoo.org/755932 Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Sven Eden <sven.eden@prydeworx.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/aws-c-common')
-rw-r--r--dev-libs/aws-c-common/Manifest1
-rw-r--r--dev-libs/aws-c-common/aws-c-common-0.4.62.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/aws-c-common/Manifest b/dev-libs/aws-c-common/Manifest
index 2b7630e5d4ae..5403e3469540 100644
--- a/dev-libs/aws-c-common/Manifest
+++ b/dev-libs/aws-c-common/Manifest
@@ -1 +1,2 @@
DIST aws-c-common-0.4.57.tar.gz 418954 BLAKE2B cfb268d92e90343e01756b571d0d7fa1269a144b933b5dfae6e5fb92a2b384ff73bf14ad830b53427ad37e9dbd9a0afff5b571108869a69a8d466982a2e6c6ef SHA512 77a9110a067e3057ae3cb90ee0b1fa42e18595e476b803f83711ecc164053db73683df2fccf75ad992b7d08e142cb31d6a70f87ce2f3b87ce28ee1e8151b3c62
+DIST aws-c-common-0.4.62.tar.gz 411263 BLAKE2B b9eb8eab8fceb949adcb96bc98987c318dcc70dae2cb8ecdcdf36c306be97158a64208c4bcc2452c83f03708cd7fb5401639558bc9bea946234f4b6b4c8eaec1 SHA512 7f31d739a3376404016bd509b40656d7620bddfb77a7f988306f2dcb2b03a03387855d845c2b9f63194d0bf2182a8d96392dba6c2bf847eaeb008115561d73ba
diff --git a/dev-libs/aws-c-common/aws-c-common-0.4.62.ebuild b/dev-libs/aws-c-common/aws-c-common-0.4.62.ebuild
new file mode 100644
index 000000000000..4d03853e528e
--- /dev/null
+++ b/dev-libs/aws-c-common/aws-c-common-0.4.62.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Core c99 package for AWS SDK for C"
+HOMEPAGE="https://github.com/awslabs/aws-c-common"
+SRC_URI="https://github.com/awslabs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs test"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ || ( <dev-util/cmake-3.19.0
+ >dev-util/cmake-3.19.1 )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4.57-remove-Werror-CFLAG.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=$(usex !static-libs)
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}