summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@prydeworx.com>2020-09-29 09:32:46 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-09-30 10:06:39 +0300
commitac980372dc0487ad5f8f773dba883bb7f32a679f (patch)
tree0df9f5f4afcac629b4ad4af6fec7dc704716222d /dev-libs/aws-c-common
parentdev-libs/libstrophe: state explicitly that testing is enabled (diff)
downloadgentoo-ac980372dc0487ad5f8f773dba883bb7f32a679f.tar.gz
gentoo-ac980372dc0487ad5f8f773dba883bb7f32a679f.tar.bz2
gentoo-ac980372dc0487ad5f8f773dba883bb7f32a679f.zip
dev-libs/aws-c-common: Remove -Werror from build FLAGS
Issue: dev-libs/aws-c-common-0.4.57 uses -Werror for build. Discovered on: amd64 (internal ref: ci) -Werror is not recommended for releases and should always be disabled when encountered in build-logs, because there are numerous cases where this breaks without purpose. Closes: https://bugs.gentoo.org/745093 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Sven Eden <sven.eden@prydeworx.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/aws-c-common')
-rw-r--r--dev-libs/aws-c-common/aws-c-common-0.4.57-r1.ebuild (renamed from dev-libs/aws-c-common/aws-c-common-0.4.57.ebuild)4
-rw-r--r--dev-libs/aws-c-common/files/aws-c-common-0.4.57-remove-Werror-CFLAG.patch11
2 files changed, 15 insertions, 0 deletions
diff --git a/dev-libs/aws-c-common/aws-c-common-0.4.57.ebuild b/dev-libs/aws-c-common/aws-c-common-0.4.57-r1.ebuild
index f12798d26684..120faea56d6a 100644
--- a/dev-libs/aws-c-common/aws-c-common-0.4.57.ebuild
+++ b/dev-libs/aws-c-common/aws-c-common-0.4.57-r1.ebuild
@@ -16,6 +16,10 @@ IUSE="static-libs test"
RESTRICT="!test? ( test )"
+PATCHES=(
+ "${FILESDIR}"/${P}-remove-Werror-CFLAG.patch
+)
+
src_configure() {
local mycmakeargs=(
-DBUILD_SHARED_LIBS=$(usex !static-libs)
diff --git a/dev-libs/aws-c-common/files/aws-c-common-0.4.57-remove-Werror-CFLAG.patch b/dev-libs/aws-c-common/files/aws-c-common-0.4.57-remove-Werror-CFLAG.patch
new file mode 100644
index 000000000000..767407062453
--- /dev/null
+++ b/dev-libs/aws-c-common/files/aws-c-common-0.4.57-remove-Werror-CFLAG.patch
@@ -0,0 +1,11 @@
+--- a/cmake/AwsCFlags.cmake 2020-09-29 09:19:28.820584526 +0200
++++ b/cmake/AwsCFlags.cmake 2020-09-29 09:19:36.068584784 +0200
+@@ -48,7 +48,7 @@
+ list(APPEND AWS_C_FLAGS "${_FLAGS}")
+
+ else()
+- list(APPEND AWS_C_FLAGS -Wall -Werror -Wstrict-prototypes)
++ list(APPEND AWS_C_FLAGS -Wall -Wstrict-prototypes)
+
+ if(NOT SET_PROPERTIES_NO_WEXTRA)
+ list(APPEND AWS_C_FLAGS -Wextra)