summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@prydeworx.com>2020-12-08 10:14:59 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-12-13 12:50:21 +0200
commit81e89e6f30ef16742a3cb4f61f8869eaf1f3d55c (patch)
tree1efa8e80ec2bbc6db95056a418692a78180e4dd2 /dev-libs/aws-c-io/files
parentdev-libs/s2n: C99 TLS/SSL, needed for dev-libs/aws-c-io (diff)
downloadgentoo-81e89e6f30ef16742a3cb4f61f8869eaf1f3d55c.tar.gz
gentoo-81e89e6f30ef16742a3cb4f61f8869eaf1f3d55c.tar.bz2
gentoo-81e89e6f30ef16742a3cb4f61f8869eaf1f3d55c.zip
dev-libs/aws-c-io: IO/TLS module, for dev-libs/aws-c-event-stream
This is a new dependency of dev-libs/aws-c-event-stream. Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Sven Eden <sven.eden@prydeworx.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/aws-c-io/files')
-rw-r--r--dev-libs/aws-c-io/files/aws-c-io-0.7.0-cmake-prefix.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/dev-libs/aws-c-io/files/aws-c-io-0.7.0-cmake-prefix.patch b/dev-libs/aws-c-io/files/aws-c-io-0.7.0-cmake-prefix.patch
new file mode 100644
index 000000000000..39cab922b3d9
--- /dev/null
+++ b/dev-libs/aws-c-io/files/aws-c-io-0.7.0-cmake-prefix.patch
@@ -0,0 +1,12 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -23,7 +23,7 @@ elseif(NOT DEFINED CMAKE_INSTALL_LIBDIR)
+ endif()
+
+ # This is required in order to append /lib/cmake to each element in CMAKE_PREFIX_PATH
+-set(AWS_MODULE_DIR "/${CMAKE_INSTALL_LIBDIR}/cmake")
++set(AWS_MODULE_DIR "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/cmake")
+ string(REPLACE ";" "${AWS_MODULE_DIR};" AWS_MODULE_PATH "${CMAKE_PREFIX_PATH}${AWS_MODULE_DIR}")
+ # Append that generated list to the module search path
+ list(APPEND CMAKE_MODULE_PATH ${AWS_MODULE_PATH})
+