summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@prydeworx.com>2020-12-14 21:10:07 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-01-05 11:06:29 +0200
commit0e81304b543febf538717b560e6cd821c6131a3e (patch)
tree873c18b24c17cdd5818a8c7eae7d403aa3d571c0 /dev-libs/aws-c-io
parentprofiles/base/package.use.mask: mask gdb[cet] (diff)
downloadgentoo-0e81304b543febf538717b560e6cd821c6131a3e.tar.gz
gentoo-0e81304b543febf538717b560e6cd821c6131a3e.tar.bz2
gentoo-0e81304b543febf538717b560e6cd821c6131a3e.zip
dev-libs/aws-c-io: Disable tests requiring an internet connection
Some of the tests require internet connectivity. On an offline machine these tests will therefore fail. As network sandboxing is enabled by default for years now, it is very unlikely that anybody would perform these tests anyway. Closes: https://bugs.gentoo.org/759802 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sven Eden <sven.eden@prydeworx.com> Closes: https://github.com/gentoo/gentoo/pull/18656 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/aws-c-io')
-rw-r--r--dev-libs/aws-c-io/aws-c-io-0.7.0-r1.ebuild (renamed from dev-libs/aws-c-io/aws-c-io-0.7.0.ebuild)12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-libs/aws-c-io/aws-c-io-0.7.0.ebuild b/dev-libs/aws-c-io/aws-c-io-0.7.0-r1.ebuild
index e3fbefde1310..3bae4a9f0357 100644
--- a/dev-libs/aws-c-io/aws-c-io-0.7.0.ebuild
+++ b/dev-libs/aws-c-io/aws-c-io-0.7.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -38,5 +38,15 @@ src_configure() {
-DBUILD_SHARED_LIBS=$(usex !static-libs)
-DBUILD_TESTING=$(usex test)
)
+
+ if use test; then
+ # (#759802) Due to network sandboxing of portage, internet connectivity
+ # tests will always fail. If you need a USE flag, because you want/need
+ # to perform these tests manually, please open a bug report for it.
+ mycmakeargs+=(
+ -DENABLE_NET_TESTS=OFF
+ )
+ fi
+
cmake_src_configure
}