summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@prydeworx.com>2020-09-29 10:53:02 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-09-30 10:06:44 +0300
commitd37df88ee5b07c4286698a8332f1893066a75217 (patch)
tree58381e5746e6ebcc7ce1bebb2c8b90211efe851f /dev-libs/aws-sdk-cpp/files
parentdev-libs/aws-c-event-stream: Remove 0.1.3, it is not needed anymore. (diff)
downloadgentoo-d37df88ee5b07c4286698a8332f1893066a75217.tar.gz
gentoo-d37df88ee5b07c4286698a8332f1893066a75217.tar.bz2
gentoo-d37df88ee5b07c4286698a8332f1893066a75217.zip
dev-libs/aws-sdk-cpp: Fix dependency and build FLAGS
* The dependency on dev-libs/aws-checkums has been fixed * The build system introduces -Werror into the build system, which has been removed. Closes: https://bugs.gentoo.org/745087 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Sven Eden <sven.eden@prydeworx.com> Closes: https://github.com/gentoo/gentoo/pull/17707 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/aws-sdk-cpp/files')
-rw-r--r--dev-libs/aws-sdk-cpp/files/aws-sdk-cpp-1.8.46-remove_Werror_from_FLAGS.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/aws-sdk-cpp/files/aws-sdk-cpp-1.8.46-remove_Werror_from_FLAGS.patch b/dev-libs/aws-sdk-cpp/files/aws-sdk-cpp-1.8.46-remove_Werror_from_FLAGS.patch
new file mode 100644
index 000000000000..9c8ff79e311e
--- /dev/null
+++ b/dev-libs/aws-sdk-cpp/files/aws-sdk-cpp-1.8.46-remove_Werror_from_FLAGS.patch
@@ -0,0 +1,30 @@
+--- a/cmake/compiler_settings.cmake 2020-09-29 10:15:14.293703615 +0200
++++ b/cmake/compiler_settings.cmake 2020-09-29 10:15:32.173704251 +0200
+@@ -53,7 +53,7 @@
+ endmacro()
+
+ macro(set_gcc_warnings)
+- list(APPEND AWS_COMPILER_WARNINGS "-Wall" "-Werror" "-pedantic" "-Wextra")
++ list(APPEND AWS_COMPILER_WARNINGS "-Wall" "-pedantic" "-Wextra")
+ if(COMPILER_CLANG)
+ if(PLATFORM_ANDROID)
+ # when using clang with libc and API lower than 21 we need to include Android support headers and ignore the gnu-include-next warning.
+--- a/cspell.json 2020-09-29 10:19:23.102712472 +0200
++++ b/cspell.json 2020-09-29 10:20:32.195714931 +0200
+@@ -11,7 +11,7 @@
+ // CMake
+ "cmake",
+ // Compiler and linker
+- "Wpedantic", "Wextra", "Werror", "xldscope", "Wtype", "Wunused",
++ "Wpedantic", "Wextra", "xldscope", "Wtype", "Wunused",
+ // Android NDK
+ "JNIEXPORT", "jint", "JNICALL", "jobject", "jclass", "jmethod", "Ljava",
+ // XML parser
+--- a/CI/install-test/CMakeLists.txt 2020-09-29 10:19:32.094712792 +0200
++++ b/CI/install-test/CMakeLists.txt 2020-09-29 10:19:46.064713289 +0200
+@@ -4,4 +4,4 @@
+ find_package(AWSSDK REQUIRED COMPONENTS s3)
+ add_executable(${PROJECT_NAME} "main.cpp")
+ target_link_libraries(${PROJECT_NAME} ${AWSSDK_LINK_LIBRARIES})
+-target_compile_options(${PROJECT_NAME} PRIVATE "-Wall" "-Werror")
++target_compile_options(${PROJECT_NAME} PRIVATE "-Wall")