summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuan Liao <liaoyuan@gmail.com>2021-12-20 07:56:10 -0800
committerMiroslav Šulc <fordfrog@gentoo.org>2022-01-19 10:21:06 +0100
commite13afd32c88258f381c8e35e2520201f18211b2d (patch)
tree6023478b476089a193a8db3fe48d9e1201837e65 /dev-libs/bitshuffle/bitshuffle-0.3.5.ebuild
parentdev-python/pytest-codeblocks: Add BDEP on pytest (diff)
downloadgentoo-e13afd32c88258f381c8e35e2520201f18211b2d.tar.gz
gentoo-e13afd32c88258f381c8e35e2520201f18211b2d.tar.bz2
gentoo-e13afd32c88258f381c8e35e2520201f18211b2d.zip
dev-libs/bitshuffle: Initial import
Signed-off-by: Yuan Liao <liaoyuan@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/23438/commits/2f68538368b6456bdd83fe9dd7b9b159bb850756 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-libs/bitshuffle/bitshuffle-0.3.5.ebuild')
-rw-r--r--dev-libs/bitshuffle/bitshuffle-0.3.5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/bitshuffle/bitshuffle-0.3.5.ebuild b/dev-libs/bitshuffle/bitshuffle-0.3.5.ebuild
new file mode 100644
index 000000000000..3a4dd5a7574d
--- /dev/null
+++ b/dev-libs/bitshuffle/bitshuffle-0.3.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Bitshuffle C library"
+HOMEPAGE="https://github.com/kiyo-masui/bitshuffle"
+SRC_URI="https://github.com/kiyo-masui/bitshuffle/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+DEPEND="
+ app-arch/lz4
+"
+
+src_prepare() {
+ cp "${FILESDIR}/${P}-Makefile" "Makefile" || die "Failed to copy Makefile"
+ default
+}
+
+src_configure() {
+ tc-export CC
+ export PACKAGE_VERSION="${PV}"
+}
+
+src_install() {
+ local prefix="${EPREFIX}/usr"
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="${prefix}" \
+ LIBDIR="${prefix}/$(get_libdir)" \
+ install
+}